%global _empty_manifest_terminate_build 0
Name: python-django-treebeard
Version: 4.6.1
Release: 1
Summary: Efficient tree implementations for Django
License: Apache License 2.0
URL: https://github.com/django-treebeard/django-treebeard/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/26/5b5f6161bdd16615f2b87083995a634a7270c1523a143a09665a7e177a77/django-treebeard-4.6.1.tar.gz
BuildArch: noarch
Requires: python3-Django
%description
# django-treebeard
**django-treebeard** is a library that implements efficient tree
implementations for the Django Web Framework 2.2 and later.
It is written by Gustavo Picón and licensed under the Apache License
2.0.
## Status
[](https://django-treebeard.readthedocs.io/en/latest/?badge=latest)
[]()
[](https://ci.appveyor.com/project/mvantellingen/django-treebeard)
[]()
[](https://pypi.org/project/django-treebeard/)
## Features
django-treebeard is:
- **Flexible**: Includes 3 different tree implementations with the
same API:
1. Adjacency List
2. Materialized Path
3. Nested Sets
- **Fast**: Optimized non-naive tree operations
- **Easy**: Uses Django Model Inheritance with abstract classes to
define your own models.
- **Clean**: Testable and well tested code base. Code/branch test
coverage is above 96%.
You can find the documentation in
>
### Supported versions
**django-treebeard** officially supports
- Django 3.2, 4.0, 4.1
- Python 3.8 - 3.11
- PostgreSQL, MySQL, MSSQL, SQLite database back-ends.
%package -n python3-django-treebeard
Summary: Efficient tree implementations for Django
Provides: python-django-treebeard
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-treebeard
# django-treebeard
**django-treebeard** is a library that implements efficient tree
implementations for the Django Web Framework 2.2 and later.
It is written by Gustavo Picón and licensed under the Apache License
2.0.
## Status
[](https://django-treebeard.readthedocs.io/en/latest/?badge=latest)
[]()
[](https://ci.appveyor.com/project/mvantellingen/django-treebeard)
[]()
[](https://pypi.org/project/django-treebeard/)
## Features
django-treebeard is:
- **Flexible**: Includes 3 different tree implementations with the
same API:
1. Adjacency List
2. Materialized Path
3. Nested Sets
- **Fast**: Optimized non-naive tree operations
- **Easy**: Uses Django Model Inheritance with abstract classes to
define your own models.
- **Clean**: Testable and well tested code base. Code/branch test
coverage is above 96%.
You can find the documentation in
>
### Supported versions
**django-treebeard** officially supports
- Django 3.2, 4.0, 4.1
- Python 3.8 - 3.11
- PostgreSQL, MySQL, MSSQL, SQLite database back-ends.
%package help
Summary: Development documents and examples for django-treebeard
Provides: python3-django-treebeard-doc
%description help
# django-treebeard
**django-treebeard** is a library that implements efficient tree
implementations for the Django Web Framework 2.2 and later.
It is written by Gustavo Picón and licensed under the Apache License
2.0.
## Status
[](https://django-treebeard.readthedocs.io/en/latest/?badge=latest)
[]()
[](https://ci.appveyor.com/project/mvantellingen/django-treebeard)
[]()
[](https://pypi.org/project/django-treebeard/)
## Features
django-treebeard is:
- **Flexible**: Includes 3 different tree implementations with the
same API:
1. Adjacency List
2. Materialized Path
3. Nested Sets
- **Fast**: Optimized non-naive tree operations
- **Easy**: Uses Django Model Inheritance with abstract classes to
define your own models.
- **Clean**: Testable and well tested code base. Code/branch test
coverage is above 96%.
You can find the documentation in
>
### Supported versions
**django-treebeard** officially supports
- Django 3.2, 4.0, 4.1
- Python 3.8 - 3.11
- PostgreSQL, MySQL, MSSQL, SQLite database back-ends.
%prep
%autosetup -n django-treebeard-4.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-treebeard -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 4.6.1-1
- Package Spec generated