%global _empty_manifest_terminate_build 0
Name:		python-hurry.filesize
Version:	0.9
Release:	1
Summary:	A simple Python library for human readable file sizes (or anything sized in bytes).
License:	ZPL 2.1
URL:		UNKNOWN
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ee/5e/16e17bedcf54d5b618dc0771690deda77178e5c310402881c3d2d6c5f27c/hurry.filesize-0.9.tar.gz
BuildArch:	noarch


%description
hurry.filesize a simple Python library that can take a number of bytes and
returns a human-readable string with the size in it, in kilobytes (K),
megabytes (M), etc.
The default system it uses is "traditional", where multipliers of 1024
increase the unit size::
  >>> from hurry.filesize import size
  >>> size(1024)
  '1K'
An alternative, slightly more verbose system::
  >>> from hurry.filesize import alternative
  >>> size(1, system=alternative)
  '1 byte'
  >>> size(10, system=alternative)
  '10 bytes'
  >>> size(1024, system=alternative)
  '1 KB'
A verbose system::
  >>> from hurry.filesize import verbose
  >>> size(10, system=verbose)
  '10 bytes'
  >>> size(1024, system=verbose)
  '1 kilobyte'
  >>> size(2000, system=verbose)
  '1 kilobyte'
  >>> size(3000, system=verbose)
  '2 kilobytes'
  >>> size(1024 * 1024, system=verbose)
  '1 megabyte'
  >>> size(1024 * 1024 * 3, system=verbose)
  '3 megabytes'
You can also use the SI system, where multipliers of 1000 increase the unit
size::
  >>> from hurry.filesize import si
  >>> size(1000, system=si)
  '1K'

%package -n python3-hurry.filesize
Summary:	A simple Python library for human readable file sizes (or anything sized in bytes).
Provides:	python-hurry.filesize
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-hurry.filesize
hurry.filesize a simple Python library that can take a number of bytes and
returns a human-readable string with the size in it, in kilobytes (K),
megabytes (M), etc.
The default system it uses is "traditional", where multipliers of 1024
increase the unit size::
  >>> from hurry.filesize import size
  >>> size(1024)
  '1K'
An alternative, slightly more verbose system::
  >>> from hurry.filesize import alternative
  >>> size(1, system=alternative)
  '1 byte'
  >>> size(10, system=alternative)
  '10 bytes'
  >>> size(1024, system=alternative)
  '1 KB'
A verbose system::
  >>> from hurry.filesize import verbose
  >>> size(10, system=verbose)
  '10 bytes'
  >>> size(1024, system=verbose)
  '1 kilobyte'
  >>> size(2000, system=verbose)
  '1 kilobyte'
  >>> size(3000, system=verbose)
  '2 kilobytes'
  >>> size(1024 * 1024, system=verbose)
  '1 megabyte'
  >>> size(1024 * 1024 * 3, system=verbose)
  '3 megabytes'
You can also use the SI system, where multipliers of 1000 increase the unit
size::
  >>> from hurry.filesize import si
  >>> size(1000, system=si)
  '1K'

%package help
Summary:	Development documents and examples for hurry.filesize
Provides:	python3-hurry.filesize-doc
%description help
hurry.filesize a simple Python library that can take a number of bytes and
returns a human-readable string with the size in it, in kilobytes (K),
megabytes (M), etc.
The default system it uses is "traditional", where multipliers of 1024
increase the unit size::
  >>> from hurry.filesize import size
  >>> size(1024)
  '1K'
An alternative, slightly more verbose system::
  >>> from hurry.filesize import alternative
  >>> size(1, system=alternative)
  '1 byte'
  >>> size(10, system=alternative)
  '10 bytes'
  >>> size(1024, system=alternative)
  '1 KB'
A verbose system::
  >>> from hurry.filesize import verbose
  >>> size(10, system=verbose)
  '10 bytes'
  >>> size(1024, system=verbose)
  '1 kilobyte'
  >>> size(2000, system=verbose)
  '1 kilobyte'
  >>> size(3000, system=verbose)
  '2 kilobytes'
  >>> size(1024 * 1024, system=verbose)
  '1 megabyte'
  >>> size(1024 * 1024 * 3, system=verbose)
  '3 megabytes'
You can also use the SI system, where multipliers of 1000 increase the unit
size::
  >>> from hurry.filesize import si
  >>> size(1000, system=si)
  '1K'

%prep
%autosetup -n hurry.filesize-0.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-hurry.filesize -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9-1
- Package Spec generated