%global _empty_manifest_terminate_build 0
Name:		python-td-client
Version:	1.2.1
Release:	1
Summary:	Treasure Data API library for Python
License:	Apache Software License
URL:		http://treasuredata.com/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/42/5c/2596a23fc20f15959685f05cad5f4f9bf7002a8e328aa7b1faf8544f7dc6/td-client-1.2.1.tar.gz
BuildArch:	noarch

Requires:	python3-msgpack
Requires:	python3-dateutil
Requires:	python3-urllib3
Requires:	python3-black
Requires:	python3-isort
Requires:	python3-flake8
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme

%description
Treasure Data API library for Python

%package -n python3-td-client
Summary:	Treasure Data API library for Python
Provides:	python-td-client
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-td-client
Treasure Data API library for Python

%package help
Summary:	Development documents and examples for td-client
Provides:	python3-td-client-doc
%description help
Treasure Data API library for Python

%prep
%autosetup -n td-client-1.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-td-client -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.1-1
- Package Spec generated