%global _empty_manifest_terminate_build 0
Name:		python-translate
Version:	3.6.1
Release:	1
Summary:	This is a simple, yet powerful command line translator with google translate behind it. You can also use it as a Python module in your code.
License:	MIT
URL:		https://github.com/terryyin/google-translate-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d1/9d/692066b9e26176a93ce627bf467bca48f198eb0e036337a5180d566c9561/translate-3.6.1.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-lxml
Requires:	python3-requests
Requires:	python3-libretranslatepy

%description


%package -n python3-translate
Summary:	This is a simple, yet powerful command line translator with google translate behind it. You can also use it as a Python module in your code.
Provides:	python-translate
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-translate


%package help
Summary:	Development documents and examples for translate
Provides:	python3-translate-doc
%description help


%prep
%autosetup -n translate-3.6.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-translate -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.6.1-1
- Package Spec generated