%global _empty_manifest_terminate_build 0
Name: python-pyPrivnote
Version: 0.0.1a1
Release: 1
Summary: A Python Interface to Privnote service
License: GPLv3+
URL: https://github.com/intelligentguy/pyPrivnote
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fe/63/43bf71ce0302248adac8845f511b93ecba3a4adef1b0d88c1e4341b6b09b/pyPrivnote-0.0.1a1.tar.gz
BuildArch: noarch
%description
# pyPrivnote
A Python Interface to Privnote service
#### [privnote.com](https://privnote.com): Send notes that will self-destruct after being read.
Privnote allows you to create one-time-pad encrypted, burn-after-reading notes over the internet. It's a great way to share passwords or other sensitive peices of information.
### Installation
```shell
pip install pyPrivnote
```
### Usage
Functions **create_note** and **read_note** thats all you need to use full functionality of Privnote
#### To make a simple note call function create_note.
```python
import pyPrivnote as pn
note_link = pn.create_note("Private message")
# "https://privnote.com/hl5R6EqM#UFgVC2UHD"
```
#### To read note call read_note with note link.
```python
note_text = pn.read_note(note_link)
# "Private message"
```
##### Making/reading notes with manual password.
```python
import pyPrivnote as pn
note_link = pn.create_note("Super secret message", manual_pass="12345")
# "https://privnote.com/w0q6kGlR"
note_text = pn.read_note(note_link, password="12345")
# "Super secret message"
```
#### Full functionality of privnote
**Manual password**
**E-mail notification** with _reference name_
Note **self-destructs** after reading or _expire lifetime_
**Asking confirmation** before reading _(only for web reading)_
```python
import pyPrivnote as pn
note_link = pn.create_note(
"Super secret message",
manual_pass="12345",
duration_hours=5,
ask_confirm=False,
notify_email="address@domain.com",
email_ref_name="Note sent to Bob"
)
```
#### Release History
v0.0.1 - First release
%package -n python3-pyPrivnote
Summary: A Python Interface to Privnote service
Provides: python-pyPrivnote
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyPrivnote
# pyPrivnote
A Python Interface to Privnote service
#### [privnote.com](https://privnote.com): Send notes that will self-destruct after being read.
Privnote allows you to create one-time-pad encrypted, burn-after-reading notes over the internet. It's a great way to share passwords or other sensitive peices of information.
### Installation
```shell
pip install pyPrivnote
```
### Usage
Functions **create_note** and **read_note** thats all you need to use full functionality of Privnote
#### To make a simple note call function create_note.
```python
import pyPrivnote as pn
note_link = pn.create_note("Private message")
# "https://privnote.com/hl5R6EqM#UFgVC2UHD"
```
#### To read note call read_note with note link.
```python
note_text = pn.read_note(note_link)
# "Private message"
```
##### Making/reading notes with manual password.
```python
import pyPrivnote as pn
note_link = pn.create_note("Super secret message", manual_pass="12345")
# "https://privnote.com/w0q6kGlR"
note_text = pn.read_note(note_link, password="12345")
# "Super secret message"
```
#### Full functionality of privnote
**Manual password**
**E-mail notification** with _reference name_
Note **self-destructs** after reading or _expire lifetime_
**Asking confirmation** before reading _(only for web reading)_
```python
import pyPrivnote as pn
note_link = pn.create_note(
"Super secret message",
manual_pass="12345",
duration_hours=5,
ask_confirm=False,
notify_email="address@domain.com",
email_ref_name="Note sent to Bob"
)
```
#### Release History
v0.0.1 - First release
%package help
Summary: Development documents and examples for pyPrivnote
Provides: python3-pyPrivnote-doc
%description help
# pyPrivnote
A Python Interface to Privnote service
#### [privnote.com](https://privnote.com): Send notes that will self-destruct after being read.
Privnote allows you to create one-time-pad encrypted, burn-after-reading notes over the internet. It's a great way to share passwords or other sensitive peices of information.
### Installation
```shell
pip install pyPrivnote
```
### Usage
Functions **create_note** and **read_note** thats all you need to use full functionality of Privnote
#### To make a simple note call function create_note.
```python
import pyPrivnote as pn
note_link = pn.create_note("Private message")
# "https://privnote.com/hl5R6EqM#UFgVC2UHD"
```
#### To read note call read_note with note link.
```python
note_text = pn.read_note(note_link)
# "Private message"
```
##### Making/reading notes with manual password.
```python
import pyPrivnote as pn
note_link = pn.create_note("Super secret message", manual_pass="12345")
# "https://privnote.com/w0q6kGlR"
note_text = pn.read_note(note_link, password="12345")
# "Super secret message"
```
#### Full functionality of privnote
**Manual password**
**E-mail notification** with _reference name_
Note **self-destructs** after reading or _expire lifetime_
**Asking confirmation** before reading _(only for web reading)_
```python
import pyPrivnote as pn
note_link = pn.create_note(
"Super secret message",
manual_pass="12345",
duration_hours=5,
ask_confirm=False,
notify_email="address@domain.com",
email_ref_name="Note sent to Bob"
)
```
#### Release History
v0.0.1 - First release
%prep
%autosetup -n pyPrivnote-0.0.1a1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyPrivnote -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.0.1a1-1
- Package Spec generated