%global _empty_manifest_terminate_build 0
Name: python-mypy-boto3
Version: 1.26.109
Release: 1
Summary: Type annotations for boto3 1.26.109 master module generated with mypy-boto3-builder 7.14.5
License: MIT License
URL: https://github.com/youtype/mypy_boto3_builder
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9a/d4/eb7b5132301eb5e99d59cff40aa3027192656356040a76162afc474dbdcb/mypy-boto3-1.26.109.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-typing-extensions
%description
# mypy-boto3
[![PyPI - mypy-boto3](https://img.shields.io/pypi/v/mypy-boto3.svg?color=blue)](https://pypi.org/project/mypy-boto3)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mypy-boto3.svg?color=blue)](https://pypi.org/project/mypy-boto3)
[![Docs](https://img.shields.io/readthedocs/boto3-stubs.svg?color=blue)](https://youtype.github.io/boto3_stubs_docs/)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/mypy-boto3?color=blue)](https://pypistats.org/packages/mypy-boto3)
![boto3.typed](https://github.com/youtype/mypy_boto3_builder/raw/main/logo.png)
Dynamic
[boto3 1.26.109](https://boto3.amazonaws.com/v1/documentation/api/1.26.109/index.html)
type annotations builder for
[boto3-stubs](https://pypi.org/project/boto3-stubs/).
Generated by
[mypy-boto3-builder 7.14.5](https://github.com/youtype/mypy_boto3_builder).
More information can be found on
[boto3-stubs](https://pypi.org/project/boto3-stubs/) page.
See how it helps to find and fix potential bugs:
![boto3-stubs demo](https://github.com/youtype/mypy_boto3_builder/raw/main/demo.gif)
- [mypy-boto3](#mypy-boto3)
- [How to install](#how-to-install)
- [Usage](#usage)
## How to install
```bash
# Install type annotations for boto3 services you use
python -m pip install 'boto3-stubs[s3,ec2]'
# Lite version does not provide session.client/resource overloads
# it is more RAM-friendly, but requires explicit type annotations
python -m pip install 'boto3-stubs-lite[s3,ec2]'
```
## Usage
This tool is not longer required for annotations to work. Do not use it,
install [boto3-stubs](https://pypi.org/project/boto3-stubs/) instead.
%package -n python3-mypy-boto3
Summary: Type annotations for boto3 1.26.109 master module generated with mypy-boto3-builder 7.14.5
Provides: python-mypy-boto3
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mypy-boto3
# mypy-boto3
[![PyPI - mypy-boto3](https://img.shields.io/pypi/v/mypy-boto3.svg?color=blue)](https://pypi.org/project/mypy-boto3)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mypy-boto3.svg?color=blue)](https://pypi.org/project/mypy-boto3)
[![Docs](https://img.shields.io/readthedocs/boto3-stubs.svg?color=blue)](https://youtype.github.io/boto3_stubs_docs/)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/mypy-boto3?color=blue)](https://pypistats.org/packages/mypy-boto3)
![boto3.typed](https://github.com/youtype/mypy_boto3_builder/raw/main/logo.png)
Dynamic
[boto3 1.26.109](https://boto3.amazonaws.com/v1/documentation/api/1.26.109/index.html)
type annotations builder for
[boto3-stubs](https://pypi.org/project/boto3-stubs/).
Generated by
[mypy-boto3-builder 7.14.5](https://github.com/youtype/mypy_boto3_builder).
More information can be found on
[boto3-stubs](https://pypi.org/project/boto3-stubs/) page.
See how it helps to find and fix potential bugs:
![boto3-stubs demo](https://github.com/youtype/mypy_boto3_builder/raw/main/demo.gif)
- [mypy-boto3](#mypy-boto3)
- [How to install](#how-to-install)
- [Usage](#usage)
## How to install
```bash
# Install type annotations for boto3 services you use
python -m pip install 'boto3-stubs[s3,ec2]'
# Lite version does not provide session.client/resource overloads
# it is more RAM-friendly, but requires explicit type annotations
python -m pip install 'boto3-stubs-lite[s3,ec2]'
```
## Usage
This tool is not longer required for annotations to work. Do not use it,
install [boto3-stubs](https://pypi.org/project/boto3-stubs/) instead.
%package help
Summary: Development documents and examples for mypy-boto3
Provides: python3-mypy-boto3-doc
%description help
# mypy-boto3
[![PyPI - mypy-boto3](https://img.shields.io/pypi/v/mypy-boto3.svg?color=blue)](https://pypi.org/project/mypy-boto3)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mypy-boto3.svg?color=blue)](https://pypi.org/project/mypy-boto3)
[![Docs](https://img.shields.io/readthedocs/boto3-stubs.svg?color=blue)](https://youtype.github.io/boto3_stubs_docs/)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/mypy-boto3?color=blue)](https://pypistats.org/packages/mypy-boto3)
![boto3.typed](https://github.com/youtype/mypy_boto3_builder/raw/main/logo.png)
Dynamic
[boto3 1.26.109](https://boto3.amazonaws.com/v1/documentation/api/1.26.109/index.html)
type annotations builder for
[boto3-stubs](https://pypi.org/project/boto3-stubs/).
Generated by
[mypy-boto3-builder 7.14.5](https://github.com/youtype/mypy_boto3_builder).
More information can be found on
[boto3-stubs](https://pypi.org/project/boto3-stubs/) page.
See how it helps to find and fix potential bugs:
![boto3-stubs demo](https://github.com/youtype/mypy_boto3_builder/raw/main/demo.gif)
- [mypy-boto3](#mypy-boto3)
- [How to install](#how-to-install)
- [Usage](#usage)
## How to install
```bash
# Install type annotations for boto3 services you use
python -m pip install 'boto3-stubs[s3,ec2]'
# Lite version does not provide session.client/resource overloads
# it is more RAM-friendly, but requires explicit type annotations
python -m pip install 'boto3-stubs-lite[s3,ec2]'
```
## Usage
This tool is not longer required for annotations to work. Do not use it,
install [boto3-stubs](https://pypi.org/project/boto3-stubs/) instead.
%prep
%autosetup -n mypy-boto3-1.26.109
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mypy-boto3 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.26.109-1
- Package Spec generated