%global _empty_manifest_terminate_build 0
Name: python-prsaw
Version: 0.4.0
Release: 1
Summary: PRSAW, an acronym for `Python Random Stuff API Wrapper`, is a wrapper for the Random Stuff API.
License: MIT
URL: https://github.com/CodeWithSwastik/prsaw
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/c2/bfb3ee30541a147cc05d0f206cbb33bf23165d7dbc10d5e9dbabd2f083d1/prsaw-0.4.0.tar.gz
BuildArch: noarch
%description
# PRSAW 0.4.0
[![Downloads](https://static.pepy.tech/personalized-badge/prsaw?period=total&units=international_system&left_color=green&right_color=orange&left_text=Downloads)](https://pepy.tech/project/prsaw)
PRSAW, an acronym for `Python Random Stuff API Wrapper`, is a wrapper for the [Random Stuff API](https://api.pgamerx.com/).
PyPI: https://pypi.org/project/prsaw/
## Installation
You can install released versions of prsaw from the Python Package Index with pip or a similar tool:
**Stable Release:** `pip install prsaw`
**Working Version:** `pip install git+https://github.com/CodeWithSwastik/prsaw.git`
## Example Usage (No API KEY)
```python
# import the module
from prsaw import RandomStuff
# initiate the object
rs = RandomStuffV2()
# get a response from an endpoint
response = rs.get_ai_response("How are you?")
print(response)
# close the object once done (recommended)
rs.close()
```
## Example async usage (With an API key)
```python
# import the module
from prsaw import RandomStuff
# initiate the object with async mode
api_key = "Your API Key"
rs = RandomStuff(async_mode = True, api_key = api_key)
# get a joke
joke = await rs.get_joke()
print(joke)
# close the session
await rs.aclose()
```
## Plans
If you've purchased a premium plan you can pass that as a paramater to RandomStuffV3 or RandomStuffV4
```python
plan = "Can be pro/biz/mega/ultra"
rs = RandomStuffV4(api_key = api_key, plan=plan)
```
## Server (V4)
You can specify the server in RandomStuffV4 if you want
```python
server = "Can be primary/backup/unstable"
rs = RandomStuffV4(api_key = api_key, server=server)
```
## Misc
You can also pass `dev_name`, `bot_name` and `ai_language` as paramaters to RandomStuffV3 or RandomStuffV4.
## Functions available
The current list of asynchronous functions available are:
```python
# endpoints
await get_joke(_type) # Refer to https://api.pgamerx.com/endpoints
await get_image(_type) # for all the endpoints
await get_ai_response(msg)
# others
await aclose() # closes the object
```
## Important Links
* Register API key - [Click Here](https://api.pgamerx.com/register)
* Documentation/Endpoints - [Click Here](https://api.pgamerx.com/endpoints/)
%package -n python3-prsaw
Summary: PRSAW, an acronym for `Python Random Stuff API Wrapper`, is a wrapper for the Random Stuff API.
Provides: python-prsaw
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-prsaw
# PRSAW 0.4.0
[![Downloads](https://static.pepy.tech/personalized-badge/prsaw?period=total&units=international_system&left_color=green&right_color=orange&left_text=Downloads)](https://pepy.tech/project/prsaw)
PRSAW, an acronym for `Python Random Stuff API Wrapper`, is a wrapper for the [Random Stuff API](https://api.pgamerx.com/).
PyPI: https://pypi.org/project/prsaw/
## Installation
You can install released versions of prsaw from the Python Package Index with pip or a similar tool:
**Stable Release:** `pip install prsaw`
**Working Version:** `pip install git+https://github.com/CodeWithSwastik/prsaw.git`
## Example Usage (No API KEY)
```python
# import the module
from prsaw import RandomStuff
# initiate the object
rs = RandomStuffV2()
# get a response from an endpoint
response = rs.get_ai_response("How are you?")
print(response)
# close the object once done (recommended)
rs.close()
```
## Example async usage (With an API key)
```python
# import the module
from prsaw import RandomStuff
# initiate the object with async mode
api_key = "Your API Key"
rs = RandomStuff(async_mode = True, api_key = api_key)
# get a joke
joke = await rs.get_joke()
print(joke)
# close the session
await rs.aclose()
```
## Plans
If you've purchased a premium plan you can pass that as a paramater to RandomStuffV3 or RandomStuffV4
```python
plan = "Can be pro/biz/mega/ultra"
rs = RandomStuffV4(api_key = api_key, plan=plan)
```
## Server (V4)
You can specify the server in RandomStuffV4 if you want
```python
server = "Can be primary/backup/unstable"
rs = RandomStuffV4(api_key = api_key, server=server)
```
## Misc
You can also pass `dev_name`, `bot_name` and `ai_language` as paramaters to RandomStuffV3 or RandomStuffV4.
## Functions available
The current list of asynchronous functions available are:
```python
# endpoints
await get_joke(_type) # Refer to https://api.pgamerx.com/endpoints
await get_image(_type) # for all the endpoints
await get_ai_response(msg)
# others
await aclose() # closes the object
```
## Important Links
* Register API key - [Click Here](https://api.pgamerx.com/register)
* Documentation/Endpoints - [Click Here](https://api.pgamerx.com/endpoints/)
%package help
Summary: Development documents and examples for prsaw
Provides: python3-prsaw-doc
%description help
# PRSAW 0.4.0
[![Downloads](https://static.pepy.tech/personalized-badge/prsaw?period=total&units=international_system&left_color=green&right_color=orange&left_text=Downloads)](https://pepy.tech/project/prsaw)
PRSAW, an acronym for `Python Random Stuff API Wrapper`, is a wrapper for the [Random Stuff API](https://api.pgamerx.com/).
PyPI: https://pypi.org/project/prsaw/
## Installation
You can install released versions of prsaw from the Python Package Index with pip or a similar tool:
**Stable Release:** `pip install prsaw`
**Working Version:** `pip install git+https://github.com/CodeWithSwastik/prsaw.git`
## Example Usage (No API KEY)
```python
# import the module
from prsaw import RandomStuff
# initiate the object
rs = RandomStuffV2()
# get a response from an endpoint
response = rs.get_ai_response("How are you?")
print(response)
# close the object once done (recommended)
rs.close()
```
## Example async usage (With an API key)
```python
# import the module
from prsaw import RandomStuff
# initiate the object with async mode
api_key = "Your API Key"
rs = RandomStuff(async_mode = True, api_key = api_key)
# get a joke
joke = await rs.get_joke()
print(joke)
# close the session
await rs.aclose()
```
## Plans
If you've purchased a premium plan you can pass that as a paramater to RandomStuffV3 or RandomStuffV4
```python
plan = "Can be pro/biz/mega/ultra"
rs = RandomStuffV4(api_key = api_key, plan=plan)
```
## Server (V4)
You can specify the server in RandomStuffV4 if you want
```python
server = "Can be primary/backup/unstable"
rs = RandomStuffV4(api_key = api_key, server=server)
```
## Misc
You can also pass `dev_name`, `bot_name` and `ai_language` as paramaters to RandomStuffV3 or RandomStuffV4.
## Functions available
The current list of asynchronous functions available are:
```python
# endpoints
await get_joke(_type) # Refer to https://api.pgamerx.com/endpoints
await get_image(_type) # for all the endpoints
await get_ai_response(msg)
# others
await aclose() # closes the object
```
## Important Links
* Register API key - [Click Here](https://api.pgamerx.com/register)
* Documentation/Endpoints - [Click Here](https://api.pgamerx.com/endpoints/)
%prep
%autosetup -n prsaw-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-prsaw -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.4.0-1
- Package Spec generated