%global _empty_manifest_terminate_build 0
Name:		python-flameprof
Version:	0.4
Release:	1
Summary:	cProfile flamegraph generator
License:	MIT
URL:		https://github.com/baverman/flameprof/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c0/e7/114f6710d31854b694598f577f9eac49d7f38b7fb8a55e86e2d3f848fd1c/flameprof-0.4.tar.gz
BuildArch:	noarch


%description
Via pip::
    pip install flameprof
Or you can invoke ``flameprof.py`` directly::
    python flameprof.py input.prof > output.svg

%package -n python3-flameprof
Summary:	cProfile flamegraph generator
Provides:	python-flameprof
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-flameprof
Via pip::
    pip install flameprof
Or you can invoke ``flameprof.py`` directly::
    python flameprof.py input.prof > output.svg

%package help
Summary:	Development documents and examples for flameprof
Provides:	python3-flameprof-doc
%description help
Via pip::
    pip install flameprof
Or you can invoke ``flameprof.py`` directly::
    python flameprof.py input.prof > output.svg

%prep
%autosetup -n flameprof-0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-flameprof -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4-1
- Package Spec generated