%global _empty_manifest_terminate_build 0
Name:		python-django-admin-sortable
Version:	2.3
Release:	1
Summary:	Drag and drop sorting for models and inline models in Django admin.
License:	APL
URL:		https://github.com/iambrandontaylor/django-admin-sortable
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/43/f5/8938ea07833a065bcab3f019789c43ec8bc916673509607704a9af0ea57d/django-admin-sortable-2.3.tar.gz
BuildArch:	noarch

Requires:	python3-django

%description
|PyPI version| |Python versions| |Build Status|
This project makes it easy to add drag-and-drop ordering to any model in
Django admin. Inlines for a sortable model may also be made sortable,
enabling individual items or groups of items to be sortable.
If you find Django Admin Sortable to be helpful, consider `buying me a
coffee <https://www.buymeacoffee.com/NY9TUAEwF>`__!
Sorting model instances with a sortable parent:
   sortable-models
Sorting inlines:
   sortable-inlines

%package -n python3-django-admin-sortable
Summary:	Drag and drop sorting for models and inline models in Django admin.
Provides:	python-django-admin-sortable
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-admin-sortable
|PyPI version| |Python versions| |Build Status|
This project makes it easy to add drag-and-drop ordering to any model in
Django admin. Inlines for a sortable model may also be made sortable,
enabling individual items or groups of items to be sortable.
If you find Django Admin Sortable to be helpful, consider `buying me a
coffee <https://www.buymeacoffee.com/NY9TUAEwF>`__!
Sorting model instances with a sortable parent:
   sortable-models
Sorting inlines:
   sortable-inlines

%package help
Summary:	Development documents and examples for django-admin-sortable
Provides:	python3-django-admin-sortable-doc
%description help
|PyPI version| |Python versions| |Build Status|
This project makes it easy to add drag-and-drop ordering to any model in
Django admin. Inlines for a sortable model may also be made sortable,
enabling individual items or groups of items to be sortable.
If you find Django Admin Sortable to be helpful, consider `buying me a
coffee <https://www.buymeacoffee.com/NY9TUAEwF>`__!
Sorting model instances with a sortable parent:
   sortable-models
Sorting inlines:
   sortable-inlines

%prep
%autosetup -n django-admin-sortable-2.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-admin-sortable -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3-1
- Package Spec generated