%global _empty_manifest_terminate_build 0
Name:		python-vistir
Version:	0.8.0
Release:	1
Summary:	Miscellaneous utilities for dealing with filesystems, paths, projects, subprocesses, and more.
License:	ISC License
URL:		https://github.com/sarugaku/vistir
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/aa/a3/59cb91b40dfc9f11773522d1199a02f93c881e09a091cf36fc635ef585dc/vistir-0.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-colorama
Requires:	python3-pre-commit
Requires:	python3-coverage
Requires:	python3-isort
Requires:	python3-flake8
Requires:	python3-rope
Requires:	python3-invoke
Requires:	python3-parver
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-flake8-bugbear
Requires:	python3-black
Requires:	python3-requests
Requires:	python3-hypothesis
Requires:	python3-hypothesis-fspaths
Requires:	python3-pytest
Requires:	python3-pytest-rerunfailures
Requires:	python3-pytest-xdist
Requires:	python3-pytest-timeout
Requires:	python3-readme-renderer[md]
Requires:	python3-twine
Requires:	python3-mypy
Requires:	python3-mypy-extensions
Requires:	python3-mypytools
Requires:	python3-typed-ast

%description


%package -n python3-vistir
Summary:	Miscellaneous utilities for dealing with filesystems, paths, projects, subprocesses, and more.
Provides:	python-vistir
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vistir


%package help
Summary:	Development documents and examples for vistir
Provides:	python3-vistir-doc
%description help


%prep
%autosetup -n vistir-0.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vistir -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
- Package Spec generated