%global _empty_manifest_terminate_build 0
Name:		python-aiohttp-swagger
Version:	1.0.16
Release:	1
Summary:	Swagger API Documentation builder for aiohttp server
License:	BSD
URL:		https://github.com/cr0hn/aiohttp-swagger
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f6/ca/ce6f8fa22a916163e4ab3361936f0f5ff7d0f5daa7521531a089741fa7a5/aiohttp-swagger-1.0.16.tar.gz
BuildArch:	noarch

Requires:	python3-pyYAML
Requires:	python3-jinja2
Requires:	python3-aiohttp
Requires:	python3-ujson

%description
**LOOCKING FOR MAINTAINERS**!!!!!
![Logo](doc/source/_static/logo.png)
[![Build Status](https://travis-ci.org/cr0hn/aiohttp-swagger.svg?branch=master)](https://travis-ci.org/cr0hn/aiohttp-swagger)
[![codecov.io](https://codecov.io/github/cr0hn/aiohttp-swagger/coverage.svg?branch=master)](https://codecov.io/github/cr0hn/aiohttp-swagger)
*aiohttp-swagger: Swagger API Documentation builder for aiohttp server*

%package -n python3-aiohttp-swagger
Summary:	Swagger API Documentation builder for aiohttp server
Provides:	python-aiohttp-swagger
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-aiohttp-swagger
**LOOCKING FOR MAINTAINERS**!!!!!
![Logo](doc/source/_static/logo.png)
[![Build Status](https://travis-ci.org/cr0hn/aiohttp-swagger.svg?branch=master)](https://travis-ci.org/cr0hn/aiohttp-swagger)
[![codecov.io](https://codecov.io/github/cr0hn/aiohttp-swagger/coverage.svg?branch=master)](https://codecov.io/github/cr0hn/aiohttp-swagger)
*aiohttp-swagger: Swagger API Documentation builder for aiohttp server*

%package help
Summary:	Development documents and examples for aiohttp-swagger
Provides:	python3-aiohttp-swagger-doc
%description help
**LOOCKING FOR MAINTAINERS**!!!!!
![Logo](doc/source/_static/logo.png)
[![Build Status](https://travis-ci.org/cr0hn/aiohttp-swagger.svg?branch=master)](https://travis-ci.org/cr0hn/aiohttp-swagger)
[![codecov.io](https://codecov.io/github/cr0hn/aiohttp-swagger/coverage.svg?branch=master)](https://codecov.io/github/cr0hn/aiohttp-swagger)
*aiohttp-swagger: Swagger API Documentation builder for aiohttp server*

%prep
%autosetup -n aiohttp-swagger-1.0.16

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-aiohttp-swagger -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.16-1
- Package Spec generated