%global _empty_manifest_terminate_build 0
Name: python-dowhy
Version: 0.9.1
Release: 1
Summary: DoWhy is a Python library for causal inference that supports explicit modeling and testing of causal assumptions
License: MIT
URL: https://github.com/py-why/dowhy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e5/89/caa4c274b6bf42724d55f3dc92042ea75c626dc83a9fda56c8ab880a9169/dowhy-0.9.1.tar.gz
BuildArch: noarch
Requires: python3-cython
Requires: python3-scipy
Requires: python3-statsmodels
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-networkx
Requires: python3-sympy
Requires: python3-scikit-learn
Requires: python3-pydot
Requires: python3-joblib
Requires: python3-pygraphviz
Requires: python3-econml
Requires: python3-tqdm
Requires: python3-causal-learn
Requires: python3-autogluon-tabular[all]
Requires: python3-matplotlib
Requires: python3-sphinx_design
%description
Introducing DoWhy and the 4 steps of causal inference | `Microsoft Research Blog `_ | `Video Tutorial `_ | `Arxiv Paper `_ | `Arxiv Paper (GCM-extension) `_ | `Slides `_
Read the `docs `_ | Try it online! |Binder|_
**Case Studies using DoWhy**: `Hotel booking cancellations `_ | `Effect of customer loyalty programs `_ | `Optimizing article headlines `_ | `Effect of home visits on infant health (IHDP) `_ | `Causes of customer churn/attrition `_
As computing systems are more frequently and more actively intervening in societally critical domains such as healthcare, education, and governance, it is critical to correctly predict and understand the causal effects of these interventions. Without an A/B test, conventional machine learning methods, built on pattern recognition and correlational analyses, are insufficient for decision-making.
Much like machine learning libraries have done for prediction, **"DoWhy" is a Python library that aims to spark causal thinking and analysis**. DoWhy provides a principled four-step interface for causal inference that focuses on explicitly modeling causal assumptions and validating them as much as possible. The key feature of DoWhy is its state-of-the-art refutation API that can automatically test causal assumptions for any estimation method, thus making inference more robust and accessible to non-experts. DoWhy supports estimation of the average causal effect for backdoor, frontdoor, instrumental variable and other identification methods, and estimation of the conditional effect (CATE) through an integration with the EconML library.
For a quick introduction to causal inference, check out `amit-sharma/causal-inference-tutorial `_. We also gave a more comprehensive tutorial at the ACM Knowledge Discovery and Data Mining (`KDD 2018 `_) conference: `causalinference.gitlab.io/kdd-tutorial `_. For an introduction to the four steps of causal inference and its implications for machine learning, you can access this video tutorial from Microsoft Research: `DoWhy Webinar `_.
Documentation for DoWhy is available at `py-why.github.io/dowhy `_.
%package -n python3-dowhy
Summary: DoWhy is a Python library for causal inference that supports explicit modeling and testing of causal assumptions
Provides: python-dowhy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dowhy
Introducing DoWhy and the 4 steps of causal inference | `Microsoft Research Blog `_ | `Video Tutorial `_ | `Arxiv Paper `_ | `Arxiv Paper (GCM-extension) `_ | `Slides `_
Read the `docs `_ | Try it online! |Binder|_
**Case Studies using DoWhy**: `Hotel booking cancellations `_ | `Effect of customer loyalty programs `_ | `Optimizing article headlines `_ | `Effect of home visits on infant health (IHDP) `_ | `Causes of customer churn/attrition `_
As computing systems are more frequently and more actively intervening in societally critical domains such as healthcare, education, and governance, it is critical to correctly predict and understand the causal effects of these interventions. Without an A/B test, conventional machine learning methods, built on pattern recognition and correlational analyses, are insufficient for decision-making.
Much like machine learning libraries have done for prediction, **"DoWhy" is a Python library that aims to spark causal thinking and analysis**. DoWhy provides a principled four-step interface for causal inference that focuses on explicitly modeling causal assumptions and validating them as much as possible. The key feature of DoWhy is its state-of-the-art refutation API that can automatically test causal assumptions for any estimation method, thus making inference more robust and accessible to non-experts. DoWhy supports estimation of the average causal effect for backdoor, frontdoor, instrumental variable and other identification methods, and estimation of the conditional effect (CATE) through an integration with the EconML library.
For a quick introduction to causal inference, check out `amit-sharma/causal-inference-tutorial `_. We also gave a more comprehensive tutorial at the ACM Knowledge Discovery and Data Mining (`KDD 2018 `_) conference: `causalinference.gitlab.io/kdd-tutorial `_. For an introduction to the four steps of causal inference and its implications for machine learning, you can access this video tutorial from Microsoft Research: `DoWhy Webinar `_.
Documentation for DoWhy is available at `py-why.github.io/dowhy `_.
%package help
Summary: Development documents and examples for dowhy
Provides: python3-dowhy-doc
%description help
Introducing DoWhy and the 4 steps of causal inference | `Microsoft Research Blog `_ | `Video Tutorial `_ | `Arxiv Paper `_ | `Arxiv Paper (GCM-extension) `_ | `Slides `_
Read the `docs `_ | Try it online! |Binder|_
**Case Studies using DoWhy**: `Hotel booking cancellations `_ | `Effect of customer loyalty programs `_ | `Optimizing article headlines `_ | `Effect of home visits on infant health (IHDP) `_ | `Causes of customer churn/attrition `_
As computing systems are more frequently and more actively intervening in societally critical domains such as healthcare, education, and governance, it is critical to correctly predict and understand the causal effects of these interventions. Without an A/B test, conventional machine learning methods, built on pattern recognition and correlational analyses, are insufficient for decision-making.
Much like machine learning libraries have done for prediction, **"DoWhy" is a Python library that aims to spark causal thinking and analysis**. DoWhy provides a principled four-step interface for causal inference that focuses on explicitly modeling causal assumptions and validating them as much as possible. The key feature of DoWhy is its state-of-the-art refutation API that can automatically test causal assumptions for any estimation method, thus making inference more robust and accessible to non-experts. DoWhy supports estimation of the average causal effect for backdoor, frontdoor, instrumental variable and other identification methods, and estimation of the conditional effect (CATE) through an integration with the EconML library.
For a quick introduction to causal inference, check out `amit-sharma/causal-inference-tutorial `_. We also gave a more comprehensive tutorial at the ACM Knowledge Discovery and Data Mining (`KDD 2018 `_) conference: `causalinference.gitlab.io/kdd-tutorial `_. For an introduction to the four steps of causal inference and its implications for machine learning, you can access this video tutorial from Microsoft Research: `DoWhy Webinar `_.
Documentation for DoWhy is available at `py-why.github.io/dowhy `_.
%prep
%autosetup -n dowhy-0.9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dowhy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.9.1-1
- Package Spec generated