%global _empty_manifest_terminate_build 0
Name:		python-workdays
Version:	1.4
Release:	1
Summary:	Workday date utility functions to extend python's datetime
License:	UNKNOWN
URL:		http://github.com/ogt/workdays
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6c/fc/82bda622103b7cf2a07fec350a7eb46dfab513064c8947a79bd122f35794/workdays-1.4.tar.gz
BuildArch:	noarch


%description
Extend python datetime with excel-like workday addition/subtraction
    functionality:

    NETWORKDAYS(start_date,end_date,holidays)

    Returns the number of whole working days between start_date and
    end_date (inclusive of both start_date and end_date). Working days
    exclude weekends and any dates identified in holidays. Use NETWORKDAYS
    to calculate employee benefits that accrue based on the number of
    days worked during a specific term.

    WORKDAY(start_date,days,[holidays])

    Returns a number that represents a date that is the indicated number
    of working days before or after a date (the starting date). Working
    days exclude weekends and any dates identified as holidays. Use
    WORKDAY to exclude weekends or holidays when you calculate invoice
    due dates, expected delivery times, or the number of days of work
    performed.

    This module has similarities with the BusinessHours module - you may
    want to check it out as well to see which one better fits your needs.

%package -n python3-workdays
Summary:	Workday date utility functions to extend python's datetime
Provides:	python-workdays
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-workdays
Extend python datetime with excel-like workday addition/subtraction
    functionality:

    NETWORKDAYS(start_date,end_date,holidays)

    Returns the number of whole working days between start_date and
    end_date (inclusive of both start_date and end_date). Working days
    exclude weekends and any dates identified in holidays. Use NETWORKDAYS
    to calculate employee benefits that accrue based on the number of
    days worked during a specific term.

    WORKDAY(start_date,days,[holidays])

    Returns a number that represents a date that is the indicated number
    of working days before or after a date (the starting date). Working
    days exclude weekends and any dates identified as holidays. Use
    WORKDAY to exclude weekends or holidays when you calculate invoice
    due dates, expected delivery times, or the number of days of work
    performed.

    This module has similarities with the BusinessHours module - you may
    want to check it out as well to see which one better fits your needs.

%package help
Summary:	Development documents and examples for workdays
Provides:	python3-workdays-doc
%description help
Extend python datetime with excel-like workday addition/subtraction
    functionality:

    NETWORKDAYS(start_date,end_date,holidays)

    Returns the number of whole working days between start_date and
    end_date (inclusive of both start_date and end_date). Working days
    exclude weekends and any dates identified in holidays. Use NETWORKDAYS
    to calculate employee benefits that accrue based on the number of
    days worked during a specific term.

    WORKDAY(start_date,days,[holidays])

    Returns a number that represents a date that is the indicated number
    of working days before or after a date (the starting date). Working
    days exclude weekends and any dates identified as holidays. Use
    WORKDAY to exclude weekends or holidays when you calculate invoice
    due dates, expected delivery times, or the number of days of work
    performed.

    This module has similarities with the BusinessHours module - you may
    want to check it out as well to see which one better fits your needs.

%prep
%autosetup -n workdays-1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-workdays -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4-1
- Package Spec generated