%global _empty_manifest_terminate_build 0
Name:		python-sparknlp
Version:	1.0.0
Release:	1
Summary:	John Snow Labs Spark NLP is a natural language processing library built on top of Apache Spark ML. It provides simple, performant & accurate NLP annotations for machine learning pipelines, that scale easily in a distributed environment.
License:	Apache Software License
URL:		http://nlp.johnsnowlabs.com
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b1/13/2168ddad88eee0637e10b6a7c0a7b6a3143ee76fde414c481b9977b9cd8c/sparknlp-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-spark-nlp
Requires:	python3-numpy

%description
# sparknlp

The correct URL for Spark NLP PyPI package: [https://pypi.org/project/spark-nlp/](https://pypi.org/project/spark-nlp/).




%package -n python3-sparknlp
Summary:	John Snow Labs Spark NLP is a natural language processing library built on top of Apache Spark ML. It provides simple, performant & accurate NLP annotations for machine learning pipelines, that scale easily in a distributed environment.
Provides:	python-sparknlp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sparknlp
# sparknlp

The correct URL for Spark NLP PyPI package: [https://pypi.org/project/spark-nlp/](https://pypi.org/project/spark-nlp/).




%package help
Summary:	Development documents and examples for sparknlp
Provides:	python3-sparknlp-doc
%description help
# sparknlp

The correct URL for Spark NLP PyPI package: [https://pypi.org/project/spark-nlp/](https://pypi.org/project/spark-nlp/).




%prep
%autosetup -n sparknlp-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sparknlp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated