%global _empty_manifest_terminate_build 0
Name: python-dj-stripe
Version: 2.7.3
Release: 1
Summary: Django + Stripe made easy
License: MIT
URL: https://dj-stripe.dev
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8f/30/d526b6f6410c458c85c9492af23da630dfa687cd4104572a0b4b954d6a13/dj_stripe-2.7.3.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-jsonfield
Requires: python3-stripe
Requires: python3-psycopg2
Requires: python3-mysqlclient
%description
# dj-stripe - Django + Stripe Made Easy
[![Stripe Verified Partner](https://img.shields.io/static/v1?label=Stripe&message=Verified%20Partner&color=red&style=for-the-badge)](https://stripe.com/docs/libraries#community-libraries)
[![CI tests](https://github.com/dj-stripe/dj-stripe/actions/workflows/ci.yml/badge.svg)](https://github.com/dj-stripe/dj-stripe/actions/workflows/ci.yml)
[![Package Downloads](https://img.shields.io/pypi/dm/dj-stripe)](https://pypi.org/project/dj-stripe/)
[![Documentation](https://img.shields.io/static/v1?label=Docs&message=READ&color=informational&style=plastic)](https://dj-stripe.github.io/dj-stripe/)
[![Sponsor dj-stripe](https://img.shields.io/static/v1?label=Sponsor&message=%E2%9D%A4&logo=GitHub&color=red&style=plastic)](https://github.com/sponsors/dj-stripe)
[![MIT License](https://img.shields.io/static/v1?label=License&message=MIT&color=informational&style=plastic)](https://github.com/sponsors/dj-stripe)
Stripe Models for Django.
## Introduction
dj-stripe implements all of the Stripe models, for Django. Set up your
webhook endpoint and start receiving model updates. You will then have
a copy of all the Stripe models available in Django models, as soon as
they are updated!
The full documentation is available [on Read the Docs](https://dj-stripe.github.io/dj-stripe/).
## Features
- Stripe Core
- Stripe Billing
- Stripe Cards (JS v2) and Sources (JS v3)
- Payment Methods and Payment Intents (SCA support)
- Support for multiple accounts and API keys
- Stripe Connect (partial support)
- Tested with Stripe API `2020-08-27` (see [API versions](api_versions.md#dj-stripe_latest_tested_version))
## Requirements
- Django >=3.2
- Python >=3.7.12
- PostgreSQL engine (recommended) >=9.6
- MySQL engine: MariaDB >=10.2 or MySQL >=5.7
- SQLite: Not recommended in production. Version >=3.26 required.
## Installation
See [installation](docs/installation.md) instructions.
## Changelog
[See release notes on Read the Docs](https://dj-stripe.github.io/dj-stripe/history/2_5_0/).
## Funding and Support
You can now become a sponsor to dj-stripe with [GitHub Sponsors](https://github.com/sponsors/dj-stripe).
We've been bringing dj-stripe to the world for over 7 years and are excited to be able to start
dedicating some real resources to the project.
Your sponsorship helps us keep a team of maintainers actively working to improve dj-stripe and
ensure it stays up-to-date with the latest Stripe changes. If you use dj-stripe commercially, we would encourage you to invest in its continued
development by [signing up for a paid plan](https://github.com/sponsors/dj-stripe).
Corporate sponsors [receive priority support and development time](project/support.md).
All contributions through GitHub sponsors flow into our [Open Collective](https://opencollective.com/dj-stripe), which holds our funds and keeps
an open ledger on how donations are spent.
## Our Gold sponsors
## Similar libraries
- [dj-paypal](https://github.com/HearthSim/dj-paypal)
([PayPal](https://www.paypal.com/))
- [dj-paddle](https://github.com/paddle-python/dj-paddle)
([Paddle](https://paddle.com/))
%package -n python3-dj-stripe
Summary: Django + Stripe made easy
Provides: python-dj-stripe
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dj-stripe
# dj-stripe - Django + Stripe Made Easy
[![Stripe Verified Partner](https://img.shields.io/static/v1?label=Stripe&message=Verified%20Partner&color=red&style=for-the-badge)](https://stripe.com/docs/libraries#community-libraries)
[![CI tests](https://github.com/dj-stripe/dj-stripe/actions/workflows/ci.yml/badge.svg)](https://github.com/dj-stripe/dj-stripe/actions/workflows/ci.yml)
[![Package Downloads](https://img.shields.io/pypi/dm/dj-stripe)](https://pypi.org/project/dj-stripe/)
[![Documentation](https://img.shields.io/static/v1?label=Docs&message=READ&color=informational&style=plastic)](https://dj-stripe.github.io/dj-stripe/)
[![Sponsor dj-stripe](https://img.shields.io/static/v1?label=Sponsor&message=%E2%9D%A4&logo=GitHub&color=red&style=plastic)](https://github.com/sponsors/dj-stripe)
[![MIT License](https://img.shields.io/static/v1?label=License&message=MIT&color=informational&style=plastic)](https://github.com/sponsors/dj-stripe)
Stripe Models for Django.
## Introduction
dj-stripe implements all of the Stripe models, for Django. Set up your
webhook endpoint and start receiving model updates. You will then have
a copy of all the Stripe models available in Django models, as soon as
they are updated!
The full documentation is available [on Read the Docs](https://dj-stripe.github.io/dj-stripe/).
## Features
- Stripe Core
- Stripe Billing
- Stripe Cards (JS v2) and Sources (JS v3)
- Payment Methods and Payment Intents (SCA support)
- Support for multiple accounts and API keys
- Stripe Connect (partial support)
- Tested with Stripe API `2020-08-27` (see [API versions](api_versions.md#dj-stripe_latest_tested_version))
## Requirements
- Django >=3.2
- Python >=3.7.12
- PostgreSQL engine (recommended) >=9.6
- MySQL engine: MariaDB >=10.2 or MySQL >=5.7
- SQLite: Not recommended in production. Version >=3.26 required.
## Installation
See [installation](docs/installation.md) instructions.
## Changelog
[See release notes on Read the Docs](https://dj-stripe.github.io/dj-stripe/history/2_5_0/).
## Funding and Support
You can now become a sponsor to dj-stripe with [GitHub Sponsors](https://github.com/sponsors/dj-stripe).
We've been bringing dj-stripe to the world for over 7 years and are excited to be able to start
dedicating some real resources to the project.
Your sponsorship helps us keep a team of maintainers actively working to improve dj-stripe and
ensure it stays up-to-date with the latest Stripe changes. If you use dj-stripe commercially, we would encourage you to invest in its continued
development by [signing up for a paid plan](https://github.com/sponsors/dj-stripe).
Corporate sponsors [receive priority support and development time](project/support.md).
All contributions through GitHub sponsors flow into our [Open Collective](https://opencollective.com/dj-stripe), which holds our funds and keeps
an open ledger on how donations are spent.
## Our Gold sponsors
## Similar libraries
- [dj-paypal](https://github.com/HearthSim/dj-paypal)
([PayPal](https://www.paypal.com/))
- [dj-paddle](https://github.com/paddle-python/dj-paddle)
([Paddle](https://paddle.com/))
%package help
Summary: Development documents and examples for dj-stripe
Provides: python3-dj-stripe-doc
%description help
# dj-stripe - Django + Stripe Made Easy
[![Stripe Verified Partner](https://img.shields.io/static/v1?label=Stripe&message=Verified%20Partner&color=red&style=for-the-badge)](https://stripe.com/docs/libraries#community-libraries)
[![CI tests](https://github.com/dj-stripe/dj-stripe/actions/workflows/ci.yml/badge.svg)](https://github.com/dj-stripe/dj-stripe/actions/workflows/ci.yml)
[![Package Downloads](https://img.shields.io/pypi/dm/dj-stripe)](https://pypi.org/project/dj-stripe/)
[![Documentation](https://img.shields.io/static/v1?label=Docs&message=READ&color=informational&style=plastic)](https://dj-stripe.github.io/dj-stripe/)
[![Sponsor dj-stripe](https://img.shields.io/static/v1?label=Sponsor&message=%E2%9D%A4&logo=GitHub&color=red&style=plastic)](https://github.com/sponsors/dj-stripe)
[![MIT License](https://img.shields.io/static/v1?label=License&message=MIT&color=informational&style=plastic)](https://github.com/sponsors/dj-stripe)
Stripe Models for Django.
## Introduction
dj-stripe implements all of the Stripe models, for Django. Set up your
webhook endpoint and start receiving model updates. You will then have
a copy of all the Stripe models available in Django models, as soon as
they are updated!
The full documentation is available [on Read the Docs](https://dj-stripe.github.io/dj-stripe/).
## Features
- Stripe Core
- Stripe Billing
- Stripe Cards (JS v2) and Sources (JS v3)
- Payment Methods and Payment Intents (SCA support)
- Support for multiple accounts and API keys
- Stripe Connect (partial support)
- Tested with Stripe API `2020-08-27` (see [API versions](api_versions.md#dj-stripe_latest_tested_version))
## Requirements
- Django >=3.2
- Python >=3.7.12
- PostgreSQL engine (recommended) >=9.6
- MySQL engine: MariaDB >=10.2 or MySQL >=5.7
- SQLite: Not recommended in production. Version >=3.26 required.
## Installation
See [installation](docs/installation.md) instructions.
## Changelog
[See release notes on Read the Docs](https://dj-stripe.github.io/dj-stripe/history/2_5_0/).
## Funding and Support
You can now become a sponsor to dj-stripe with [GitHub Sponsors](https://github.com/sponsors/dj-stripe).
We've been bringing dj-stripe to the world for over 7 years and are excited to be able to start
dedicating some real resources to the project.
Your sponsorship helps us keep a team of maintainers actively working to improve dj-stripe and
ensure it stays up-to-date with the latest Stripe changes. If you use dj-stripe commercially, we would encourage you to invest in its continued
development by [signing up for a paid plan](https://github.com/sponsors/dj-stripe).
Corporate sponsors [receive priority support and development time](project/support.md).
All contributions through GitHub sponsors flow into our [Open Collective](https://opencollective.com/dj-stripe), which holds our funds and keeps
an open ledger on how donations are spent.
## Our Gold sponsors
## Similar libraries
- [dj-paypal](https://github.com/HearthSim/dj-paypal)
([PayPal](https://www.paypal.com/))
- [dj-paddle](https://github.com/paddle-python/dj-paddle)
([Paddle](https://paddle.com/))
%prep
%autosetup -n dj-stripe-2.7.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dj-stripe -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 2.7.3-1
- Package Spec generated