%global _empty_manifest_terminate_build 0
Name: python-c3-toolset-nightly
Version: 20230126
Release: 1
Summary: Toolset for control, calibration and characterization of physical systems
License: Apache Software License
URL: http://www.q-optimize.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b1/9c/0495d455ca068dba9372288fe88dbfeef9e876f092e9e50f894c01051126/c3-toolset-nightly-20230126.tar.gz
BuildArch: noarch
Requires: python3-adaptive
Requires: python3-cma
Requires: python3-gast
Requires: python3-hjson
Requires: python3-rich
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-tensorflow
Requires: python3-tensorflow-estimator
Requires: python3-tensorflow-probability
%description
# C3 - An integrated tool-set for Control, Calibration and Characterization
[![codecov](https://codecov.io/gh/q-optimize/c3/branch/dev/graph/badge.svg)](https://codecov.io/gh/q-optimize/c3)
[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/q-optimize/c3.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/q-optimize/c3/context:python)
[![Build and Test](https://github.com/q-optimize/c3/actions/workflows/build_package.yml/badge.svg)](https://github.com/q-optimize/c3/actions/workflows/build_package.yml)
[![Documentation Status](https://readthedocs.org/projects/c3-toolset/badge/?version=latest)](https://c3-toolset.readthedocs.io/en/latest/?badge=latest)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![PyPI version fury.io](https://badge.fury.io/py/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![PyPI license](https://img.shields.io/pypi/l/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/q-optimize/c3/dev)
The C3 package is intended to close the loop between open-loop control optimization, control pulse calibration, and model-matching based on calibration data.
## Installation
```bash
pip install c3-toolset
```
If you want to try out the bleeding edge (possibly buggy) version under development:
```bash
pip install c3-toolset-nightly
```
There is no official support for `c3-toolset` on Apple Silicon devices, but you can check the [`CONTRIBUTING.md`](CONTRIBUTING.md#development-on-apple-silicon) for instructions on setting up an experimental version.
## Usage
C3 provides a simple Python API through which it may integrate with virtually any experimental setup.
Contact us at [c3@q-optimize.org](mailto://quantum.c3po@gmail.com).
The paper introducing C3 as a scientific concept can be found in [Wittler2021](https://arxiv.org/abs/2009.09866). Software and implementation details are described in [SahaRoy2022](https://arxiv.org/abs/2205.04829).
Documentation is available [here](https://c3-toolset.readthedocs.io) on RTD.
### Examples
The following notebooks are available in the `examples/` directory and can also be run online using the `launch|binder` badge above:
- [Model-based Optimal Control for Single Qubit Gate](examples/two_qubits.ipynb)
- [Model-based Optimal Control for Two Qubit Engtangling Gate](examples/two_qubit_entangling_gate.ipynb)
- [Model-free Calibration on Simulated Hardware](examples/Simulated_calibration.ipynb)
- [Simulated Model Learning with data from Simulated Calibration](examples/Simulated_Model_Learning.ipynb)
- [Full loop - Control, Calibration & Characterization](examples/Full_loop_single_qubit.ipynb)
- [Minimum example for using the Qiskit interface](examples/c3_qiskit.ipynb)
- [Minimum example for optimizing piece-wise constant pulses](examples/Piecewise_constant_controls.ipynb)
- [Understanding the ParameterMap](examples/Parametermap.ipynb)
- [Frequency Dependent Coupling](examples/frequency_dependent_coupling.ipynb)
## Contributing
If you wish to contribute, please check out the issues tab and also the [CONTRIBUTING.md](CONTRIBUTING.md) for useful resources.
The source code is available on Github at [https://github.com/q-optimize/c3](https://github.com/q-optimize/c3).
## Citation
If you use `c3-toolset` in your research, please cite it as below:
```
@article{Wittler2021,
title={Integrated Tool Set for Control, Calibration, and Characterization of Quantum Devices Applied to Superconducting Qubits},
volume={15},
DOI={10.1103/physrevapplied.15.034080},
number={3},
journal={Physical Review Applied},
author={Wittler, Nicolas and Roy, Federico and Pack, Kevin and Werninghaus, Max and Saha Roy, Anurag and Egger, Daniel J. and Filipp, Stefan and Wilhelm, Frank K. and Machnes, Shai},
year={2021},
month={Mar}
}
```
%package -n python3-c3-toolset-nightly
Summary: Toolset for control, calibration and characterization of physical systems
Provides: python-c3-toolset-nightly
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-c3-toolset-nightly
# C3 - An integrated tool-set for Control, Calibration and Characterization
[![codecov](https://codecov.io/gh/q-optimize/c3/branch/dev/graph/badge.svg)](https://codecov.io/gh/q-optimize/c3)
[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/q-optimize/c3.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/q-optimize/c3/context:python)
[![Build and Test](https://github.com/q-optimize/c3/actions/workflows/build_package.yml/badge.svg)](https://github.com/q-optimize/c3/actions/workflows/build_package.yml)
[![Documentation Status](https://readthedocs.org/projects/c3-toolset/badge/?version=latest)](https://c3-toolset.readthedocs.io/en/latest/?badge=latest)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![PyPI version fury.io](https://badge.fury.io/py/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![PyPI license](https://img.shields.io/pypi/l/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/q-optimize/c3/dev)
The C3 package is intended to close the loop between open-loop control optimization, control pulse calibration, and model-matching based on calibration data.
## Installation
```bash
pip install c3-toolset
```
If you want to try out the bleeding edge (possibly buggy) version under development:
```bash
pip install c3-toolset-nightly
```
There is no official support for `c3-toolset` on Apple Silicon devices, but you can check the [`CONTRIBUTING.md`](CONTRIBUTING.md#development-on-apple-silicon) for instructions on setting up an experimental version.
## Usage
C3 provides a simple Python API through which it may integrate with virtually any experimental setup.
Contact us at [c3@q-optimize.org](mailto://quantum.c3po@gmail.com).
The paper introducing C3 as a scientific concept can be found in [Wittler2021](https://arxiv.org/abs/2009.09866). Software and implementation details are described in [SahaRoy2022](https://arxiv.org/abs/2205.04829).
Documentation is available [here](https://c3-toolset.readthedocs.io) on RTD.
### Examples
The following notebooks are available in the `examples/` directory and can also be run online using the `launch|binder` badge above:
- [Model-based Optimal Control for Single Qubit Gate](examples/two_qubits.ipynb)
- [Model-based Optimal Control for Two Qubit Engtangling Gate](examples/two_qubit_entangling_gate.ipynb)
- [Model-free Calibration on Simulated Hardware](examples/Simulated_calibration.ipynb)
- [Simulated Model Learning with data from Simulated Calibration](examples/Simulated_Model_Learning.ipynb)
- [Full loop - Control, Calibration & Characterization](examples/Full_loop_single_qubit.ipynb)
- [Minimum example for using the Qiskit interface](examples/c3_qiskit.ipynb)
- [Minimum example for optimizing piece-wise constant pulses](examples/Piecewise_constant_controls.ipynb)
- [Understanding the ParameterMap](examples/Parametermap.ipynb)
- [Frequency Dependent Coupling](examples/frequency_dependent_coupling.ipynb)
## Contributing
If you wish to contribute, please check out the issues tab and also the [CONTRIBUTING.md](CONTRIBUTING.md) for useful resources.
The source code is available on Github at [https://github.com/q-optimize/c3](https://github.com/q-optimize/c3).
## Citation
If you use `c3-toolset` in your research, please cite it as below:
```
@article{Wittler2021,
title={Integrated Tool Set for Control, Calibration, and Characterization of Quantum Devices Applied to Superconducting Qubits},
volume={15},
DOI={10.1103/physrevapplied.15.034080},
number={3},
journal={Physical Review Applied},
author={Wittler, Nicolas and Roy, Federico and Pack, Kevin and Werninghaus, Max and Saha Roy, Anurag and Egger, Daniel J. and Filipp, Stefan and Wilhelm, Frank K. and Machnes, Shai},
year={2021},
month={Mar}
}
```
%package help
Summary: Development documents and examples for c3-toolset-nightly
Provides: python3-c3-toolset-nightly-doc
%description help
# C3 - An integrated tool-set for Control, Calibration and Characterization
[![codecov](https://codecov.io/gh/q-optimize/c3/branch/dev/graph/badge.svg)](https://codecov.io/gh/q-optimize/c3)
[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/q-optimize/c3.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/q-optimize/c3/context:python)
[![Build and Test](https://github.com/q-optimize/c3/actions/workflows/build_package.yml/badge.svg)](https://github.com/q-optimize/c3/actions/workflows/build_package.yml)
[![Documentation Status](https://readthedocs.org/projects/c3-toolset/badge/?version=latest)](https://c3-toolset.readthedocs.io/en/latest/?badge=latest)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![PyPI version fury.io](https://badge.fury.io/py/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![PyPI license](https://img.shields.io/pypi/l/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/c3-toolset.svg)](https://pypi.python.org/pypi/c3-toolset/)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/q-optimize/c3/dev)
The C3 package is intended to close the loop between open-loop control optimization, control pulse calibration, and model-matching based on calibration data.
## Installation
```bash
pip install c3-toolset
```
If you want to try out the bleeding edge (possibly buggy) version under development:
```bash
pip install c3-toolset-nightly
```
There is no official support for `c3-toolset` on Apple Silicon devices, but you can check the [`CONTRIBUTING.md`](CONTRIBUTING.md#development-on-apple-silicon) for instructions on setting up an experimental version.
## Usage
C3 provides a simple Python API through which it may integrate with virtually any experimental setup.
Contact us at [c3@q-optimize.org](mailto://quantum.c3po@gmail.com).
The paper introducing C3 as a scientific concept can be found in [Wittler2021](https://arxiv.org/abs/2009.09866). Software and implementation details are described in [SahaRoy2022](https://arxiv.org/abs/2205.04829).
Documentation is available [here](https://c3-toolset.readthedocs.io) on RTD.
### Examples
The following notebooks are available in the `examples/` directory and can also be run online using the `launch|binder` badge above:
- [Model-based Optimal Control for Single Qubit Gate](examples/two_qubits.ipynb)
- [Model-based Optimal Control for Two Qubit Engtangling Gate](examples/two_qubit_entangling_gate.ipynb)
- [Model-free Calibration on Simulated Hardware](examples/Simulated_calibration.ipynb)
- [Simulated Model Learning with data from Simulated Calibration](examples/Simulated_Model_Learning.ipynb)
- [Full loop - Control, Calibration & Characterization](examples/Full_loop_single_qubit.ipynb)
- [Minimum example for using the Qiskit interface](examples/c3_qiskit.ipynb)
- [Minimum example for optimizing piece-wise constant pulses](examples/Piecewise_constant_controls.ipynb)
- [Understanding the ParameterMap](examples/Parametermap.ipynb)
- [Frequency Dependent Coupling](examples/frequency_dependent_coupling.ipynb)
## Contributing
If you wish to contribute, please check out the issues tab and also the [CONTRIBUTING.md](CONTRIBUTING.md) for useful resources.
The source code is available on Github at [https://github.com/q-optimize/c3](https://github.com/q-optimize/c3).
## Citation
If you use `c3-toolset` in your research, please cite it as below:
```
@article{Wittler2021,
title={Integrated Tool Set for Control, Calibration, and Characterization of Quantum Devices Applied to Superconducting Qubits},
volume={15},
DOI={10.1103/physrevapplied.15.034080},
number={3},
journal={Physical Review Applied},
author={Wittler, Nicolas and Roy, Federico and Pack, Kevin and Werninghaus, Max and Saha Roy, Anurag and Egger, Daniel J. and Filipp, Stefan and Wilhelm, Frank K. and Machnes, Shai},
year={2021},
month={Mar}
}
```
%prep
%autosetup -n c3-toolset-nightly-20230126
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-c3-toolset-nightly -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 20230126-1
- Package Spec generated