%global _empty_manifest_terminate_build 0
Name: python-flytekit
Version: 1.5.0
Release: 1
Summary: Flyte SDK for Python
License: apache2
URL: https://github.com/flyteorg/flytekit
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/18/ee/f876e4bc8b9ac015e8e0da0cf4123a684658085bece435169e8581259181/flytekit-1.5.0.tar.gz
BuildArch: noarch
Requires: python3-googleapis-common-protos
Requires: python3-flyteidl
Requires: python3-wheel
Requires: python3-pandas
Requires: python3-pyarrow
Requires: python3-click
Requires: python3-croniter
Requires: python3-deprecated
Requires: python3-docker
Requires: python3-dateutil
Requires: python3-grpcio
Requires: python3-grpcio-status
Requires: python3-importlib-metadata
Requires: python3-fsspec
Requires: python3-adlfs
Requires: python3-s3fs
Requires: python3-gcsfs
Requires: python3-pyopenssl
Requires: python3-joblib
Requires: python3-json-logger
Requires: python3-pytimeparse
Requires: python3-pytz
Requires: python3-pyyaml
Requires: python3-keyring
Requires: python3-requests
Requires: python3-responses
Requires: python3-sortedcontainers
Requires: python3-statsd
Requires: python3-urllib3
Requires: python3-wrapt
Requires: python3-dataclasses-json
Requires: python3-marshmallow-jsonschema
Requires: python3-natsort
Requires: python3-docker-image-py
Requires: python3-typing-extensions
Requires: python3-docstring-parser
Requires: python3-diskcache
Requires: python3-cloudpickle
Requires: python3-cookiecutter
Requires: python3-numpy
Requires: python3-gitpython
Requires: python3-kubernetes
Requires: python3-singledispatchmethod
%description
Flytekit Python
Flytekit Python is the Python SDK built on top of Flyte
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)

[](https://pypi.python.org/pypi/flytekit/)
[](https://flytekit.rtfd.io)
[](https://github.com/psf/black)
[](https://slack.flyte.org)
Flytekit Python is the Python Library for easily authoring, testing, deploying, and interacting with Flyte tasks, workflows, and launch plans.
If you haven't explored Flyte yet, please refer to:
- [Flyte homepage](https://flyte.org)
- [Flyte core repository](https://github.com/flyteorg/flyte)
## ๐ Quick Start
Flytekit is the core extensible library to author Flyte workflows and tasks and interact with Flyte backend services.
### Installation
```bash
pip install flytekit
```
### A Simple Example
```python
from flytekit import task, workflow
@task(cache=True, cache_version="1", retries=3)
def sum(x: int, y: int) -> int:
return x + y
@task(cache=True, cache_version="1", retries=3)
def square(z: int) -> int:
return z*z
@workflow
def my_workflow(x: int, y: int) -> int:
return sum(x=square(z=x), y=square(z=y))
```
## ๐ฆ Resources
- [Learn Flytekit by examples](https://flytecookbook.readthedocs.io/)
- [Flytekit API documentation](https://flytekit.readthedocs.io/)
## ๐ How to Contribute to Flytekit
You can find the detailed contribution guide [here](https://docs.flyte.org/projects/flytekit/en/latest/contributing.html). Plugins' contribution guide is included as well.
## Code Structure
Please see the [contributor's guide](https://docs.flyte.org/projects/flytekit/en/latest/contributing.html) for a quick summary of how this code is structured.
## ๐ File an Issue
Refer to the [issues](https://docs.flyte.org/en/latest/community/contribute.html#file-an-issue) section in the contribution guide if you'd like to file an issue.
## ๐ Flytekit Plugins
Refer to [plugins/README.md](plugins/README.md) for a list of available plugins.
There may be plugins outside of this list, but the core maintainers maintain this list.
%package -n python3-flytekit
Summary: Flyte SDK for Python
Provides: python-flytekit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flytekit
Flytekit Python
Flytekit Python is the Python SDK built on top of Flyte
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)

[](https://pypi.python.org/pypi/flytekit/)
[](https://flytekit.rtfd.io)
[](https://github.com/psf/black)
[](https://slack.flyte.org)
Flytekit Python is the Python Library for easily authoring, testing, deploying, and interacting with Flyte tasks, workflows, and launch plans.
If you haven't explored Flyte yet, please refer to:
- [Flyte homepage](https://flyte.org)
- [Flyte core repository](https://github.com/flyteorg/flyte)
## ๐ Quick Start
Flytekit is the core extensible library to author Flyte workflows and tasks and interact with Flyte backend services.
### Installation
```bash
pip install flytekit
```
### A Simple Example
```python
from flytekit import task, workflow
@task(cache=True, cache_version="1", retries=3)
def sum(x: int, y: int) -> int:
return x + y
@task(cache=True, cache_version="1", retries=3)
def square(z: int) -> int:
return z*z
@workflow
def my_workflow(x: int, y: int) -> int:
return sum(x=square(z=x), y=square(z=y))
```
## ๐ฆ Resources
- [Learn Flytekit by examples](https://flytecookbook.readthedocs.io/)
- [Flytekit API documentation](https://flytekit.readthedocs.io/)
## ๐ How to Contribute to Flytekit
You can find the detailed contribution guide [here](https://docs.flyte.org/projects/flytekit/en/latest/contributing.html). Plugins' contribution guide is included as well.
## Code Structure
Please see the [contributor's guide](https://docs.flyte.org/projects/flytekit/en/latest/contributing.html) for a quick summary of how this code is structured.
## ๐ File an Issue
Refer to the [issues](https://docs.flyte.org/en/latest/community/contribute.html#file-an-issue) section in the contribution guide if you'd like to file an issue.
## ๐ Flytekit Plugins
Refer to [plugins/README.md](plugins/README.md) for a list of available plugins.
There may be plugins outside of this list, but the core maintainers maintain this list.
%package help
Summary: Development documents and examples for flytekit
Provides: python3-flytekit-doc
%description help
Flytekit Python
Flytekit Python is the Python SDK built on top of Flyte
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)
[](https://pypi.python.org/pypi/flytekit/)

[](https://pypi.python.org/pypi/flytekit/)
[](https://flytekit.rtfd.io)
[](https://github.com/psf/black)
[](https://slack.flyte.org)
Flytekit Python is the Python Library for easily authoring, testing, deploying, and interacting with Flyte tasks, workflows, and launch plans.
If you haven't explored Flyte yet, please refer to:
- [Flyte homepage](https://flyte.org)
- [Flyte core repository](https://github.com/flyteorg/flyte)
## ๐ Quick Start
Flytekit is the core extensible library to author Flyte workflows and tasks and interact with Flyte backend services.
### Installation
```bash
pip install flytekit
```
### A Simple Example
```python
from flytekit import task, workflow
@task(cache=True, cache_version="1", retries=3)
def sum(x: int, y: int) -> int:
return x + y
@task(cache=True, cache_version="1", retries=3)
def square(z: int) -> int:
return z*z
@workflow
def my_workflow(x: int, y: int) -> int:
return sum(x=square(z=x), y=square(z=y))
```
## ๐ฆ Resources
- [Learn Flytekit by examples](https://flytecookbook.readthedocs.io/)
- [Flytekit API documentation](https://flytekit.readthedocs.io/)
## ๐ How to Contribute to Flytekit
You can find the detailed contribution guide [here](https://docs.flyte.org/projects/flytekit/en/latest/contributing.html). Plugins' contribution guide is included as well.
## Code Structure
Please see the [contributor's guide](https://docs.flyte.org/projects/flytekit/en/latest/contributing.html) for a quick summary of how this code is structured.
## ๐ File an Issue
Refer to the [issues](https://docs.flyte.org/en/latest/community/contribute.html#file-an-issue) section in the contribution guide if you'd like to file an issue.
## ๐ Flytekit Plugins
Refer to [plugins/README.md](plugins/README.md) for a list of available plugins.
There may be plugins outside of this list, but the core maintainers maintain this list.
%prep
%autosetup -n flytekit-1.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flytekit -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.5.0-1
- Package Spec generated