%global _empty_manifest_terminate_build 0
Name: python-pep257
Version: 0.7.0
Release: 1
Summary: Python docstring style checker
License: MIT
URL: https://github.com/GreenSteam/pep257/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/03/37/872af099c9864f7584bad9a561f6493d5d5eca9fc2b14c7d32407c90c639/pep257-0.7.0.tar.gz
BuildArch: noarch
%description
**pep257** is a static analysis tool for checking
compliance with Python `PEP 257
`_.
The framework for checking docstring style is flexible, and
custom checks can be easily added, for example to cover
NumPy `docstring conventions
`_.
**pep257** supports Python 2.6, 2.7, 3.2, 3.3, 3.4, pypy and pypy3.
%package -n python3-pep257
Summary: Python docstring style checker
Provides: python-pep257
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pep257
**pep257** is a static analysis tool for checking
compliance with Python `PEP 257
`_.
The framework for checking docstring style is flexible, and
custom checks can be easily added, for example to cover
NumPy `docstring conventions
`_.
**pep257** supports Python 2.6, 2.7, 3.2, 3.3, 3.4, pypy and pypy3.
%package help
Summary: Development documents and examples for pep257
Provides: python3-pep257-doc
%description help
**pep257** is a static analysis tool for checking
compliance with Python `PEP 257
`_.
The framework for checking docstring style is flexible, and
custom checks can be easily added, for example to cover
NumPy `docstring conventions
`_.
**pep257** supports Python 2.6, 2.7, 3.2, 3.3, 3.4, pypy and pypy3.
%prep
%autosetup -n pep257-0.7.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pep257 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.7.0-1
- Package Spec generated