%global _empty_manifest_terminate_build 0
Name: python-pyatv
Version: 0.10.3
Release: 1
Summary: A client library for Apple TV and AirPlay devices
License: MIT
URL: https://pyatv.dev
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d8/2a/785a3c6e405ba92c9da6bc59dc87c68c4abe7350616635e121e34682f696/pyatv-0.10.3.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-async-timeout
Requires: python3-bitarray
Requires: python3-cryptography
Requires: python3-chacha20poly1305-reuseable
Requires: python3-ifaddr
Requires: python3-mediafile
Requires: python3-miniaudio
Requires: python3-protobuf
Requires: python3-requests
Requires: python3-srptools
Requires: python3-zeroconf
%description
![Tests](https://github.com/postlund/pyatv/workflows/Tests/badge.svg)
![pyatv Actions](https://api.meercode.io/badge/postlund/pyatv?type=ci-success-rate&branch=master&lastDay=30)
[![codecov](https://codecov.io/gh/postlund/pyatv/branch/master/graph/badge.svg)](https://codecov.io/gh/postlund/pyatv)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![PyPi Package](https://badge.fury.io/py/pyatv.svg)](https://badge.fury.io/py/pyatv)
[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/postlund/pyatv.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/postlund/pyatv/context:python)
[![Gitpod Ready-to-Code](https://img.shields.io/badge/Gitpod-ready--to--code-blue?logo=gitpod)](https://gitpod.io/#https://github.com/postlund/pyatv)
[![Downloads](https://pepy.tech/badge/pyatv)](https://pepy.tech/project/pyatv)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/pyatv.svg)](https://pypi.python.org/pypi/pyatv/)
[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://opensource.org/licenses/MIT)
This is an asyncio python library for interacting with Apple TV and AirPlay devices. It mainly
targets Apple TVs (all generations, **including tvOS 15**), but also support audio streaming via AirPlay to
receivers like the HomePod, AirPort Express and third-party speakers. It can act as remote control to the Music
app/iTunes in macOS.
All the documentation you need is available at **[pyatv.dev](https://pyatv.dev)**.
# What can it do?
Some examples include:
* Remote control commands
* Metadata retrieval with push updates
* Stream files via AirPlay
* List and launch installed apps
# Great, but how do I use it?
All documentation (especially for developers) are available at [pyatv.dev](https://pyatv.dev).
It is however possible to install with `pip` and try things out with `atvremote`:
```raw
$ pip install pyatv
$ atvremote scan
Name: Office
Model/SW: HomePodMini tvOS 14.7
Address: 10.0.10.84
MAC: AA:BB:CC:DD:EE:FF
Deep Sleep: False
Identifiers:
- AA:BB:CC:DD:EE:FF
- AABBCCDDEEFF
Services:
- Protocol: AirPlay, Port: 7000, Credentials: None
- Protocol: Companion, Port: 49152, Credentials: None
- Protocol: RAOP, Port: 7000, Credentials: None, Password: None
```
Or run in a container (x86_64, aarch64, armv7):
```raw
docker run -it --rm --network=host ghcr.io/postlund/pyatv:master atvremote scan
```
The `master` tag points to latest commit on the `master` branch and can
be changed to a specific version, e.g. `v0.9.0`.
# I need to change something?
Want to help out with `pyatv`? Press the button below to get a fully prepared development environment and get started right away!
[![Open in Gitpod](https://gitpod.io/button/open-in-gitpod.svg)](https://gitpod.io/#https://github.com/postlund/pyatv)
# Shortcuts to the good stuff
To save you some time, here are some shortcuts:
* [Getting started](https://pyatv.dev/documentation/getting-started/)
* [Documentation](https://pyatv.dev/documentation)
* [Development](https://pyatv.dev/development)
* [API Reference](https://pyatv.dev/api)
* [Support](https://pyatv.dev/support)
%package -n python3-pyatv
Summary: A client library for Apple TV and AirPlay devices
Provides: python-pyatv
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyatv
![Tests](https://github.com/postlund/pyatv/workflows/Tests/badge.svg)
![pyatv Actions](https://api.meercode.io/badge/postlund/pyatv?type=ci-success-rate&branch=master&lastDay=30)
[![codecov](https://codecov.io/gh/postlund/pyatv/branch/master/graph/badge.svg)](https://codecov.io/gh/postlund/pyatv)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![PyPi Package](https://badge.fury.io/py/pyatv.svg)](https://badge.fury.io/py/pyatv)
[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/postlund/pyatv.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/postlund/pyatv/context:python)
[![Gitpod Ready-to-Code](https://img.shields.io/badge/Gitpod-ready--to--code-blue?logo=gitpod)](https://gitpod.io/#https://github.com/postlund/pyatv)
[![Downloads](https://pepy.tech/badge/pyatv)](https://pepy.tech/project/pyatv)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/pyatv.svg)](https://pypi.python.org/pypi/pyatv/)
[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://opensource.org/licenses/MIT)
This is an asyncio python library for interacting with Apple TV and AirPlay devices. It mainly
targets Apple TVs (all generations, **including tvOS 15**), but also support audio streaming via AirPlay to
receivers like the HomePod, AirPort Express and third-party speakers. It can act as remote control to the Music
app/iTunes in macOS.
All the documentation you need is available at **[pyatv.dev](https://pyatv.dev)**.
# What can it do?
Some examples include:
* Remote control commands
* Metadata retrieval with push updates
* Stream files via AirPlay
* List and launch installed apps
# Great, but how do I use it?
All documentation (especially for developers) are available at [pyatv.dev](https://pyatv.dev).
It is however possible to install with `pip` and try things out with `atvremote`:
```raw
$ pip install pyatv
$ atvremote scan
Name: Office
Model/SW: HomePodMini tvOS 14.7
Address: 10.0.10.84
MAC: AA:BB:CC:DD:EE:FF
Deep Sleep: False
Identifiers:
- AA:BB:CC:DD:EE:FF
- AABBCCDDEEFF
Services:
- Protocol: AirPlay, Port: 7000, Credentials: None
- Protocol: Companion, Port: 49152, Credentials: None
- Protocol: RAOP, Port: 7000, Credentials: None, Password: None
```
Or run in a container (x86_64, aarch64, armv7):
```raw
docker run -it --rm --network=host ghcr.io/postlund/pyatv:master atvremote scan
```
The `master` tag points to latest commit on the `master` branch and can
be changed to a specific version, e.g. `v0.9.0`.
# I need to change something?
Want to help out with `pyatv`? Press the button below to get a fully prepared development environment and get started right away!
[![Open in Gitpod](https://gitpod.io/button/open-in-gitpod.svg)](https://gitpod.io/#https://github.com/postlund/pyatv)
# Shortcuts to the good stuff
To save you some time, here are some shortcuts:
* [Getting started](https://pyatv.dev/documentation/getting-started/)
* [Documentation](https://pyatv.dev/documentation)
* [Development](https://pyatv.dev/development)
* [API Reference](https://pyatv.dev/api)
* [Support](https://pyatv.dev/support)
%package help
Summary: Development documents and examples for pyatv
Provides: python3-pyatv-doc
%description help
![Tests](https://github.com/postlund/pyatv/workflows/Tests/badge.svg)
![pyatv Actions](https://api.meercode.io/badge/postlund/pyatv?type=ci-success-rate&branch=master&lastDay=30)
[![codecov](https://codecov.io/gh/postlund/pyatv/branch/master/graph/badge.svg)](https://codecov.io/gh/postlund/pyatv)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![PyPi Package](https://badge.fury.io/py/pyatv.svg)](https://badge.fury.io/py/pyatv)
[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/postlund/pyatv.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/postlund/pyatv/context:python)
[![Gitpod Ready-to-Code](https://img.shields.io/badge/Gitpod-ready--to--code-blue?logo=gitpod)](https://gitpod.io/#https://github.com/postlund/pyatv)
[![Downloads](https://pepy.tech/badge/pyatv)](https://pepy.tech/project/pyatv)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/pyatv.svg)](https://pypi.python.org/pypi/pyatv/)
[![License: MIT](https://img.shields.io/badge/License-MIT-yellow.svg)](https://opensource.org/licenses/MIT)
This is an asyncio python library for interacting with Apple TV and AirPlay devices. It mainly
targets Apple TVs (all generations, **including tvOS 15**), but also support audio streaming via AirPlay to
receivers like the HomePod, AirPort Express and third-party speakers. It can act as remote control to the Music
app/iTunes in macOS.
All the documentation you need is available at **[pyatv.dev](https://pyatv.dev)**.
# What can it do?
Some examples include:
* Remote control commands
* Metadata retrieval with push updates
* Stream files via AirPlay
* List and launch installed apps
# Great, but how do I use it?
All documentation (especially for developers) are available at [pyatv.dev](https://pyatv.dev).
It is however possible to install with `pip` and try things out with `atvremote`:
```raw
$ pip install pyatv
$ atvremote scan
Name: Office
Model/SW: HomePodMini tvOS 14.7
Address: 10.0.10.84
MAC: AA:BB:CC:DD:EE:FF
Deep Sleep: False
Identifiers:
- AA:BB:CC:DD:EE:FF
- AABBCCDDEEFF
Services:
- Protocol: AirPlay, Port: 7000, Credentials: None
- Protocol: Companion, Port: 49152, Credentials: None
- Protocol: RAOP, Port: 7000, Credentials: None, Password: None
```
Or run in a container (x86_64, aarch64, armv7):
```raw
docker run -it --rm --network=host ghcr.io/postlund/pyatv:master atvremote scan
```
The `master` tag points to latest commit on the `master` branch and can
be changed to a specific version, e.g. `v0.9.0`.
# I need to change something?
Want to help out with `pyatv`? Press the button below to get a fully prepared development environment and get started right away!
[![Open in Gitpod](https://gitpod.io/button/open-in-gitpod.svg)](https://gitpod.io/#https://github.com/postlund/pyatv)
# Shortcuts to the good stuff
To save you some time, here are some shortcuts:
* [Getting started](https://pyatv.dev/documentation/getting-started/)
* [Documentation](https://pyatv.dev/documentation)
* [Development](https://pyatv.dev/development)
* [API Reference](https://pyatv.dev/api)
* [Support](https://pyatv.dev/support)
%prep
%autosetup -n pyatv-0.10.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyatv -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.10.3-1
- Package Spec generated