%global _empty_manifest_terminate_build 0
Name:		python-flake8-snippets
Version:	0.2
Release:	1
Summary:	A flake8 extension to find any code snippets you don't like
License:	The MIT License
URL:		https://github.com/bitmazk/flake8-snippets
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c1/0c/bc119ffe4bce7d98fc9ff6e716f29af862235cf3450c345fc51127199eef/flake8-snippets-0.2.tar.gz
BuildArch:	noarch


%description
A flake8 extension to find any code snippets you don't like.
Flake8 is a tool to combine different apps (like pep8) and therefore to
guarantee clean Python code.
Read more: http://flake8.readthedocs.org/en/latest/

%package -n python3-flake8-snippets
Summary:	A flake8 extension to find any code snippets you don't like
Provides:	python-flake8-snippets
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-flake8-snippets
A flake8 extension to find any code snippets you don't like.
Flake8 is a tool to combine different apps (like pep8) and therefore to
guarantee clean Python code.
Read more: http://flake8.readthedocs.org/en/latest/

%package help
Summary:	Development documents and examples for flake8-snippets
Provides:	python3-flake8-snippets-doc
%description help
A flake8 extension to find any code snippets you don't like.
Flake8 is a tool to combine different apps (like pep8) and therefore to
guarantee clean Python code.
Read more: http://flake8.readthedocs.org/en/latest/

%prep
%autosetup -n flake8-snippets-0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-flake8-snippets -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2-1
- Package Spec generated