%global _empty_manifest_terminate_build 0
Name: python-django-cities-light
Version: 3.9.2
Release: 1
Summary: Simple alternative to django-cities
License: MIT
URL: https://github.com/yourlabs/django-cities-light
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/84/6d/26841a5a9c422f1c09a11cb79ecc920cb4a1dc2068d76b8098e55fc1a108/django-cities-light-3.9.2.tar.gz
BuildArch: noarch
Requires: python3-pytz
Requires: python3-unidecode
Requires: python3-django-autoslug
Requires: python3-progressbar2
%description
This add-on provides models and commands to import country, subregion, region/state, and
city data in your database.
The data is pulled from `GeoNames
`_ and contains cities, subregions, regions/states and countries.
Spatial query support is not required by this application.
This application is very simple and is useful if you want to make a simple
address book for example. If you intend to build a fully featured spatial
database, you should use
`django-cities
`_.
Requirements:
- Python >= 3.8
- Django >= 3.0
- MySQL or PostgreSQL or SQLite.
Yes, for some reason, code that used to work on MySQL (not without pain xD)
does not work anymore. So we're now using django.db.transaction.atomic which
comes from Django 1.6 just to support MySQL quacks.
%package -n python3-django-cities-light
Summary: Simple alternative to django-cities
Provides: python-django-cities-light
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-cities-light
This add-on provides models and commands to import country, subregion, region/state, and
city data in your database.
The data is pulled from `GeoNames
`_ and contains cities, subregions, regions/states and countries.
Spatial query support is not required by this application.
This application is very simple and is useful if you want to make a simple
address book for example. If you intend to build a fully featured spatial
database, you should use
`django-cities
`_.
Requirements:
- Python >= 3.8
- Django >= 3.0
- MySQL or PostgreSQL or SQLite.
Yes, for some reason, code that used to work on MySQL (not without pain xD)
does not work anymore. So we're now using django.db.transaction.atomic which
comes from Django 1.6 just to support MySQL quacks.
%package help
Summary: Development documents and examples for django-cities-light
Provides: python3-django-cities-light-doc
%description help
This add-on provides models and commands to import country, subregion, region/state, and
city data in your database.
The data is pulled from `GeoNames
`_ and contains cities, subregions, regions/states and countries.
Spatial query support is not required by this application.
This application is very simple and is useful if you want to make a simple
address book for example. If you intend to build a fully featured spatial
database, you should use
`django-cities
`_.
Requirements:
- Python >= 3.8
- Django >= 3.0
- MySQL or PostgreSQL or SQLite.
Yes, for some reason, code that used to work on MySQL (not without pain xD)
does not work anymore. So we're now using django.db.transaction.atomic which
comes from Django 1.6 just to support MySQL quacks.
%prep
%autosetup -n django-cities-light-3.9.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-cities-light -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 3.9.2-1
- Package Spec generated