%global _empty_manifest_terminate_build 0
Name: python-phoenixdb
Version: 1.2.1
Release: 1
Summary: Phoenix database adapter for Python
License: Apache 2
URL: http://phoenix.apache.org/python.html
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3d/fc/35d257efeef9d1de343fb1fe4ba467fd60d30faa9cc8bf0beafa05ed0450/phoenixdb-1.2.1.tar.gz
BuildArch: noarch
Requires: python3-protobuf
Requires: python3-requests
Requires: python3-requests-gssapi
Requires: python3-gssapi
Requires: python3-SQLAlchemy
Requires: python3-SQLAlchemy
%description
``phoenixdb`` is a Python library for accessing
`Apache Phoenix `_
using the
`remote query server `_.
This library implements the
standard `DB API 2.0 `_ interface and a
subset of `SQLAlchemy `_, either of which should be familiar
to most Python programmers.
%package -n python3-phoenixdb
Summary: Phoenix database adapter for Python
Provides: python-phoenixdb
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-phoenixdb
``phoenixdb`` is a Python library for accessing
`Apache Phoenix `_
using the
`remote query server `_.
This library implements the
standard `DB API 2.0 `_ interface and a
subset of `SQLAlchemy `_, either of which should be familiar
to most Python programmers.
%package help
Summary: Development documents and examples for phoenixdb
Provides: python3-phoenixdb-doc
%description help
``phoenixdb`` is a Python library for accessing
`Apache Phoenix `_
using the
`remote query server `_.
This library implements the
standard `DB API 2.0 `_ interface and a
subset of `SQLAlchemy `_, either of which should be familiar
to most Python programmers.
%prep
%autosetup -n phoenixdb-1.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-phoenixdb -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.2.1-1
- Package Spec generated