%global _empty_manifest_terminate_build 0
Name: python-pyansys
Version: 2023.1.3
Release: 1
Summary: Pythonic interfaces to Ansys products
License: MIT
URL: https://github.com/pyansys
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f1/8a/9257c0125056db047a8a3a0407a7faa4e03424baf2b3c365f5b32fd18ac8/pyansys-2023.1.3.tar.gz
BuildArch: noarch
Requires: python3-Sphinx
Requires: python3-ansys-dpf-core
Requires: python3-ansys-dpf-gate
Requires: python3-ansys-dpf-post
Requires: python3-ansys-fluent-core
Requires: python3-ansys-fluent-parametric
Requires: python3-ansys-fluent-visualization
Requires: python3-ansys-grantami-bomanalytics
Requires: python3-ansys-mapdl-core
Requires: python3-ansys-mapdl-reader
Requires: python3-ansys-meshing-prime
Requires: python3-ansys-openapi-common
Requires: python3-ansys-platform-instancemanagement
Requires: python3-ansys-seascape
Requires: python3-ansys-sphinx-theme
Requires: python3-importlib-metadata
Requires: python3-pyaedt
Requires: python3-pytwin
%description
|pyansys| |python| |pypi| |GH-CI| |MIT| |black|
Welcome to the PyAnsys metapackage repository. This project originated as a single ``pyansys`` package,
which provides support to Ansys product releases. Compatibility of these packages amongst themselves
and with the Ansys product release they are linked to is ensured.
At this moment, this package ensures the compatibility between the following PyAnsys packages:
- `PyAEDT `_ : Pythonic interface to AEDT (Ansys Electronic Desktop)
- `PyDPF-Core `_ : Pythonic interface to DPF (Data Processing Framework) for building more advanced and customized workflows
- `PyDPF-Post `_ : Pythonic interface to DPF's postprocessing toolbox for manipulating and transforming simulation data
- `PyFluent `_ : Pythonic interface to Ansys Fluent
- `PyFluent-Parametric `_ : Pythonic interface to Ansys Fluent parametric workflows
- `PyFluent-Visualization `_ : Pythonic interface to visualize Ansys Fluent simulations using Python
- `PyMAPDL `_ : Pythonic interface to MAPDL.
- `PyMAPDL Reader `_: Pythonic interface to read legacy MAPDL result files (MAPDL 14.5 and later)
- `PyPIM `_: Pythonic interface to communicate with the PIM (Product Instance Management) API
- `Granta MI BoM Analytics `_: Pythonic interface to Granta MI BoM Analytics services
- `Shared Components `_: Shared software components to enable package interoperability and minimize maintenance
Much effort is underway to continue expanding and developing packages in the
`PyAnsys GitHub `__ account. On the ``Issues`` page
for each package, you can post issues and request new features. You can also email
questions to `PyAnsys Support `_.
By default, the PyAnsys package installs these core modules:
- `PyAEDT`_
- `PyDPF-Core`_
- `PyDPF-Post`_
- `PyFluent`_
- `PyMAPDL`_
- `PyPIM`_
- `Granta MI BoM Analytics`_
- `Shared Components`_
However, the ``pyansys`` package also contains certain extra targets, which can be installed upon request:
- **mapdl-all**: this target installs the core packages and `PyMAPDL Reader`_.
- **fluent-all**: this target installs the core packages and `PyFluent-Parametric`_ and `PyFluent-Visualization`_.
- **all**: this target install all extra ``pyansys`` packages.
%package -n python3-pyansys
Summary: Pythonic interfaces to Ansys products
Provides: python-pyansys
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyansys
|pyansys| |python| |pypi| |GH-CI| |MIT| |black|
Welcome to the PyAnsys metapackage repository. This project originated as a single ``pyansys`` package,
which provides support to Ansys product releases. Compatibility of these packages amongst themselves
and with the Ansys product release they are linked to is ensured.
At this moment, this package ensures the compatibility between the following PyAnsys packages:
- `PyAEDT `_ : Pythonic interface to AEDT (Ansys Electronic Desktop)
- `PyDPF-Core `_ : Pythonic interface to DPF (Data Processing Framework) for building more advanced and customized workflows
- `PyDPF-Post `_ : Pythonic interface to DPF's postprocessing toolbox for manipulating and transforming simulation data
- `PyFluent `_ : Pythonic interface to Ansys Fluent
- `PyFluent-Parametric `_ : Pythonic interface to Ansys Fluent parametric workflows
- `PyFluent-Visualization `_ : Pythonic interface to visualize Ansys Fluent simulations using Python
- `PyMAPDL `_ : Pythonic interface to MAPDL.
- `PyMAPDL Reader `_: Pythonic interface to read legacy MAPDL result files (MAPDL 14.5 and later)
- `PyPIM `_: Pythonic interface to communicate with the PIM (Product Instance Management) API
- `Granta MI BoM Analytics `_: Pythonic interface to Granta MI BoM Analytics services
- `Shared Components `_: Shared software components to enable package interoperability and minimize maintenance
Much effort is underway to continue expanding and developing packages in the
`PyAnsys GitHub `__ account. On the ``Issues`` page
for each package, you can post issues and request new features. You can also email
questions to `PyAnsys Support `_.
By default, the PyAnsys package installs these core modules:
- `PyAEDT`_
- `PyDPF-Core`_
- `PyDPF-Post`_
- `PyFluent`_
- `PyMAPDL`_
- `PyPIM`_
- `Granta MI BoM Analytics`_
- `Shared Components`_
However, the ``pyansys`` package also contains certain extra targets, which can be installed upon request:
- **mapdl-all**: this target installs the core packages and `PyMAPDL Reader`_.
- **fluent-all**: this target installs the core packages and `PyFluent-Parametric`_ and `PyFluent-Visualization`_.
- **all**: this target install all extra ``pyansys`` packages.
%package help
Summary: Development documents and examples for pyansys
Provides: python3-pyansys-doc
%description help
|pyansys| |python| |pypi| |GH-CI| |MIT| |black|
Welcome to the PyAnsys metapackage repository. This project originated as a single ``pyansys`` package,
which provides support to Ansys product releases. Compatibility of these packages amongst themselves
and with the Ansys product release they are linked to is ensured.
At this moment, this package ensures the compatibility between the following PyAnsys packages:
- `PyAEDT `_ : Pythonic interface to AEDT (Ansys Electronic Desktop)
- `PyDPF-Core `_ : Pythonic interface to DPF (Data Processing Framework) for building more advanced and customized workflows
- `PyDPF-Post `_ : Pythonic interface to DPF's postprocessing toolbox for manipulating and transforming simulation data
- `PyFluent `_ : Pythonic interface to Ansys Fluent
- `PyFluent-Parametric `_ : Pythonic interface to Ansys Fluent parametric workflows
- `PyFluent-Visualization `_ : Pythonic interface to visualize Ansys Fluent simulations using Python
- `PyMAPDL `_ : Pythonic interface to MAPDL.
- `PyMAPDL Reader `_: Pythonic interface to read legacy MAPDL result files (MAPDL 14.5 and later)
- `PyPIM `_: Pythonic interface to communicate with the PIM (Product Instance Management) API
- `Granta MI BoM Analytics `_: Pythonic interface to Granta MI BoM Analytics services
- `Shared Components `_: Shared software components to enable package interoperability and minimize maintenance
Much effort is underway to continue expanding and developing packages in the
`PyAnsys GitHub `__ account. On the ``Issues`` page
for each package, you can post issues and request new features. You can also email
questions to `PyAnsys Support `_.
By default, the PyAnsys package installs these core modules:
- `PyAEDT`_
- `PyDPF-Core`_
- `PyDPF-Post`_
- `PyFluent`_
- `PyMAPDL`_
- `PyPIM`_
- `Granta MI BoM Analytics`_
- `Shared Components`_
However, the ``pyansys`` package also contains certain extra targets, which can be installed upon request:
- **mapdl-all**: this target installs the core packages and `PyMAPDL Reader`_.
- **fluent-all**: this target installs the core packages and `PyFluent-Parametric`_ and `PyFluent-Visualization`_.
- **all**: this target install all extra ``pyansys`` packages.
%prep
%autosetup -n pyansys-2023.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyansys -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 2023.1.3-1
- Package Spec generated