%global _empty_manifest_terminate_build 0
Name:		python-tcod
Version:	15.0.1
Release:	1
Summary:	The official Python port of libtcod.
License:	Simplified BSD License
URL:		https://github.com/libtcod/python-tcod
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/37/72/372e84a2f42d17b05e07cb6a7a0f8ec24b99a2d671ea6f095dfdb812eb0b/tcod-15.0.1.tar.gz

Requires:	python3-cffi
Requires:	python3-numpy
Requires:	python3-typing-extensions

%description


%package -n python3-tcod
Summary:	The official Python port of libtcod.
Provides:	python-tcod
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-tcod


%package help
Summary:	Development documents and examples for tcod
Provides:	python3-tcod-doc
%description help


%prep
%autosetup -n tcod-15.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tcod -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 15.0.1-1
- Package Spec generated