%global _empty_manifest_terminate_build 0
Name: python-mega
Version: 0.2.11
Release: 1
Summary: Python web scraper for DMCA evangelists.
License: MIT
URL: https://github.com/bl0nd/mega
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3f/dd/24edab88a347f6e9e8050b4b52a00654f81343a0361dd34e312b63dd5fd6/mega-0.2.11.tar.gz
BuildArch: noarch
Requires: python3-trio
Requires: python3-asks
Requires: python3-beautifulsoup4
Requires: python3-lxml
Requires: python3-requests
%description
Mega
[](https://pypi.python.org/pypi/mega/)
[](https://pypi.python.org/pypi/mega/)
mega
is an asynchronous web scraper for download links (primarily from Mega) of content such as movies, TV shows, music albums, and more.
## Table of Contents
- [Setup](#setup)
- [Getting Started](#start)
- [Usage](#usage)
- [License](#license)
## Setup
1. Create an account at https://forum.snahp.it/
2. Install mega: ```pip install mega```
3. Create mega's configuration file: ```mega config create```
## Getting Started
First, set your credentials in the configuration file:
```sh
$ mega config user.name USERNAME
$ mega config user.pass PASSWORD
```
To check that they're correct, run the above commands but omit USERNAME and PASSWORD.
Next, select the categories you want to check out:
```sh
$ mega config defaults
```
After applying your selected categories, you can their view their contents with:
```sh
$ mega
```
## Usage
```sh
usage: mega [OPTIONS]
mega brings you the latest content as soon as its available.
General options:
-h, --help Show this help message and exit
--version Show program version and exit
--config, config Activate configuration mode
--search, search Activate search mode
Configuration options:
user.name [NAME] Show current username or add username to .megarc
user.pass [PASS] Show current password or add password to .megarc
user.creds Show current username and password
defaults Select categories to request content from
create Create configuration file
Movement:
Normal and Search mode
j Page down
k Page up
b Back to search (search mode only)
q Quit
Default mode
j, ↑ Move up a listing or category
k, ↓ Move down a listing or category
l, ENTER Select listing, category, or menu option
→, ← Move to menu
```
## License
All files within this repo are released under the [MIT (OSI) License](https://en.wikipedia.org/wiki/MIT_License) as per the [LICENSE](https://github.com/bl0nd/mega/blob/master/LICENSE) file stored in the root of this repo.
%package -n python3-mega
Summary: Python web scraper for DMCA evangelists.
Provides: python-mega
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mega
Mega
[](https://pypi.python.org/pypi/mega/)
[](https://pypi.python.org/pypi/mega/)
mega
is an asynchronous web scraper for download links (primarily from Mega) of content such as movies, TV shows, music albums, and more.
## Table of Contents
- [Setup](#setup)
- [Getting Started](#start)
- [Usage](#usage)
- [License](#license)
## Setup
1. Create an account at https://forum.snahp.it/
2. Install mega: ```pip install mega```
3. Create mega's configuration file: ```mega config create```
## Getting Started
First, set your credentials in the configuration file:
```sh
$ mega config user.name USERNAME
$ mega config user.pass PASSWORD
```
To check that they're correct, run the above commands but omit USERNAME and PASSWORD.
Next, select the categories you want to check out:
```sh
$ mega config defaults
```
After applying your selected categories, you can their view their contents with:
```sh
$ mega
```
## Usage
```sh
usage: mega [OPTIONS]
mega brings you the latest content as soon as its available.
General options:
-h, --help Show this help message and exit
--version Show program version and exit
--config, config Activate configuration mode
--search, search Activate search mode
Configuration options:
user.name [NAME] Show current username or add username to .megarc
user.pass [PASS] Show current password or add password to .megarc
user.creds Show current username and password
defaults Select categories to request content from
create Create configuration file
Movement:
Normal and Search mode
j Page down
k Page up
b Back to search (search mode only)
q Quit
Default mode
j, ↑ Move up a listing or category
k, ↓ Move down a listing or category
l, ENTER Select listing, category, or menu option
→, ← Move to menu
```
## License
All files within this repo are released under the [MIT (OSI) License](https://en.wikipedia.org/wiki/MIT_License) as per the [LICENSE](https://github.com/bl0nd/mega/blob/master/LICENSE) file stored in the root of this repo.
%package help
Summary: Development documents and examples for mega
Provides: python3-mega-doc
%description help
Mega
[](https://pypi.python.org/pypi/mega/)
[](https://pypi.python.org/pypi/mega/)
mega
is an asynchronous web scraper for download links (primarily from Mega) of content such as movies, TV shows, music albums, and more.
## Table of Contents
- [Setup](#setup)
- [Getting Started](#start)
- [Usage](#usage)
- [License](#license)
## Setup
1. Create an account at https://forum.snahp.it/
2. Install mega: ```pip install mega```
3. Create mega's configuration file: ```mega config create```
## Getting Started
First, set your credentials in the configuration file:
```sh
$ mega config user.name USERNAME
$ mega config user.pass PASSWORD
```
To check that they're correct, run the above commands but omit USERNAME and PASSWORD.
Next, select the categories you want to check out:
```sh
$ mega config defaults
```
After applying your selected categories, you can their view their contents with:
```sh
$ mega
```
## Usage
```sh
usage: mega [OPTIONS]
mega brings you the latest content as soon as its available.
General options:
-h, --help Show this help message and exit
--version Show program version and exit
--config, config Activate configuration mode
--search, search Activate search mode
Configuration options:
user.name [NAME] Show current username or add username to .megarc
user.pass [PASS] Show current password or add password to .megarc
user.creds Show current username and password
defaults Select categories to request content from
create Create configuration file
Movement:
Normal and Search mode
j Page down
k Page up
b Back to search (search mode only)
q Quit
Default mode
j, ↑ Move up a listing or category
k, ↓ Move down a listing or category
l, ENTER Select listing, category, or menu option
→, ← Move to menu
```
## License
All files within this repo are released under the [MIT (OSI) License](https://en.wikipedia.org/wiki/MIT_License) as per the [LICENSE](https://github.com/bl0nd/mega/blob/master/LICENSE) file stored in the root of this repo.
%prep
%autosetup -n mega-0.2.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mega -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.2.11-1
- Package Spec generated