%global _empty_manifest_terminate_build 0
Name: python-silx
Version: 1.1.2
Release: 1
Summary: Software library for X-ray data analysis
License: MIT
URL: http://www.silx.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/aa/d4/edc7ded73dde49871240ea10c3f36ecbc2325768d0853c21b5dfa9600872/silx-1.1.2.tar.gz
Requires: python3-numpy
Requires: python3-setuptools
Requires: python3-h5py
Requires: python3-fabio
Requires: python3-pyopencl
Requires: python3-Mako
Requires: python3-qtconsole
Requires: python3-matplotlib
Requires: python3-PyOpenGL
Requires: python3-dateutil
Requires: python3-PyQt5
Requires: python3-hdf5plugin
Requires: python3-scipy
Requires: python3-Pillow
Requires: python3-pytest
Requires: python3-pytest-xvfb
Requires: python3-pytest-mock
%description
The purpose of the *silx* project is to provide a collection of Python packages to support the
development of data assessment, reduction and analysis applications at synchrotron
radiation facilities.
*silx* aims to provide reading/writing tools for different file formats, data reduction routines
and a set of Qt widgets to browse and visualise data.
The current version features:
* Support of `HDF5 `_,
`SPEC `_ and
`FabIO `_
images file formats.
* OpenCL-based data processing: image alignment (SIFT),
image processing (median filter, histogram),
filtered backprojection for tomography,
convolution
* Data reduction: histogramming, fitting, median filter
* A set of Qt widgets, including:
* 1D and 2D visualization widgets with a set of associated tools using multiple backends (matplotlib or OpenGL)
* OpenGL-based widgets to visualize data in 3D (scalar field with isosurface and cut plane, scatter plot)
* a unified browser for HDF5, SPEC and image file formats supporting inspection and
visualization of n-dimensional datasets.
* a set of applications:
* a unified viewer (*silx view filename*) for HDF5, SPEC and image file formats
|silxView|
* a unified converter to HDF5 format (*silx convert filename*)
%package -n python3-silx
Summary: Software library for X-ray data analysis
Provides: python-silx
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-silx
The purpose of the *silx* project is to provide a collection of Python packages to support the
development of data assessment, reduction and analysis applications at synchrotron
radiation facilities.
*silx* aims to provide reading/writing tools for different file formats, data reduction routines
and a set of Qt widgets to browse and visualise data.
The current version features:
* Support of `HDF5 `_,
`SPEC `_ and
`FabIO `_
images file formats.
* OpenCL-based data processing: image alignment (SIFT),
image processing (median filter, histogram),
filtered backprojection for tomography,
convolution
* Data reduction: histogramming, fitting, median filter
* A set of Qt widgets, including:
* 1D and 2D visualization widgets with a set of associated tools using multiple backends (matplotlib or OpenGL)
* OpenGL-based widgets to visualize data in 3D (scalar field with isosurface and cut plane, scatter plot)
* a unified browser for HDF5, SPEC and image file formats supporting inspection and
visualization of n-dimensional datasets.
* a set of applications:
* a unified viewer (*silx view filename*) for HDF5, SPEC and image file formats
|silxView|
* a unified converter to HDF5 format (*silx convert filename*)
%package help
Summary: Development documents and examples for silx
Provides: python3-silx-doc
%description help
The purpose of the *silx* project is to provide a collection of Python packages to support the
development of data assessment, reduction and analysis applications at synchrotron
radiation facilities.
*silx* aims to provide reading/writing tools for different file formats, data reduction routines
and a set of Qt widgets to browse and visualise data.
The current version features:
* Support of `HDF5 `_,
`SPEC `_ and
`FabIO `_
images file formats.
* OpenCL-based data processing: image alignment (SIFT),
image processing (median filter, histogram),
filtered backprojection for tomography,
convolution
* Data reduction: histogramming, fitting, median filter
* A set of Qt widgets, including:
* 1D and 2D visualization widgets with a set of associated tools using multiple backends (matplotlib or OpenGL)
* OpenGL-based widgets to visualize data in 3D (scalar field with isosurface and cut plane, scatter plot)
* a unified browser for HDF5, SPEC and image file formats supporting inspection and
visualization of n-dimensional datasets.
* a set of applications:
* a unified viewer (*silx view filename*) for HDF5, SPEC and image file formats
|silxView|
* a unified converter to HDF5 format (*silx convert filename*)
%prep
%autosetup -n silx-1.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-silx -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.1.2-1
- Package Spec generated