%global _empty_manifest_terminate_build 0 Name: python-composeml Version: 0.10.1 Release: 1 Summary: a framework for automated prediction engineering License: BSD 3-clause URL: https://pypi.org/project/composeml/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/98/d7/70264fb178f79f6c7b1981cf6780dc0a2feb4ed76bdea771882b38b971f7/composeml-0.10.1.tar.gz BuildArch: noarch Requires: python3-pandas Requires: python3-tqdm Requires: python3-matplotlib Requires: python3-seaborn Requires: python3-composeml[updater] Requires: python3-codecov Requires: python3-flake8 Requires: python3-isort Requires: python3-black Requires: python3-nbsphinx Requires: python3-pydata-sphinx-theme Requires: python3-Sphinx Requires: python3-sphinx-inline-tabs Requires: python3-sphinx-copybutton Requires: python3-myst-parser Requires: python3-nbconvert Requires: python3-ipython Requires: python3-pygments Requires: python3-jupyter Requires: python3-pandoc Requires: python3-ipykernel Requires: python3-scikit-learn Requires: python3-evalml Requires: python3-pip Requires: python3-pytest-cov Requires: python3-pytest-xdist Requires: python3-wheel Requires: python3-featuretools Requires: python3-woodwork Requires: python3-pyarrow Requires: python3-alteryx-open-src-update-checker %description

Compose

"Build better training examples in a fraction of the time."

Tests ReadTheDocs PyPI Version StackOverflow PyPI Downloads


[Compose](https://compose.alteryx.com) is a machine learning tool for automated prediction engineering. It allows you to structure prediction problems and generate labels for supervised learning. An end user defines an outcome of interest by writing a *labeling function*, then runs a search to automatically extract training examples from historical data. Its result is then provided to [Featuretools](https://docs.featuretools.com/) for automated feature engineering and subsequently to [EvalML](https://evalml.alteryx.com/) for automated machine learning. The workflow of an applied machine learning engineer then becomes:

Compose


By automating the early stage of the machine learning pipeline, our end user can easily define a task and solve it. See the [documentation](https://compose.alteryx.com) for more information. ## Installation Install with pip ``` python -m pip install composeml ``` or from the Conda-forge channel on [conda](https://anaconda.org/conda-forge/composeml): ``` conda install -c conda-forge composeml ``` ### Add-ons **Update checker** - Receive automatic notifications of new Compose releases ``` python -m pip install "composeml[update_checker]" ``` ## Example > Will a customer spend more than 300 in the next hour of transactions? In this example, we automatically generate new training examples from a historical dataset of transactions. ```python import composeml as cp df = cp.demos.load_transactions() df = df[df.columns[:7]] df.head() ```
transaction_id session_id transaction_time product_id amount customer_id device
298 1 2014-01-01 00:00:00 5 127.64 2 desktop
10 1 2014-01-01 00:09:45 5 57.39 2 desktop
495 1 2014-01-01 00:14:05 5 69.45 2 desktop
460 10 2014-01-01 02:33:50 5 123.19 2 tablet
302 10 2014-01-01 02:37:05 5 64.47 2 tablet
First, we represent the prediction problem with a labeling function and a label maker. ```python def total_spent(ds): return ds['amount'].sum() label_maker = cp.LabelMaker( target_dataframe_index="customer_id", time_index="transaction_time", labeling_function=total_spent, window_size="1h", ) ``` Then, we run a search to automatically generate the training examples. ```python label_times = label_maker.search( df.sort_values('transaction_time'), num_examples_per_instance=2, minimum_data='2014-01-01', drop_empty=False, verbose=False, ) label_times = label_times.threshold(300) label_times.head() ```
customer_id time total_spent
1 2014-01-01 00:00:00 True
1 2014-01-01 01:00:00 True
2 2014-01-01 00:00:00 False
2 2014-01-01 01:00:00 False
3 2014-01-01 00:00:00 False
We now have labels that are ready to use in [Featuretools](https://docs.featuretools.com/) to generate features. ## Support The Innovation Labs open source community is happy to provide support to users of Compose. Project support can be found in three places depending on the type of question: 1. For usage questions, use [Stack Overflow](https://stackoverflow.com/questions/tagged/compose-ml) with the `composeml` tag. 2. For bugs, issues, or feature requests start a Github [issue](https://github.com/alteryx/compose/issues/new). 3. For discussion regarding development on the core library, use [Slack](https://join.slack.com/t/alteryx-oss/shared_invite/zt-182tyvuxv-NzIn6eiCEf8TBziuKp0bNA). 4. For everything else, the core developers can be reached by email at open_source_support@alteryx.com ## Citing Compose Compose is built upon a newly defined part of the machine learning process — prediction engineering. If you use Compose, please consider citing this paper: James Max Kanter, Gillespie, Owen, Kalyan Veeramachaneni. [Label, Segment,Featurize: a cross domain framework for prediction engineering.](https://dai.lids.mit.edu/wp-content/uploads/2017/10/Pred_eng1.pdf) IEEE DSAA 2016. BibTeX entry: ```bibtex @inproceedings{kanter2016label, title={Label, segment, featurize: a cross domain framework for prediction engineering}, author={Kanter, James Max and Gillespie, Owen and Veeramachaneni, Kalyan}, booktitle={2016 IEEE International Conference on Data Science and Advanced Analytics (DSAA)}, pages={430--439}, year={2016}, organization={IEEE} } ``` ## Acknowledgements The open source development has been supported in part by DARPA's Data driven discovery of models program (D3M). ## Alteryx **Compose** is an open source project maintained by [Alteryx](https://www.alteryx.com). We developed Compose to enable flexible definition of the machine learning task. To see the other open source projects we’re working on visit [Alteryx Open Source](https://www.alteryx.com/open-source). If building impactful data science pipelines is important to you or your business, please get in touch.

Alteryx Open Source

%package -n python3-composeml Summary: a framework for automated prediction engineering Provides: python-composeml BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-composeml

Compose

"Build better training examples in a fraction of the time."

Tests ReadTheDocs PyPI Version StackOverflow PyPI Downloads


[Compose](https://compose.alteryx.com) is a machine learning tool for automated prediction engineering. It allows you to structure prediction problems and generate labels for supervised learning. An end user defines an outcome of interest by writing a *labeling function*, then runs a search to automatically extract training examples from historical data. Its result is then provided to [Featuretools](https://docs.featuretools.com/) for automated feature engineering and subsequently to [EvalML](https://evalml.alteryx.com/) for automated machine learning. The workflow of an applied machine learning engineer then becomes:

Compose


By automating the early stage of the machine learning pipeline, our end user can easily define a task and solve it. See the [documentation](https://compose.alteryx.com) for more information. ## Installation Install with pip ``` python -m pip install composeml ``` or from the Conda-forge channel on [conda](https://anaconda.org/conda-forge/composeml): ``` conda install -c conda-forge composeml ``` ### Add-ons **Update checker** - Receive automatic notifications of new Compose releases ``` python -m pip install "composeml[update_checker]" ``` ## Example > Will a customer spend more than 300 in the next hour of transactions? In this example, we automatically generate new training examples from a historical dataset of transactions. ```python import composeml as cp df = cp.demos.load_transactions() df = df[df.columns[:7]] df.head() ```
transaction_id session_id transaction_time product_id amount customer_id device
298 1 2014-01-01 00:00:00 5 127.64 2 desktop
10 1 2014-01-01 00:09:45 5 57.39 2 desktop
495 1 2014-01-01 00:14:05 5 69.45 2 desktop
460 10 2014-01-01 02:33:50 5 123.19 2 tablet
302 10 2014-01-01 02:37:05 5 64.47 2 tablet
First, we represent the prediction problem with a labeling function and a label maker. ```python def total_spent(ds): return ds['amount'].sum() label_maker = cp.LabelMaker( target_dataframe_index="customer_id", time_index="transaction_time", labeling_function=total_spent, window_size="1h", ) ``` Then, we run a search to automatically generate the training examples. ```python label_times = label_maker.search( df.sort_values('transaction_time'), num_examples_per_instance=2, minimum_data='2014-01-01', drop_empty=False, verbose=False, ) label_times = label_times.threshold(300) label_times.head() ```
customer_id time total_spent
1 2014-01-01 00:00:00 True
1 2014-01-01 01:00:00 True
2 2014-01-01 00:00:00 False
2 2014-01-01 01:00:00 False
3 2014-01-01 00:00:00 False
We now have labels that are ready to use in [Featuretools](https://docs.featuretools.com/) to generate features. ## Support The Innovation Labs open source community is happy to provide support to users of Compose. Project support can be found in three places depending on the type of question: 1. For usage questions, use [Stack Overflow](https://stackoverflow.com/questions/tagged/compose-ml) with the `composeml` tag. 2. For bugs, issues, or feature requests start a Github [issue](https://github.com/alteryx/compose/issues/new). 3. For discussion regarding development on the core library, use [Slack](https://join.slack.com/t/alteryx-oss/shared_invite/zt-182tyvuxv-NzIn6eiCEf8TBziuKp0bNA). 4. For everything else, the core developers can be reached by email at open_source_support@alteryx.com ## Citing Compose Compose is built upon a newly defined part of the machine learning process — prediction engineering. If you use Compose, please consider citing this paper: James Max Kanter, Gillespie, Owen, Kalyan Veeramachaneni. [Label, Segment,Featurize: a cross domain framework for prediction engineering.](https://dai.lids.mit.edu/wp-content/uploads/2017/10/Pred_eng1.pdf) IEEE DSAA 2016. BibTeX entry: ```bibtex @inproceedings{kanter2016label, title={Label, segment, featurize: a cross domain framework for prediction engineering}, author={Kanter, James Max and Gillespie, Owen and Veeramachaneni, Kalyan}, booktitle={2016 IEEE International Conference on Data Science and Advanced Analytics (DSAA)}, pages={430--439}, year={2016}, organization={IEEE} } ``` ## Acknowledgements The open source development has been supported in part by DARPA's Data driven discovery of models program (D3M). ## Alteryx **Compose** is an open source project maintained by [Alteryx](https://www.alteryx.com). We developed Compose to enable flexible definition of the machine learning task. To see the other open source projects we’re working on visit [Alteryx Open Source](https://www.alteryx.com/open-source). If building impactful data science pipelines is important to you or your business, please get in touch.

Alteryx Open Source

%package help Summary: Development documents and examples for composeml Provides: python3-composeml-doc %description help

Compose

"Build better training examples in a fraction of the time."

Tests ReadTheDocs PyPI Version StackOverflow PyPI Downloads


[Compose](https://compose.alteryx.com) is a machine learning tool for automated prediction engineering. It allows you to structure prediction problems and generate labels for supervised learning. An end user defines an outcome of interest by writing a *labeling function*, then runs a search to automatically extract training examples from historical data. Its result is then provided to [Featuretools](https://docs.featuretools.com/) for automated feature engineering and subsequently to [EvalML](https://evalml.alteryx.com/) for automated machine learning. The workflow of an applied machine learning engineer then becomes:

Compose


By automating the early stage of the machine learning pipeline, our end user can easily define a task and solve it. See the [documentation](https://compose.alteryx.com) for more information. ## Installation Install with pip ``` python -m pip install composeml ``` or from the Conda-forge channel on [conda](https://anaconda.org/conda-forge/composeml): ``` conda install -c conda-forge composeml ``` ### Add-ons **Update checker** - Receive automatic notifications of new Compose releases ``` python -m pip install "composeml[update_checker]" ``` ## Example > Will a customer spend more than 300 in the next hour of transactions? In this example, we automatically generate new training examples from a historical dataset of transactions. ```python import composeml as cp df = cp.demos.load_transactions() df = df[df.columns[:7]] df.head() ```
transaction_id session_id transaction_time product_id amount customer_id device
298 1 2014-01-01 00:00:00 5 127.64 2 desktop
10 1 2014-01-01 00:09:45 5 57.39 2 desktop
495 1 2014-01-01 00:14:05 5 69.45 2 desktop
460 10 2014-01-01 02:33:50 5 123.19 2 tablet
302 10 2014-01-01 02:37:05 5 64.47 2 tablet
First, we represent the prediction problem with a labeling function and a label maker. ```python def total_spent(ds): return ds['amount'].sum() label_maker = cp.LabelMaker( target_dataframe_index="customer_id", time_index="transaction_time", labeling_function=total_spent, window_size="1h", ) ``` Then, we run a search to automatically generate the training examples. ```python label_times = label_maker.search( df.sort_values('transaction_time'), num_examples_per_instance=2, minimum_data='2014-01-01', drop_empty=False, verbose=False, ) label_times = label_times.threshold(300) label_times.head() ```
customer_id time total_spent
1 2014-01-01 00:00:00 True
1 2014-01-01 01:00:00 True
2 2014-01-01 00:00:00 False
2 2014-01-01 01:00:00 False
3 2014-01-01 00:00:00 False
We now have labels that are ready to use in [Featuretools](https://docs.featuretools.com/) to generate features. ## Support The Innovation Labs open source community is happy to provide support to users of Compose. Project support can be found in three places depending on the type of question: 1. For usage questions, use [Stack Overflow](https://stackoverflow.com/questions/tagged/compose-ml) with the `composeml` tag. 2. For bugs, issues, or feature requests start a Github [issue](https://github.com/alteryx/compose/issues/new). 3. For discussion regarding development on the core library, use [Slack](https://join.slack.com/t/alteryx-oss/shared_invite/zt-182tyvuxv-NzIn6eiCEf8TBziuKp0bNA). 4. For everything else, the core developers can be reached by email at open_source_support@alteryx.com ## Citing Compose Compose is built upon a newly defined part of the machine learning process — prediction engineering. If you use Compose, please consider citing this paper: James Max Kanter, Gillespie, Owen, Kalyan Veeramachaneni. [Label, Segment,Featurize: a cross domain framework for prediction engineering.](https://dai.lids.mit.edu/wp-content/uploads/2017/10/Pred_eng1.pdf) IEEE DSAA 2016. BibTeX entry: ```bibtex @inproceedings{kanter2016label, title={Label, segment, featurize: a cross domain framework for prediction engineering}, author={Kanter, James Max and Gillespie, Owen and Veeramachaneni, Kalyan}, booktitle={2016 IEEE International Conference on Data Science and Advanced Analytics (DSAA)}, pages={430--439}, year={2016}, organization={IEEE} } ``` ## Acknowledgements The open source development has been supported in part by DARPA's Data driven discovery of models program (D3M). ## Alteryx **Compose** is an open source project maintained by [Alteryx](https://www.alteryx.com). We developed Compose to enable flexible definition of the machine learning task. To see the other open source projects we’re working on visit [Alteryx Open Source](https://www.alteryx.com/open-source). If building impactful data science pipelines is important to you or your business, please get in touch.

Alteryx Open Source

%prep %autosetup -n composeml-0.10.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-composeml -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Apr 11 2023 Python_Bot - 0.10.1-1 - Package Spec generated