%global _empty_manifest_terminate_build 0
Name: python-py2app
Version: 0.28.5
Release: 1
Summary: Create standalone Mac OS X applications with Python
License: MIT or PSF License
URL: http://github.com/ronaldoussoren/py2app
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fd/83/f4e467a1e26c0c22ad1a8ae6a9def240bed934e9515be83a41e2bb423284/py2app-0.28.5.tar.gz
BuildArch: noarch
Requires: python3-altgraph
Requires: python3-modulegraph
Requires: python3-macholib
%description
* `Documentation `_
* `Issue Tracker `_
* `Repository `_
%package -n python3-py2app
Summary: Create standalone Mac OS X applications with Python
Provides: python-py2app
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-py2app
* `Documentation `_
* `Issue Tracker `_
* `Repository `_
%package help
Summary: Development documents and examples for py2app
Provides: python3-py2app-doc
%description help
* `Documentation `_
* `Issue Tracker `_
* `Repository `_
%prep
%autosetup -n py2app-0.28.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-py2app -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 0.28.5-1
- Package Spec generated