%global _empty_manifest_terminate_build 0
Name:		python-supervisor-stdout
Version:	0.1.1
Release:	1
Summary:	UNKNOWN
License:	BSD
URL:		https://github.com/coderanger/supervisor-stdout
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ef/98/557ea85b26753c990a00159e32ead242be617754b0f9f2683b0d4350a1b2/supervisor-stdout-0.1.1.tar.gz
BuildArch:	noarch


%description
# supervisor-stdout

A simple [supervisord](http://supervisord.org/) event listener to relay
process output to supervisor's stdout.

This is useful in situations where the output will be collected and set to
external logging framework, such as Heroku.

## Installation

Just install via pip or add to your requirements.txt:

    pip install supervisor-stdout

## Usage

An example supervisord.conf:

    [supervisord]
    nodaemon = true

    [program:web]
    command = ...
    stdout_events_enabled = true
    stderr_events_enabled = true

    [eventlistener:stdout]
    command = supervisor_stdout
    buffer_size = 100
    events = PROCESS_LOG
    result_handler = supervisor_stdout:event_handler

%package -n python3-supervisor-stdout
Summary:	UNKNOWN
Provides:	python-supervisor-stdout
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-supervisor-stdout
# supervisor-stdout

A simple [supervisord](http://supervisord.org/) event listener to relay
process output to supervisor's stdout.

This is useful in situations where the output will be collected and set to
external logging framework, such as Heroku.

## Installation

Just install via pip or add to your requirements.txt:

    pip install supervisor-stdout

## Usage

An example supervisord.conf:

    [supervisord]
    nodaemon = true

    [program:web]
    command = ...
    stdout_events_enabled = true
    stderr_events_enabled = true

    [eventlistener:stdout]
    command = supervisor_stdout
    buffer_size = 100
    events = PROCESS_LOG
    result_handler = supervisor_stdout:event_handler

%package help
Summary:	Development documents and examples for supervisor-stdout
Provides:	python3-supervisor-stdout-doc
%description help
# supervisor-stdout

A simple [supervisord](http://supervisord.org/) event listener to relay
process output to supervisor's stdout.

This is useful in situations where the output will be collected and set to
external logging framework, such as Heroku.

## Installation

Just install via pip or add to your requirements.txt:

    pip install supervisor-stdout

## Usage

An example supervisord.conf:

    [supervisord]
    nodaemon = true

    [program:web]
    command = ...
    stdout_events_enabled = true
    stderr_events_enabled = true

    [eventlistener:stdout]
    command = supervisor_stdout
    buffer_size = 100
    events = PROCESS_LOG
    result_handler = supervisor_stdout:event_handler

%prep
%autosetup -n supervisor-stdout-0.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-supervisor-stdout -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
- Package Spec generated