%global _empty_manifest_terminate_build 0
Name:		python-cli-exit-tools
Version:	1.2.3.2
Release:	1
Summary:	functions to exit an cli application properly
License:	MIT License
URL:		https://github.com/bitranox/cli_exit_tools
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5d/4d/27fcad9f189a53f85e4c23f16444890b3df483469c96c258acd7dcc1e079/cli_exit_tools-1.2.3.2.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-lib-detect-testenv

%description
Version v1.2.3.2 as of 2022-06-02 see `Changelog`_
|build_badge| |license| |jupyter| |pypi| |pypi-downloads| |black|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
small toolset to properly exit a cli application:
- print the traceback information (can be set with commandline option)
- get a proper exit code from the Exception
- flush the streams, to make sure output is written in proper order

%package -n python3-cli-exit-tools
Summary:	functions to exit an cli application properly
Provides:	python-cli-exit-tools
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cli-exit-tools
Version v1.2.3.2 as of 2022-06-02 see `Changelog`_
|build_badge| |license| |jupyter| |pypi| |pypi-downloads| |black|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
small toolset to properly exit a cli application:
- print the traceback information (can be set with commandline option)
- get a proper exit code from the Exception
- flush the streams, to make sure output is written in proper order

%package help
Summary:	Development documents and examples for cli-exit-tools
Provides:	python3-cli-exit-tools-doc
%description help
Version v1.2.3.2 as of 2022-06-02 see `Changelog`_
|build_badge| |license| |jupyter| |pypi| |pypi-downloads| |black|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
small toolset to properly exit a cli application:
- print the traceback information (can be set with commandline option)
- get a proper exit code from the Exception
- flush the streams, to make sure output is written in proper order

%prep
%autosetup -n cli-exit-tools-1.2.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cli-exit-tools -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.3.2-1
- Package Spec generated