%global _empty_manifest_terminate_build 0
Name: python-gwdatafind
Version: 1.1.3
Release: 1
Summary: The GWDataFind data discovery client
License: GPL-3.0-or-later
URL: https://gwdatafind.readthedocs.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d0/31/67b7da7111a5a9965b666f015f302daf6daac072f5818c7823ab4126d8b7/gwdatafind-1.1.3.tar.gz
BuildArch: noarch
Requires: python3-igwn-auth-utils
Requires: python3-ligo-segments
Requires: python3-numpydoc
Requires: python3-sphinx
Requires: python3-sphinx-argparse
Requires: python3-sphinx-automodapi
Requires: python3-sphinx-rtd-theme
Requires: python3-flake8
Requires: python3-flake8-bandit
Requires: python3-flake8-docstrings
Requires: python3-radon
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-requests-mock
%description
# GWDataFind
The GWDataFind data discovery client.
The GWDataFind service allows users to query for the location of
Gravitational-Wave Frame (GWF) files containing data from the current
gravitational-wave detectors.
[![PyPI version](https://badge.fury.io/py/gwdatafind.svg)](http://badge.fury.io/py/gwdatafind)
[![Linux status](https://git.ligo.org/lscsoft/gwdatafind/badges/main/pipeline.svg)](https://git.ligo.org/lscsoft/gwdatafind/commits/main)
[![Windows status](https://ci.appveyor.com/api/projects/status/js6gql8960qa9pkl?svg=true)](https://ci.appveyor.com/project/duncanmmacleod/gwdatafind)
[![License](https://img.shields.io/pypi/l/gwdatafind.svg)](https://choosealicense.com/licenses/gpl-3.0/)
[![Documentation status](https://readthedocs.org/projects/gwdatafind/badge/?version=latest)](https://gwdatafind.readthedocs.io/en/latest/?badge=latest)
## Installation
The simplest installation is via `pip`:
```bash
python -m pip install gwdatafind
```
This package is also available as a Conda package:
```bash
conda install -c conda-forge gwdatafind
```
## Basic Usage
To find the URLs of all `H1_R` files for the LIGO-Hanford observatory in
a given GPS interval:
```python
>>> from gwdatafind import find_urls
>>> find_urls('H', 'H1_R', 1198800018, 1198800618)
```
To utillise connection pooling, create a `Session`:
```python
>>> from gwdatafind import (find_urls, Session)
>>> with Session() as sess:
... for ifo in ("H", "L"):
... urls[ifo] = find_urls(
... ifo,
... f"{ifo}1_R",
... 1198800018,
... 1198800618,
... session=sess,
... )
## On the command-line
GWDataFind can also be executed via the command-line client, for full details
run
```bash
$ python -m gwdatafind --help
```
For more documentation, see .
%package -n python3-gwdatafind
Summary: The GWDataFind data discovery client
Provides: python-gwdatafind
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gwdatafind
# GWDataFind
The GWDataFind data discovery client.
The GWDataFind service allows users to query for the location of
Gravitational-Wave Frame (GWF) files containing data from the current
gravitational-wave detectors.
[![PyPI version](https://badge.fury.io/py/gwdatafind.svg)](http://badge.fury.io/py/gwdatafind)
[![Linux status](https://git.ligo.org/lscsoft/gwdatafind/badges/main/pipeline.svg)](https://git.ligo.org/lscsoft/gwdatafind/commits/main)
[![Windows status](https://ci.appveyor.com/api/projects/status/js6gql8960qa9pkl?svg=true)](https://ci.appveyor.com/project/duncanmmacleod/gwdatafind)
[![License](https://img.shields.io/pypi/l/gwdatafind.svg)](https://choosealicense.com/licenses/gpl-3.0/)
[![Documentation status](https://readthedocs.org/projects/gwdatafind/badge/?version=latest)](https://gwdatafind.readthedocs.io/en/latest/?badge=latest)
## Installation
The simplest installation is via `pip`:
```bash
python -m pip install gwdatafind
```
This package is also available as a Conda package:
```bash
conda install -c conda-forge gwdatafind
```
## Basic Usage
To find the URLs of all `H1_R` files for the LIGO-Hanford observatory in
a given GPS interval:
```python
>>> from gwdatafind import find_urls
>>> find_urls('H', 'H1_R', 1198800018, 1198800618)
```
To utillise connection pooling, create a `Session`:
```python
>>> from gwdatafind import (find_urls, Session)
>>> with Session() as sess:
... for ifo in ("H", "L"):
... urls[ifo] = find_urls(
... ifo,
... f"{ifo}1_R",
... 1198800018,
... 1198800618,
... session=sess,
... )
## On the command-line
GWDataFind can also be executed via the command-line client, for full details
run
```bash
$ python -m gwdatafind --help
```
For more documentation, see .
%package help
Summary: Development documents and examples for gwdatafind
Provides: python3-gwdatafind-doc
%description help
# GWDataFind
The GWDataFind data discovery client.
The GWDataFind service allows users to query for the location of
Gravitational-Wave Frame (GWF) files containing data from the current
gravitational-wave detectors.
[![PyPI version](https://badge.fury.io/py/gwdatafind.svg)](http://badge.fury.io/py/gwdatafind)
[![Linux status](https://git.ligo.org/lscsoft/gwdatafind/badges/main/pipeline.svg)](https://git.ligo.org/lscsoft/gwdatafind/commits/main)
[![Windows status](https://ci.appveyor.com/api/projects/status/js6gql8960qa9pkl?svg=true)](https://ci.appveyor.com/project/duncanmmacleod/gwdatafind)
[![License](https://img.shields.io/pypi/l/gwdatafind.svg)](https://choosealicense.com/licenses/gpl-3.0/)
[![Documentation status](https://readthedocs.org/projects/gwdatafind/badge/?version=latest)](https://gwdatafind.readthedocs.io/en/latest/?badge=latest)
## Installation
The simplest installation is via `pip`:
```bash
python -m pip install gwdatafind
```
This package is also available as a Conda package:
```bash
conda install -c conda-forge gwdatafind
```
## Basic Usage
To find the URLs of all `H1_R` files for the LIGO-Hanford observatory in
a given GPS interval:
```python
>>> from gwdatafind import find_urls
>>> find_urls('H', 'H1_R', 1198800018, 1198800618)
```
To utillise connection pooling, create a `Session`:
```python
>>> from gwdatafind import (find_urls, Session)
>>> with Session() as sess:
... for ifo in ("H", "L"):
... urls[ifo] = find_urls(
... ifo,
... f"{ifo}1_R",
... 1198800018,
... 1198800618,
... session=sess,
... )
## On the command-line
GWDataFind can also be executed via the command-line client, for full details
run
```bash
$ python -m gwdatafind --help
```
For more documentation, see .
%prep
%autosetup -n gwdatafind-1.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gwdatafind -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 11 2023 Python_Bot - 1.1.3-1
- Package Spec generated