%global _empty_manifest_terminate_build 0
Name: python-perspective-python
Version: 2.0.1
Release: 1
Summary: Python bindings and JupyterLab integration for Perspective
License: Apache 2.0
URL: https://github.com/finos/perspective
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/08/c1/ea69d50036ca9f81d158508c507a05a05a6cb9e1ab82532ea627f7e11339/perspective-python-2.0.1.tar.gz
Requires: python3-ipywidgets
Requires: python3-future
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-dateutil
Requires: python3-traitlets
Requires: python3-aiohttp
Requires: python3-black
Requires: python3-Faker
Requires: python3-flake8
Requires: python3-flake8-black
Requires: python3-httpx
Requires: python3-jupyter-packaging
Requires: python3-pip
Requires: python3-psutil
Requires: python3-pybind11
Requires: python3-pyarrow
Requires: python3-pytest
Requires: python3-pytest-aiohttp
Requires: python3-pytest-asyncio
Requires: python3-pytest-cov
Requires: python3-pytest-check-links
Requires: python3-pytest-tornado
Requires: python3-pytz
Requires: python3-Sphinx
Requires: python3-sphinx-markdown-builder
Requires: python3-wheel
Requires: python3-ipywidgets
Requires: python3-future
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-dateutil
Requires: python3-traitlets
Requires: python3-aiohttp
Requires: python3-jupyterlab
Requires: python3-fastapi
Requires: python3-starlette
Requires: python3-tornado
Requires: python3-black
Requires: python3-Faker
Requires: python3-flake8
Requires: python3-flake8-black
Requires: python3-httpx
Requires: python3-jupyter-packaging
Requires: python3-pip
Requires: python3-psutil
Requires: python3-pybind11
Requires: python3-pyarrow
Requires: python3-pytest
Requires: python3-pytest-aiohttp
Requires: python3-pytest-asyncio
Requires: python3-pytest-cov
Requires: python3-pytest-check-links
Requires: python3-pytest-tornado
Requires: python3-pytz
Requires: python3-Sphinx
Requires: python3-sphinx-markdown-builder
Requires: python3-wheel
Requires: python3-ipywidgets
Requires: python3-future
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-dateutil
Requires: python3-traitlets
Requires: python3-aiohttp
Requires: python3-jupyterlab
Requires: python3-fastapi
Requires: python3-starlette
Requires: python3-tornado
Requires: python3-fastapi
Requires: python3-starlette
Requires: python3-jupyterlab
Requires: python3-fastapi
Requires: python3-starlette
Requires: python3-tornado
%description
[](https://www.npmjs.com/package/@finos/perspective)
[](https://pypi.python.org/pypi/perspective-python)
[](https://github.com/finos/perspective/actions/workflows/build.yml)
Perspective is an interactive analytics and data visualization component,
which is especially well-suited for large and/or streaming
datasets. Use it to create user-configurable reports, dashboards, notebooks and
applications, then deploy stand-alone in the browser, or in concert with Python
and/or [Jupyterlab](https://jupyterlab.readthedocs.io/en/stable/).
### Features
- A fast, memory efficient streaming query engine, written in
C++ and compiled for both [WebAssembly](https://webassembly.org/) and
[Python](https://www.python.org/), with read/write/streaming for
[Apache Arrow](https://arrow.apache.org/), and a high-performance columnar
expression language based on [ExprTK](https://github.com/ArashPartow/exprtk).
- A framework-agnostic User Interface packaged as a
[Custom Element](https://developer.mozilla.org/en-US/docs/Web/Web_Components/Using_custom_elements),
powered either in-browser via WebAssembly or virtually via
WebSocket server (Python/Node).
- A [JupyterLab](https://jupyter.org/) widget and Python client library, for
interactive data analysis in a notebook, as well as _scalable_ production
[Voila](https://github.com/voila-dashboards/voila) applications.
### Examples
editable | csv | fractal |
 |  |  |
market | raycasting | evictions |
 |  |  |
streaming | covid | movies |
 |  |  |
superstore | citibike | olympics |
 |  |  |
jupyterlab | magic | nft |
 |  |  |
nypd ccrb |
 |
### Documentation
- [Project Site](https://perspective.finos.org/)
- User Guides
- [Javascript User Guide](https://perspective.finos.org/docs/js.html)
- [Python User Guide](https://perspective.finos.org/docs/python.html)
- [Developer Guide](https://perspective.finos.org/docs/development.html)
- Concepts
- [Table](https://perspective.finos.org/docs/table.html)
- [View](https://perspective.finos.org/docs/view.html)
- [Expression Columns](https://perspective.finos.org/docs/expressions.html)
- [Data Binding](https://perspective.finos.org/docs/table.html)
- API
- [Perspective API](https://github.com/finos/perspective/blob/master/packages/perspective/README.md)
- [Perspective Viewer API](https://perspective.finos.org/docs/obj/perspective-viewer/)
- [Perspective Python API](https://perspective.finos.org/docs/obj/perspective-python.html)
### Community / Media
- [Streaming, cross-sectional data visualization in JupyterLab | Junyuan Tan, JupyterCon 2020](http://www.youtube.com/watch?v=IO-HJsGdleE)
- [Perspective in 3D | Andrew Stein, Open Source in Finance Forum NYC 2022](https://www.youtube.com/watch?v=0ut-ynvBpGI)
- [Build an order book simulation with Perspective | Andrew Stein, FINOS Open Source in Fintech Meetup 2021](https://www.youtube.com/watch?v=no0qChjvdgQ)
- [Perspective project case study | FINOS](https://www.finos.org/hubfs/FINOS/assets/FINOS%20Perspective%20Case%20Study.pdf)
%package -n python3-perspective-python
Summary: Python bindings and JupyterLab integration for Perspective
Provides: python-perspective-python
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-perspective-python
[](https://www.npmjs.com/package/@finos/perspective)
[](https://pypi.python.org/pypi/perspective-python)
[](https://github.com/finos/perspective/actions/workflows/build.yml)
Perspective is an interactive analytics and data visualization component,
which is especially well-suited for large and/or streaming
datasets. Use it to create user-configurable reports, dashboards, notebooks and
applications, then deploy stand-alone in the browser, or in concert with Python
and/or [Jupyterlab](https://jupyterlab.readthedocs.io/en/stable/).
### Features
- A fast, memory efficient streaming query engine, written in
C++ and compiled for both [WebAssembly](https://webassembly.org/) and
[Python](https://www.python.org/), with read/write/streaming for
[Apache Arrow](https://arrow.apache.org/), and a high-performance columnar
expression language based on [ExprTK](https://github.com/ArashPartow/exprtk).
- A framework-agnostic User Interface packaged as a
[Custom Element](https://developer.mozilla.org/en-US/docs/Web/Web_Components/Using_custom_elements),
powered either in-browser via WebAssembly or virtually via
WebSocket server (Python/Node).
- A [JupyterLab](https://jupyter.org/) widget and Python client library, for
interactive data analysis in a notebook, as well as _scalable_ production
[Voila](https://github.com/voila-dashboards/voila) applications.
### Examples
editable | csv | fractal |
 |  |  |
market | raycasting | evictions |
 |  |  |
streaming | covid | movies |
 |  |  |
superstore | citibike | olympics |
 |  |  |
jupyterlab | magic | nft |
 |  |  |
nypd ccrb |
 |
### Documentation
- [Project Site](https://perspective.finos.org/)
- User Guides
- [Javascript User Guide](https://perspective.finos.org/docs/js.html)
- [Python User Guide](https://perspective.finos.org/docs/python.html)
- [Developer Guide](https://perspective.finos.org/docs/development.html)
- Concepts
- [Table](https://perspective.finos.org/docs/table.html)
- [View](https://perspective.finos.org/docs/view.html)
- [Expression Columns](https://perspective.finos.org/docs/expressions.html)
- [Data Binding](https://perspective.finos.org/docs/table.html)
- API
- [Perspective API](https://github.com/finos/perspective/blob/master/packages/perspective/README.md)
- [Perspective Viewer API](https://perspective.finos.org/docs/obj/perspective-viewer/)
- [Perspective Python API](https://perspective.finos.org/docs/obj/perspective-python.html)
### Community / Media
- [Streaming, cross-sectional data visualization in JupyterLab | Junyuan Tan, JupyterCon 2020](http://www.youtube.com/watch?v=IO-HJsGdleE)
- [Perspective in 3D | Andrew Stein, Open Source in Finance Forum NYC 2022](https://www.youtube.com/watch?v=0ut-ynvBpGI)
- [Build an order book simulation with Perspective | Andrew Stein, FINOS Open Source in Fintech Meetup 2021](https://www.youtube.com/watch?v=no0qChjvdgQ)
- [Perspective project case study | FINOS](https://www.finos.org/hubfs/FINOS/assets/FINOS%20Perspective%20Case%20Study.pdf)
%package help
Summary: Development documents and examples for perspective-python
Provides: python3-perspective-python-doc
%description help
[](https://www.npmjs.com/package/@finos/perspective)
[](https://pypi.python.org/pypi/perspective-python)
[](https://github.com/finos/perspective/actions/workflows/build.yml)
Perspective is an interactive analytics and data visualization component,
which is especially well-suited for large and/or streaming
datasets. Use it to create user-configurable reports, dashboards, notebooks and
applications, then deploy stand-alone in the browser, or in concert with Python
and/or [Jupyterlab](https://jupyterlab.readthedocs.io/en/stable/).
### Features
- A fast, memory efficient streaming query engine, written in
C++ and compiled for both [WebAssembly](https://webassembly.org/) and
[Python](https://www.python.org/), with read/write/streaming for
[Apache Arrow](https://arrow.apache.org/), and a high-performance columnar
expression language based on [ExprTK](https://github.com/ArashPartow/exprtk).
- A framework-agnostic User Interface packaged as a
[Custom Element](https://developer.mozilla.org/en-US/docs/Web/Web_Components/Using_custom_elements),
powered either in-browser via WebAssembly or virtually via
WebSocket server (Python/Node).
- A [JupyterLab](https://jupyter.org/) widget and Python client library, for
interactive data analysis in a notebook, as well as _scalable_ production
[Voila](https://github.com/voila-dashboards/voila) applications.
### Examples
editable | csv | fractal |
 |  |  |
market | raycasting | evictions |
 |  |  |
streaming | covid | movies |
 |  |  |
superstore | citibike | olympics |
 |  |  |
jupyterlab | magic | nft |
 |  |  |
nypd ccrb |
 |
### Documentation
- [Project Site](https://perspective.finos.org/)
- User Guides
- [Javascript User Guide](https://perspective.finos.org/docs/js.html)
- [Python User Guide](https://perspective.finos.org/docs/python.html)
- [Developer Guide](https://perspective.finos.org/docs/development.html)
- Concepts
- [Table](https://perspective.finos.org/docs/table.html)
- [View](https://perspective.finos.org/docs/view.html)
- [Expression Columns](https://perspective.finos.org/docs/expressions.html)
- [Data Binding](https://perspective.finos.org/docs/table.html)
- API
- [Perspective API](https://github.com/finos/perspective/blob/master/packages/perspective/README.md)
- [Perspective Viewer API](https://perspective.finos.org/docs/obj/perspective-viewer/)
- [Perspective Python API](https://perspective.finos.org/docs/obj/perspective-python.html)
### Community / Media
- [Streaming, cross-sectional data visualization in JupyterLab | Junyuan Tan, JupyterCon 2020](http://www.youtube.com/watch?v=IO-HJsGdleE)
- [Perspective in 3D | Andrew Stein, Open Source in Finance Forum NYC 2022](https://www.youtube.com/watch?v=0ut-ynvBpGI)
- [Build an order book simulation with Perspective | Andrew Stein, FINOS Open Source in Fintech Meetup 2021](https://www.youtube.com/watch?v=no0qChjvdgQ)
- [Perspective project case study | FINOS](https://www.finos.org/hubfs/FINOS/assets/FINOS%20Perspective%20Case%20Study.pdf)
%prep
%autosetup -n perspective-python-2.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-perspective-python -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 2.0.1-1
- Package Spec generated