%global _empty_manifest_terminate_build 0
Name: python-psq
Version: 0.8.0
Release: 1
Summary: A simple task queue using Google Cloud Pub/Sub
License: Apache Software License
URL: https://github.com/GoogleCloudPlatform/psq
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/11/f4/bf27d21679fd1558840c50cb8bc04348992a2d91d7b2be3c81a06f06a6ed/psq-0.8.0.tar.gz
BuildArch: noarch
Requires: python3-google-cloud-pubsub
Requires: python3-google-cloud-datastore
Requires: python3-werkzeug
Requires: python3-click
Requires: python3-colorlog
%description
|Build Status| |Coverage Status| |PyPI Version|
is provided without support. It is intended as a sample library for
demonstrating a set of use cases for Google Cloud Pub/Sub. The official
Pub/Sub client library should be used for production applications.
``psq`` is an example Python implementation of a simple distributed task
queue using `Google Cloud Pub/Sub `__.
``psq`` requires minimal configuration and relies on Cloud Pub/Sub to
provide scalable and reliable messaging.
``psq`` is intentionally similar to `rq `__ and
`simpleq `__, and takes some
inspiration from `celery `__ and `this
blog
post `__.
%package -n python3-psq
Summary: A simple task queue using Google Cloud Pub/Sub
Provides: python-psq
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-psq
|Build Status| |Coverage Status| |PyPI Version|
is provided without support. It is intended as a sample library for
demonstrating a set of use cases for Google Cloud Pub/Sub. The official
Pub/Sub client library should be used for production applications.
``psq`` is an example Python implementation of a simple distributed task
queue using `Google Cloud Pub/Sub `__.
``psq`` requires minimal configuration and relies on Cloud Pub/Sub to
provide scalable and reliable messaging.
``psq`` is intentionally similar to `rq `__ and
`simpleq `__, and takes some
inspiration from `celery `__ and `this
blog
post `__.
%package help
Summary: Development documents and examples for psq
Provides: python3-psq-doc
%description help
|Build Status| |Coverage Status| |PyPI Version|
is provided without support. It is intended as a sample library for
demonstrating a set of use cases for Google Cloud Pub/Sub. The official
Pub/Sub client library should be used for production applications.
``psq`` is an example Python implementation of a simple distributed task
queue using `Google Cloud Pub/Sub `__.
``psq`` requires minimal configuration and relies on Cloud Pub/Sub to
provide scalable and reliable messaging.
``psq`` is intentionally similar to `rq `__ and
`simpleq `__, and takes some
inspiration from `celery `__ and `this
blog
post `__.
%prep
%autosetup -n psq-0.8.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-psq -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 0.8.0-1
- Package Spec generated