%global _empty_manifest_terminate_build 0
Name:		python-pip-install
Version:	1.3.5
Release:	1
Summary:	Install packages from within code
License:	MIT
URL:		https://github.com/eugenekolo/pip-install
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a4/1b/434398102b43475f19321c444c6f7015f46b96d1bcc2435450033309670f/pip-install-1.3.5.tar.gz
BuildArch:	noarch


%description
# install

A package to install pip packages from within code.

Requires Python 2.7+, 3.5+

Usage:
```
import install
install.install('pkg_you_want')

# ... after retrieving a requirements.txt from the web or somewhere else
install.install('requirements.txt', requirements=True)

# ... need arbitary options?
install.install('my_pkg', pip_options=['--isolated'], install_options=['--no-clean', '--pre'])
```




%package -n python3-pip-install
Summary:	Install packages from within code
Provides:	python-pip-install
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pip-install
# install

A package to install pip packages from within code.

Requires Python 2.7+, 3.5+

Usage:
```
import install
install.install('pkg_you_want')

# ... after retrieving a requirements.txt from the web or somewhere else
install.install('requirements.txt', requirements=True)

# ... need arbitary options?
install.install('my_pkg', pip_options=['--isolated'], install_options=['--no-clean', '--pre'])
```




%package help
Summary:	Development documents and examples for pip-install
Provides:	python3-pip-install-doc
%description help
# install

A package to install pip packages from within code.

Requires Python 2.7+, 3.5+

Usage:
```
import install
install.install('pkg_you_want')

# ... after retrieving a requirements.txt from the web or somewhere else
install.install('requirements.txt', requirements=True)

# ... need arbitary options?
install.install('my_pkg', pip_options=['--isolated'], install_options=['--no-clean', '--pre'])
```




%prep
%autosetup -n pip-install-1.3.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pip-install -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.5-1
- Package Spec generated