%global _empty_manifest_terminate_build 0
Name: python-dbt-sqlserver
Version: 1.3.1
Release: 1
Summary: A Microsoft SQL Server adapter plugin for dbt
License: MIT
URL: https://github.com/dbt-msft/dbt-sqlserver
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/19/07/4f18c641d53e68a024b8836978f8d33820a4f92769cfc2473886e415555b/dbt-sqlserver-1.3.1.tar.gz
BuildArch: noarch
Requires: python3-dbt-core
Requires: python3-pyodbc
Requires: python3-azure-identity
%description
# dbt-sqlserver
[dbt](https://www.getdbt.com) adapter for Microsoft SQL Server and Azure SQL services.
The adapter supports dbt-core 0.14 or newer and follows the same versioning scheme.
E.g. version 1.1.x of the adapter will be compatible with dbt-core 1.1.x.
## Documentation
We've bundled all documentation on the dbt docs site:
* [Profile setup & authentication](https://docs.getdbt.com/reference/warehouse-profiles/mssql-profile)
* [Adapter-specific configuration](https://docs.getdbt.com/reference/resource-configs/mssql-configs)
Join us on the [dbt Slack](https://getdbt.slack.com/archives/CMRMDDQ9W) to ask questions, get help, or to discuss the project.
## Installation
This adapter requires the Microsoft ODBC driver to be installed:
[Windows](https://docs.microsoft.com/nl-be/sql/connect/odbc/download-odbc-driver-for-sql-server?view=sql-server-ver16#download-for-windows) |
[macOS](https://docs.microsoft.com/nl-be/sql/connect/odbc/linux-mac/install-microsoft-odbc-driver-sql-server-macos?view=sql-server-ver16) |
[Linux](https://docs.microsoft.com/nl-be/sql/connect/odbc/linux-mac/installing-the-microsoft-odbc-driver-for-sql-server?view=sql-server-ver16)
Debian/Ubuntu
Make sure to install the ODBC headers as well as the driver linked above:
```shell
sudo apt-get install -y unixodbc-dev
```
Latest version: 
```shell
pip install -U dbt-sqlserver
```
Latest pre-release: 
```shell
pip install -U --pre dbt-sqlserver
```
## Changelog
See [the changelog](CHANGELOG.md)
## Contributing
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/unit-tests.yml)
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/integration-tests-sqlserver.yml)
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/integration-tests-azure.yml)
This adapter is community-maintained.
You are welcome to contribute by creating issues, opening or reviewing pull requests or helping other users in Slack channel.
If you're unsure how to get started, check out our [contributing guide](CONTRIBUTING.md).
## License
[](https://github.com/dbt-msft/dbt-sqlserver/blob/master/LICENSE)
## Code of Conduct
This project and everyone involved is expected to follow the [dbt Code of Conduct](https://community.getdbt.com/code-of-conduct).
%package -n python3-dbt-sqlserver
Summary: A Microsoft SQL Server adapter plugin for dbt
Provides: python-dbt-sqlserver
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dbt-sqlserver
# dbt-sqlserver
[dbt](https://www.getdbt.com) adapter for Microsoft SQL Server and Azure SQL services.
The adapter supports dbt-core 0.14 or newer and follows the same versioning scheme.
E.g. version 1.1.x of the adapter will be compatible with dbt-core 1.1.x.
## Documentation
We've bundled all documentation on the dbt docs site:
* [Profile setup & authentication](https://docs.getdbt.com/reference/warehouse-profiles/mssql-profile)
* [Adapter-specific configuration](https://docs.getdbt.com/reference/resource-configs/mssql-configs)
Join us on the [dbt Slack](https://getdbt.slack.com/archives/CMRMDDQ9W) to ask questions, get help, or to discuss the project.
## Installation
This adapter requires the Microsoft ODBC driver to be installed:
[Windows](https://docs.microsoft.com/nl-be/sql/connect/odbc/download-odbc-driver-for-sql-server?view=sql-server-ver16#download-for-windows) |
[macOS](https://docs.microsoft.com/nl-be/sql/connect/odbc/linux-mac/install-microsoft-odbc-driver-sql-server-macos?view=sql-server-ver16) |
[Linux](https://docs.microsoft.com/nl-be/sql/connect/odbc/linux-mac/installing-the-microsoft-odbc-driver-for-sql-server?view=sql-server-ver16)
Debian/Ubuntu
Make sure to install the ODBC headers as well as the driver linked above:
```shell
sudo apt-get install -y unixodbc-dev
```
Latest version: 
```shell
pip install -U dbt-sqlserver
```
Latest pre-release: 
```shell
pip install -U --pre dbt-sqlserver
```
## Changelog
See [the changelog](CHANGELOG.md)
## Contributing
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/unit-tests.yml)
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/integration-tests-sqlserver.yml)
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/integration-tests-azure.yml)
This adapter is community-maintained.
You are welcome to contribute by creating issues, opening or reviewing pull requests or helping other users in Slack channel.
If you're unsure how to get started, check out our [contributing guide](CONTRIBUTING.md).
## License
[](https://github.com/dbt-msft/dbt-sqlserver/blob/master/LICENSE)
## Code of Conduct
This project and everyone involved is expected to follow the [dbt Code of Conduct](https://community.getdbt.com/code-of-conduct).
%package help
Summary: Development documents and examples for dbt-sqlserver
Provides: python3-dbt-sqlserver-doc
%description help
# dbt-sqlserver
[dbt](https://www.getdbt.com) adapter for Microsoft SQL Server and Azure SQL services.
The adapter supports dbt-core 0.14 or newer and follows the same versioning scheme.
E.g. version 1.1.x of the adapter will be compatible with dbt-core 1.1.x.
## Documentation
We've bundled all documentation on the dbt docs site:
* [Profile setup & authentication](https://docs.getdbt.com/reference/warehouse-profiles/mssql-profile)
* [Adapter-specific configuration](https://docs.getdbt.com/reference/resource-configs/mssql-configs)
Join us on the [dbt Slack](https://getdbt.slack.com/archives/CMRMDDQ9W) to ask questions, get help, or to discuss the project.
## Installation
This adapter requires the Microsoft ODBC driver to be installed:
[Windows](https://docs.microsoft.com/nl-be/sql/connect/odbc/download-odbc-driver-for-sql-server?view=sql-server-ver16#download-for-windows) |
[macOS](https://docs.microsoft.com/nl-be/sql/connect/odbc/linux-mac/install-microsoft-odbc-driver-sql-server-macos?view=sql-server-ver16) |
[Linux](https://docs.microsoft.com/nl-be/sql/connect/odbc/linux-mac/installing-the-microsoft-odbc-driver-for-sql-server?view=sql-server-ver16)
Debian/Ubuntu
Make sure to install the ODBC headers as well as the driver linked above:
```shell
sudo apt-get install -y unixodbc-dev
```
Latest version: 
```shell
pip install -U dbt-sqlserver
```
Latest pre-release: 
```shell
pip install -U --pre dbt-sqlserver
```
## Changelog
See [the changelog](CHANGELOG.md)
## Contributing
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/unit-tests.yml)
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/integration-tests-sqlserver.yml)
[](https://github.com/dbt-msft/dbt-sqlserver/actions/workflows/integration-tests-azure.yml)
This adapter is community-maintained.
You are welcome to contribute by creating issues, opening or reviewing pull requests or helping other users in Slack channel.
If you're unsure how to get started, check out our [contributing guide](CONTRIBUTING.md).
## License
[](https://github.com/dbt-msft/dbt-sqlserver/blob/master/LICENSE)
## Code of Conduct
This project and everyone involved is expected to follow the [dbt Code of Conduct](https://community.getdbt.com/code-of-conduct).
%prep
%autosetup -n dbt-sqlserver-1.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dbt-sqlserver -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 1.3.1-1
- Package Spec generated