%global _empty_manifest_terminate_build 0
Name: python-dqsegdb2
Version: 1.1.3
Release: 1
Summary: Simplified python interface to DQSEGDB
License: GPL-3.0-or-later
URL: https://pypi.org/project/dqsegdb2/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/df/de/e8d0bb2dd5b81ac01125dfe16bdf4ad18548ac665b106a43c1e981ed8865/dqsegdb2-1.1.3.tar.gz
BuildArch: noarch
Requires: python3-igwn-auth-utils
Requires: python3-ligo-segments
Requires: python3-sphinx
Requires: python3-sphinx-automodapi
Requires: python3-sphinx-immaterial
Requires: python3-flake8
Requires: python3-flake8-bandit
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-requests-mock
%description
# DQSEGDB2
[](http://badge.fury.io/py/dqsegdb2)
[](https://anaconda.org/conda-forge/dqsegdb2/)
[](https://choosealicense.com/licenses/gpl-3.0/)
[](https://zenodo.org/badge/latestdoi/136390328)

[](https://git.ligo.org/duncanmmacleod/dqsegdb2/-/pipelines)

[](https://dqsegdb2.readthedocs.io/en/latest/?badge=latest)
DQSEGDB2 is a simplified Python implementation of the DQSEGDB API as defined in
[LIGO-T1300625](https://dcc.ligo.org/LIGO-T1300625).
This package only provides a query interface for `GET` requests, any users
wishing to make `POST` requests should refer to the official `dqsegdb` Python
client available from .
## Installation
For best results, please install from [conda-forge](https://conda-forge.org/):
```shell
conda install -c conda-forge dqsegdb2
```
On Unix systems, you can also install directly from PyPI:
```shell
pip install dqsegdb2
```
## Basic Usage
```python
from dqsegdb2.query import query_segments
print(query_segments('G1:GEO-SCIENCE:1', 1000000000, 1000001000))
```
%package -n python3-dqsegdb2
Summary: Simplified python interface to DQSEGDB
Provides: python-dqsegdb2
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dqsegdb2
# DQSEGDB2
[](http://badge.fury.io/py/dqsegdb2)
[](https://anaconda.org/conda-forge/dqsegdb2/)
[](https://choosealicense.com/licenses/gpl-3.0/)
[](https://zenodo.org/badge/latestdoi/136390328)

[](https://git.ligo.org/duncanmmacleod/dqsegdb2/-/pipelines)

[](https://dqsegdb2.readthedocs.io/en/latest/?badge=latest)
DQSEGDB2 is a simplified Python implementation of the DQSEGDB API as defined in
[LIGO-T1300625](https://dcc.ligo.org/LIGO-T1300625).
This package only provides a query interface for `GET` requests, any users
wishing to make `POST` requests should refer to the official `dqsegdb` Python
client available from .
## Installation
For best results, please install from [conda-forge](https://conda-forge.org/):
```shell
conda install -c conda-forge dqsegdb2
```
On Unix systems, you can also install directly from PyPI:
```shell
pip install dqsegdb2
```
## Basic Usage
```python
from dqsegdb2.query import query_segments
print(query_segments('G1:GEO-SCIENCE:1', 1000000000, 1000001000))
```
%package help
Summary: Development documents and examples for dqsegdb2
Provides: python3-dqsegdb2-doc
%description help
# DQSEGDB2
[](http://badge.fury.io/py/dqsegdb2)
[](https://anaconda.org/conda-forge/dqsegdb2/)
[](https://choosealicense.com/licenses/gpl-3.0/)
[](https://zenodo.org/badge/latestdoi/136390328)

[](https://git.ligo.org/duncanmmacleod/dqsegdb2/-/pipelines)

[](https://dqsegdb2.readthedocs.io/en/latest/?badge=latest)
DQSEGDB2 is a simplified Python implementation of the DQSEGDB API as defined in
[LIGO-T1300625](https://dcc.ligo.org/LIGO-T1300625).
This package only provides a query interface for `GET` requests, any users
wishing to make `POST` requests should refer to the official `dqsegdb` Python
client available from .
## Installation
For best results, please install from [conda-forge](https://conda-forge.org/):
```shell
conda install -c conda-forge dqsegdb2
```
On Unix systems, you can also install directly from PyPI:
```shell
pip install dqsegdb2
```
## Basic Usage
```python
from dqsegdb2.query import query_segments
print(query_segments('G1:GEO-SCIENCE:1', 1000000000, 1000001000))
```
%prep
%autosetup -n dqsegdb2-1.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dqsegdb2 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Apr 12 2023 Python_Bot - 1.1.3-1
- Package Spec generated