%global _empty_manifest_terminate_build 0
Name:		python-eiffellib
Version:	2.4.1
Release:	1
Summary:	Python library for sending and receiving Eiffel events
License:	Apache License, Version 2.0
URL:		https://github.com/eiffel-community/eiffel-pythonlib
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/48/19/9bbc915faa85e6b575617fa086d66ebb318df9a0e8204a4abfd4631c280e/eiffellib-2.4.1.tar.gz
BuildArch:	noarch

Requires:	python3-jsonschema
Requires:	python3-importlib-metadata
Requires:	python3-pika
Requires:	python3-pytest
Requires:	python3-pytest-cov

%description
Eiffellib solves the problem of publishing Eiffel events and subscribing to events, removing the need of knowing how to connect to a message-broker or how to utilize the protocol it supplies.
With Eiffellib you can start subscribing to and publish valid Eiffel messages quickly and to get a feel for the event protocol.
It is designed to be fast and easy to start using while still being production quality.
Documentation: https://eiffellib.readthedocs.io/en/latest/

%package -n python3-eiffellib
Summary:	Python library for sending and receiving Eiffel events
Provides:	python-eiffellib
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-eiffellib
Eiffellib solves the problem of publishing Eiffel events and subscribing to events, removing the need of knowing how to connect to a message-broker or how to utilize the protocol it supplies.
With Eiffellib you can start subscribing to and publish valid Eiffel messages quickly and to get a feel for the event protocol.
It is designed to be fast and easy to start using while still being production quality.
Documentation: https://eiffellib.readthedocs.io/en/latest/

%package help
Summary:	Development documents and examples for eiffellib
Provides:	python3-eiffellib-doc
%description help
Eiffellib solves the problem of publishing Eiffel events and subscribing to events, removing the need of knowing how to connect to a message-broker or how to utilize the protocol it supplies.
With Eiffellib you can start subscribing to and publish valid Eiffel messages quickly and to get a feel for the event protocol.
It is designed to be fast and easy to start using while still being production quality.
Documentation: https://eiffellib.readthedocs.io/en/latest/

%prep
%autosetup -n eiffellib-2.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-eiffellib -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.1-1
- Package Spec generated