%global _empty_manifest_terminate_build 0
Name:		python-colcon-notification
Version:	0.2.15
Release:	1
Summary:	Extension for colcon to provide status notifications.
License:	Apache License, Version 2.0
URL:		https://colcon.readthedocs.io
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f5/24/d687b179b6a4eaa596f04c868ea093f3d10efe3d9e800d085629568418f9/colcon-notification-0.2.15.tar.gz
BuildArch:	noarch

Requires:	python3-colcon-core
Requires:	python3-notify2
Requires:	python3-pywin32
Requires:	python3-flake8-blind-except
Requires:	python3-flake8-builtins
Requires:	python3-flake8-class-newline
Requires:	python3-flake8-comprehensions
Requires:	python3-flake8-deprecated
Requires:	python3-flake8-docstrings
Requires:	python3-flake8-import-order
Requires:	python3-flake8-quotes
Requires:	python3-flake8
Requires:	python3-pep8-naming
Requires:	python3-pylint
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-scspell3k

%description
An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to provide status notifications.

%package -n python3-colcon-notification
Summary:	Extension for colcon to provide status notifications.
Provides:	python-colcon-notification
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-colcon-notification
An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to provide status notifications.

%package help
Summary:	Development documents and examples for colcon-notification
Provides:	python3-colcon-notification-doc
%description help
An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to provide status notifications.

%prep
%autosetup -n colcon-notification-0.2.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-colcon-notification -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.15-1
- Package Spec generated