%global _empty_manifest_terminate_build 0
Name: python-django-angular
Version: 2.3
Release: 1
Summary: Let Django play well with AngularJS
License: MIT
URL: https://github.com/jrief/django-angular
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/73/77/1ed70db56426976b47482ff020283edf3b37a6f2c6cccd960f452d4e965b/django-angular-2.3.tar.gz
BuildArch: noarch
%description
# django-angular
Let Django play well with AngularJS
[![Build Status](https://travis-ci.org/jrief/django-angular.svg?branch=master)](https://travis-ci.org/jrief/django-angular)
[![PyPI version](https://img.shields.io/pypi/v/django-angular.svg)](https://pypi.python.org/pypi/django-angular)
[![Python versions](https://img.shields.io/pypi/pyversions/django-angular.svg)](https://pypi.python.org/pypi/django-angular)
[![Software license](https://img.shields.io/pypi/l/django-angular.svg)](https://github.com/jrief/django-angular/blob/master/LICENSE-MIT)
[![Twitter Follow](https://img.shields.io/twitter/follow/jacobrief.svg?style=social&label=Jacob+Rief)](https://twitter.com/jacobrief)
## What does it offer?
Add AngularJS directives to Django Forms. This allows to handle client side form validation using
the constraints provided by the server side Form declaration.
For more information, please visit the [demo site](https://django-angular.awesto.com/form_validation/).
### How to run
```
git clone https://github.com/jrief/django-angular.git django-angular.git
cd django-angular.git
docker build -t django-angular.git .
docker run -d -it -p 9002:9002 django-angular.git
```
Open the application at `http://{docker-host's-ip}:9002/`
### Backward Incompatibility
To be compliant with other libraries such as **djangorestframework**, server-side responses on
rejected forms use error code 422, rather than 200. If you use your own form controllers, adopt
them accordingly. The JSON format used to communicate errors downstream has changed slightly.
### New Features
For a smoother transition path, **django-angular** added two directives in version 2.0:
``
``, which can be used to upload form
data to the server. It also populates the error fields, in case the server rejected some data.
``... ``
Similar to the above directive, but rather than validating one single form, it validates a
set of forms using one shared endpoint.
A promise chain has been introduced. Buttons used to submit form data and then proceed with
something else, now can be written as:
``Label ``
## Documentation
Detailed documentation on [ReadTheDocs](http://django-angular.readthedocs.org/en/latest/).
[Demo](http://django-angular.awesto.com/form_validation/) on how to combine Django with Angular's form validation.
Please drop me a line, if and where you use this project.
## Features
* Seamless integration of Django forms with AngularJS controllers.
* Client side form validation for Django forms using AngularJS.
* Let an AngularJS controller call methods in a Django view - kind of Javascript RPCs.
* Manage Django URLs for static controller files.
* Three way data binding to connect AngularJS models with a server side message queue.
* Perform basic CRUD operations.
## Examples
* Implement Filter On Single Page Application using Django & Angular JS https://shriniket.home.blog/2019/09/22/integrate-angular-js-with-django-filter-application/
## License
Copyright © 2019
MIT licensed
%package -n python3-django-angular
Summary: Let Django play well with AngularJS
Provides: python-django-angular
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-angular
# django-angular
Let Django play well with AngularJS
[![Build Status](https://travis-ci.org/jrief/django-angular.svg?branch=master)](https://travis-ci.org/jrief/django-angular)
[![PyPI version](https://img.shields.io/pypi/v/django-angular.svg)](https://pypi.python.org/pypi/django-angular)
[![Python versions](https://img.shields.io/pypi/pyversions/django-angular.svg)](https://pypi.python.org/pypi/django-angular)
[![Software license](https://img.shields.io/pypi/l/django-angular.svg)](https://github.com/jrief/django-angular/blob/master/LICENSE-MIT)
[![Twitter Follow](https://img.shields.io/twitter/follow/jacobrief.svg?style=social&label=Jacob+Rief)](https://twitter.com/jacobrief)
## What does it offer?
Add AngularJS directives to Django Forms. This allows to handle client side form validation using
the constraints provided by the server side Form declaration.
For more information, please visit the [demo site](https://django-angular.awesto.com/form_validation/).
### How to run
```
git clone https://github.com/jrief/django-angular.git django-angular.git
cd django-angular.git
docker build -t django-angular.git .
docker run -d -it -p 9002:9002 django-angular.git
```
Open the application at `http://{docker-host's-ip}:9002/`
### Backward Incompatibility
To be compliant with other libraries such as **djangorestframework**, server-side responses on
rejected forms use error code 422, rather than 200. If you use your own form controllers, adopt
them accordingly. The JSON format used to communicate errors downstream has changed slightly.
### New Features
For a smoother transition path, **django-angular** added two directives in version 2.0:
````, which can be used to upload form
data to the server. It also populates the error fields, in case the server rejected some data.
``... ``
Similar to the above directive, but rather than validating one single form, it validates a
set of forms using one shared endpoint.
A promise chain has been introduced. Buttons used to submit form data and then proceed with
something else, now can be written as:
``Label ``
## Documentation
Detailed documentation on [ReadTheDocs](http://django-angular.readthedocs.org/en/latest/).
[Demo](http://django-angular.awesto.com/form_validation/) on how to combine Django with Angular's form validation.
Please drop me a line, if and where you use this project.
## Features
* Seamless integration of Django forms with AngularJS controllers.
* Client side form validation for Django forms using AngularJS.
* Let an AngularJS controller call methods in a Django view - kind of Javascript RPCs.
* Manage Django URLs for static controller files.
* Three way data binding to connect AngularJS models with a server side message queue.
* Perform basic CRUD operations.
## Examples
* Implement Filter On Single Page Application using Django & Angular JS https://shriniket.home.blog/2019/09/22/integrate-angular-js-with-django-filter-application/
## License
Copyright © 2019
MIT licensed
%package help
Summary: Development documents and examples for django-angular
Provides: python3-django-angular-doc
%description help
# django-angular
Let Django play well with AngularJS
[![Build Status](https://travis-ci.org/jrief/django-angular.svg?branch=master)](https://travis-ci.org/jrief/django-angular)
[![PyPI version](https://img.shields.io/pypi/v/django-angular.svg)](https://pypi.python.org/pypi/django-angular)
[![Python versions](https://img.shields.io/pypi/pyversions/django-angular.svg)](https://pypi.python.org/pypi/django-angular)
[![Software license](https://img.shields.io/pypi/l/django-angular.svg)](https://github.com/jrief/django-angular/blob/master/LICENSE-MIT)
[![Twitter Follow](https://img.shields.io/twitter/follow/jacobrief.svg?style=social&label=Jacob+Rief)](https://twitter.com/jacobrief)
## What does it offer?
Add AngularJS directives to Django Forms. This allows to handle client side form validation using
the constraints provided by the server side Form declaration.
For more information, please visit the [demo site](https://django-angular.awesto.com/form_validation/).
### How to run
```
git clone https://github.com/jrief/django-angular.git django-angular.git
cd django-angular.git
docker build -t django-angular.git .
docker run -d -it -p 9002:9002 django-angular.git
```
Open the application at `http://{docker-host's-ip}:9002/`
### Backward Incompatibility
To be compliant with other libraries such as **djangorestframework**, server-side responses on
rejected forms use error code 422, rather than 200. If you use your own form controllers, adopt
them accordingly. The JSON format used to communicate errors downstream has changed slightly.
### New Features
For a smoother transition path, **django-angular** added two directives in version 2.0:
````, which can be used to upload form
data to the server. It also populates the error fields, in case the server rejected some data.
``... ``
Similar to the above directive, but rather than validating one single form, it validates a
set of forms using one shared endpoint.
A promise chain has been introduced. Buttons used to submit form data and then proceed with
something else, now can be written as:
``Label ``
## Documentation
Detailed documentation on [ReadTheDocs](http://django-angular.readthedocs.org/en/latest/).
[Demo](http://django-angular.awesto.com/form_validation/) on how to combine Django with Angular's form validation.
Please drop me a line, if and where you use this project.
## Features
* Seamless integration of Django forms with AngularJS controllers.
* Client side form validation for Django forms using AngularJS.
* Let an AngularJS controller call methods in a Django view - kind of Javascript RPCs.
* Manage Django URLs for static controller files.
* Three way data binding to connect AngularJS models with a server side message queue.
* Perform basic CRUD operations.
## Examples
* Implement Filter On Single Page Application using Django & Angular JS https://shriniket.home.blog/2019/09/22/integrate-angular-js-with-django-filter-application/
## License
Copyright © 2019
MIT licensed
%prep
%autosetup -n django-angular-2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-angular -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 2.3-1
- Package Spec generated