%global _empty_manifest_terminate_build 0
Name:		python-nbsphinx
Version:	0.9.1
Release:	1
Summary:	Jupyter Notebook Tools for Sphinx
License:	MIT
URL:		https://nbsphinx.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f0/70/008f1d1d4c2b9b51918d5c3bad1f5ff51a17a0d258d7a2c5f67b90bcb0f7/nbsphinx-0.9.1.tar.gz
BuildArch:	noarch

Requires:	python3-docutils
Requires:	python3-jinja2
Requires:	python3-nbconvert
Requires:	python3-traitlets
Requires:	python3-nbformat
Requires:	python3-sphinx

%description
``nbsphinx`` is a Sphinx_ extension that provides a source parser for
``*.ipynb`` files.
Custom Sphinx directives are used to show `Jupyter Notebook`_ code cells (and of
course their results) in both HTML and LaTeX output.
Un-evaluated notebooks -- i.e. notebooks without stored output cells -- will be
automatically executed during the Sphinx build process.
Quick Start:
    #. Install ``nbsphinx``
    #. Edit your ``conf.py`` and add ``'nbsphinx'`` to ``extensions``.
    #. Edit your ``index.rst`` and add the names of your ``*.ipynb`` files
       to the ``toctree``.
    #. Run Sphinx!
Online documentation (and example of use):
    https://nbsphinx.readthedocs.io/
Source code repository (and issue tracker):
    https://github.com/spatialaudio/nbsphinx/
License:
    MIT -- see the file ``LICENSE`` for details.

%package -n python3-nbsphinx
Summary:	Jupyter Notebook Tools for Sphinx
Provides:	python-nbsphinx
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-nbsphinx
``nbsphinx`` is a Sphinx_ extension that provides a source parser for
``*.ipynb`` files.
Custom Sphinx directives are used to show `Jupyter Notebook`_ code cells (and of
course their results) in both HTML and LaTeX output.
Un-evaluated notebooks -- i.e. notebooks without stored output cells -- will be
automatically executed during the Sphinx build process.
Quick Start:
    #. Install ``nbsphinx``
    #. Edit your ``conf.py`` and add ``'nbsphinx'`` to ``extensions``.
    #. Edit your ``index.rst`` and add the names of your ``*.ipynb`` files
       to the ``toctree``.
    #. Run Sphinx!
Online documentation (and example of use):
    https://nbsphinx.readthedocs.io/
Source code repository (and issue tracker):
    https://github.com/spatialaudio/nbsphinx/
License:
    MIT -- see the file ``LICENSE`` for details.

%package help
Summary:	Development documents and examples for nbsphinx
Provides:	python3-nbsphinx-doc
%description help
``nbsphinx`` is a Sphinx_ extension that provides a source parser for
``*.ipynb`` files.
Custom Sphinx directives are used to show `Jupyter Notebook`_ code cells (and of
course their results) in both HTML and LaTeX output.
Un-evaluated notebooks -- i.e. notebooks without stored output cells -- will be
automatically executed during the Sphinx build process.
Quick Start:
    #. Install ``nbsphinx``
    #. Edit your ``conf.py`` and add ``'nbsphinx'`` to ``extensions``.
    #. Edit your ``index.rst`` and add the names of your ``*.ipynb`` files
       to the ``toctree``.
    #. Run Sphinx!
Online documentation (and example of use):
    https://nbsphinx.readthedocs.io/
Source code repository (and issue tracker):
    https://github.com/spatialaudio/nbsphinx/
License:
    MIT -- see the file ``LICENSE`` for details.

%prep
%autosetup -n nbsphinx-0.9.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-nbsphinx -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.1-1
- Package Spec generated