%global _empty_manifest_terminate_build 0
Name: python-pep8-naming
Version: 0.13.3
Release: 1
Summary: Check PEP-8 naming conventions, plugin for flake8
License: Expat license
URL: https://github.com/PyCQA/pep8-naming
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5b/c0/0db8b2867395a9a137e86af8bdf5a566e41d9c6453e509cd3042419ae29e/pep8-naming-0.13.3.tar.gz
BuildArch: noarch
Requires: python3-flake8
%description
Check your code against `PEP 8 `_
naming conventions.
This module provides a plugin for ``flake8``, the Python code checker.
(It replaces the plugin ``flint-naming`` for the ``flint`` checker.)
%package -n python3-pep8-naming
Summary: Check PEP-8 naming conventions, plugin for flake8
Provides: python-pep8-naming
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pep8-naming
Check your code against `PEP 8 `_
naming conventions.
This module provides a plugin for ``flake8``, the Python code checker.
(It replaces the plugin ``flint-naming`` for the ``flint`` checker.)
%package help
Summary: Development documents and examples for pep8-naming
Provides: python3-pep8-naming-doc
%description help
Check your code against `PEP 8 `_
naming conventions.
This module provides a plugin for ``flake8``, the Python code checker.
(It replaces the plugin ``flint-naming`` for the ``flint`` checker.)
%prep
%autosetup -n pep8-naming-0.13.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pep8-naming -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.13.3-1
- Package Spec generated