%global _empty_manifest_terminate_build 0
Name:		python-tenacity
Version:	8.2.2
Release:	1
Summary:	Retry code until it succeeds
License:	Apache 2.0
URL:		https://github.com/jd/tenacity
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d3/f0/6ccd8854f4421ce1f227caf3421d9be2979aa046939268c9300030c0d250/tenacity-8.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-reno
Requires:	python3-sphinx
Requires:	python3-tornado

%description
Tenacity is a general-purpose retrying library to simplify the task of adding retry behavior to just about anything.


%package -n python3-tenacity
Summary:	Retry code until it succeeds
Provides:	python-tenacity
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tenacity
Tenacity is a general-purpose retrying library to simplify the task of adding retry behavior to just about anything.


%package help
Summary:	Development documents and examples for tenacity
Provides:	python3-tenacity-doc
%description help
Tenacity is a general-purpose retrying library to simplify the task of adding retry behavior to just about anything.


%prep
%autosetup -n tenacity-8.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tenacity -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 8.2.2-1
- Package Spec generated