%global _empty_manifest_terminate_build 0
Name:		python-Trololio
Version:	1.0
Release:	1
Summary:	Trollius and asyncio compatibility library
License:	MIT
URL:		http://github.com/ThinkChaos/Trololio/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b1/c1/b16948c621daeb905649bbb1b3d04ffd0bdcdd557909e95748ca191fb3e8/Trololio-1.0.zip
BuildArch:	noarch


%description
####################################################
Trololio: Trollius and asyncio compatibility library
####################################################

Trololio provides a compatibility layer for Trollius and asyncio (aka Tulip).
It addresses the differences listed in `Trollius and Tulip
<http://trollius.readthedocs.org/asyncio.html>`_:

* Allows the use of Trollius' syntax with asyncio.
* Provides missing objects and aliases for the others.
* Synchronizes debug environnement variables.

*****
Links
*****

* `Trololio documentation <http://trololio.readthedocs.org/>`_
* `Trollius documentation <http://trollius.readthedocs.org/>`_
* `asyncio documentation <https://docs.python.org/3/library/asyncio.html>`_

%package -n python3-Trololio
Summary:	Trollius and asyncio compatibility library
Provides:	python-Trololio
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Trololio
####################################################
Trololio: Trollius and asyncio compatibility library
####################################################

Trololio provides a compatibility layer for Trollius and asyncio (aka Tulip).
It addresses the differences listed in `Trollius and Tulip
<http://trollius.readthedocs.org/asyncio.html>`_:

* Allows the use of Trollius' syntax with asyncio.
* Provides missing objects and aliases for the others.
* Synchronizes debug environnement variables.

*****
Links
*****

* `Trololio documentation <http://trololio.readthedocs.org/>`_
* `Trollius documentation <http://trollius.readthedocs.org/>`_
* `asyncio documentation <https://docs.python.org/3/library/asyncio.html>`_

%package help
Summary:	Development documents and examples for Trololio
Provides:	python3-Trololio-doc
%description help
####################################################
Trololio: Trollius and asyncio compatibility library
####################################################

Trololio provides a compatibility layer for Trollius and asyncio (aka Tulip).
It addresses the differences listed in `Trollius and Tulip
<http://trollius.readthedocs.org/asyncio.html>`_:

* Allows the use of Trollius' syntax with asyncio.
* Provides missing objects and aliases for the others.
* Synchronizes debug environnement variables.

*****
Links
*****

* `Trololio documentation <http://trololio.readthedocs.org/>`_
* `Trollius documentation <http://trollius.readthedocs.org/>`_
* `asyncio documentation <https://docs.python.org/3/library/asyncio.html>`_

%prep
%autosetup -n Trololio-1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Trololio -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0-1
- Package Spec generated