%global _empty_manifest_terminate_build 0
Name:		python-google-cloud-firestore
Version:	2.11.0
Release:	1
Summary:	Google Cloud Firestore API client library
License:	Apache 2.0
URL:		https://github.com/googleapis/python-firestore
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3b/d3/f6efe8eea6ae1ab58e3f0ef32e0949c18f2fd4e7da29b50bda73a836f8c0/google-cloud-firestore-2.11.0.tar.gz
BuildArch:	noarch

Requires:	python3-google-api-core[grpc]
Requires:	python3-google-cloud-core
Requires:	python3-proto-plus
Requires:	python3-protobuf
Requires:	python3-proto-plus

%description
|stable| |pypi| |versions|
`Cloud Firestore API`_: is a fully-managed NoSQL document database for mobile, web, and server development from Firebase and Google Cloud Platform.  It's backed by a multi-region replicated database that ensures once data is committed, it's durable even in the face of unexpected disasters. Not only that, but despite being a distributed database, it's also strongly consistent and offers seamless integration with other Firebase and Google Cloud Platform products, including Google Cloud Functions.
- `Client Library Documentation`_
- `Product Documentation`_

%package -n python3-google-cloud-firestore
Summary:	Google Cloud Firestore API client library
Provides:	python-google-cloud-firestore
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-google-cloud-firestore
|stable| |pypi| |versions|
`Cloud Firestore API`_: is a fully-managed NoSQL document database for mobile, web, and server development from Firebase and Google Cloud Platform.  It's backed by a multi-region replicated database that ensures once data is committed, it's durable even in the face of unexpected disasters. Not only that, but despite being a distributed database, it's also strongly consistent and offers seamless integration with other Firebase and Google Cloud Platform products, including Google Cloud Functions.
- `Client Library Documentation`_
- `Product Documentation`_

%package help
Summary:	Development documents and examples for google-cloud-firestore
Provides:	python3-google-cloud-firestore-doc
%description help
|stable| |pypi| |versions|
`Cloud Firestore API`_: is a fully-managed NoSQL document database for mobile, web, and server development from Firebase and Google Cloud Platform.  It's backed by a multi-region replicated database that ensures once data is committed, it's durable even in the face of unexpected disasters. Not only that, but despite being a distributed database, it's also strongly consistent and offers seamless integration with other Firebase and Google Cloud Platform products, including Google Cloud Functions.
- `Client Library Documentation`_
- `Product Documentation`_

%prep
%autosetup -n google-cloud-firestore-2.11.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-google-cloud-firestore -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 2.11.0-1
- Package Spec generated