%global _empty_manifest_terminate_build 0
Name:		python-celery-batches
Version:	0.7
Release:	1
Summary:	Experimental task class that buffers messages and processes them as a list.
License:	BSD
URL:		https://github.com/clokep/celery-batches
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/21/9d/175ff4909bfc66237a97937adee70ab31cc3d6987599c2ef007f9a851ee2/celery-batches-0.7.tar.gz
BuildArch:	noarch

Requires:	python3-celery

%description
Celery Batches provides a ``Task`` class that allows processing of multiple
Celery task calls together as a list. The buffer of tasks calls is flushed on a
timer and based on the number of queued tasks.
Some potential use-cases for batching of task calls include:
* De-duplicating tasks.
* Accumlating / only handling the latest task with similar arguments.
* Bulk inserting / updating of data.
* Tasks with expensive setup that can run across a range of arguments.

%package -n python3-celery-batches
Summary:	Experimental task class that buffers messages and processes them as a list.
Provides:	python-celery-batches
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-celery-batches
Celery Batches provides a ``Task`` class that allows processing of multiple
Celery task calls together as a list. The buffer of tasks calls is flushed on a
timer and based on the number of queued tasks.
Some potential use-cases for batching of task calls include:
* De-duplicating tasks.
* Accumlating / only handling the latest task with similar arguments.
* Bulk inserting / updating of data.
* Tasks with expensive setup that can run across a range of arguments.

%package help
Summary:	Development documents and examples for celery-batches
Provides:	python3-celery-batches-doc
%description help
Celery Batches provides a ``Task`` class that allows processing of multiple
Celery task calls together as a list. The buffer of tasks calls is flushed on a
timer and based on the number of queued tasks.
Some potential use-cases for batching of task calls include:
* De-duplicating tasks.
* Accumlating / only handling the latest task with similar arguments.
* Bulk inserting / updating of data.
* Tasks with expensive setup that can run across a range of arguments.

%prep
%autosetup -n celery-batches-0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-celery-batches -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7-1
- Package Spec generated