%global _empty_manifest_terminate_build 0
Name: python-fab-classic
Version: 1.19.2
Release: 1
Summary: fab-classic is a simple, Pythonic tool for remote execution and deployment.
License: BSD License
URL: https://github.com/ploxiln/fab-classic
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ca/a2/7305910f51e36f7bc86addb170bd4eebd0157c6985a649bf2f4d4bc62cac/fab-classic-1.19.2.tar.gz
BuildArch: noarch
Requires: python3-paramiko-ng
Requires: python3-six
%description
fab-classic is `on PyPI `_,
so you can ``pip install fab-classic``
Be sure to ``pip uninstall fabric`` first if you happen to have it installed,
because *fab-classic* uses the same import name "fabric" and entrypoint (tool)
name "fab".
Starting with version 1.16, *fab-classic* depends on
`paramiko-ng `_ instead of
`paramiko `_. Both of those packages
are imported with the name ``paramiko``, and unfortunately that means that you
should make sure you uninstall *paramiko* before *paramiko-ng* is installed,
or you will get strange issues (even if things seem to work at first).
Starting with version 1.18, you can switch back to depending on the package
named *paramiko* by setting the environment variable ``PARAMIKO_REPLACE=1``
while installing *fab-classic*::
PARAMIKO_REPLACE=1 pip install --no-binary fab-classic fab-classic==1.18.0
(*paramiko-ng* also supports ``PARAMIKO_REPLACE``,
see `paramiko-ng#installation `_)
%package -n python3-fab-classic
Summary: fab-classic is a simple, Pythonic tool for remote execution and deployment.
Provides: python-fab-classic
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fab-classic
fab-classic is `on PyPI `_,
so you can ``pip install fab-classic``
Be sure to ``pip uninstall fabric`` first if you happen to have it installed,
because *fab-classic* uses the same import name "fabric" and entrypoint (tool)
name "fab".
Starting with version 1.16, *fab-classic* depends on
`paramiko-ng `_ instead of
`paramiko `_. Both of those packages
are imported with the name ``paramiko``, and unfortunately that means that you
should make sure you uninstall *paramiko* before *paramiko-ng* is installed,
or you will get strange issues (even if things seem to work at first).
Starting with version 1.18, you can switch back to depending on the package
named *paramiko* by setting the environment variable ``PARAMIKO_REPLACE=1``
while installing *fab-classic*::
PARAMIKO_REPLACE=1 pip install --no-binary fab-classic fab-classic==1.18.0
(*paramiko-ng* also supports ``PARAMIKO_REPLACE``,
see `paramiko-ng#installation `_)
%package help
Summary: Development documents and examples for fab-classic
Provides: python3-fab-classic-doc
%description help
fab-classic is `on PyPI `_,
so you can ``pip install fab-classic``
Be sure to ``pip uninstall fabric`` first if you happen to have it installed,
because *fab-classic* uses the same import name "fabric" and entrypoint (tool)
name "fab".
Starting with version 1.16, *fab-classic* depends on
`paramiko-ng `_ instead of
`paramiko `_. Both of those packages
are imported with the name ``paramiko``, and unfortunately that means that you
should make sure you uninstall *paramiko* before *paramiko-ng* is installed,
or you will get strange issues (even if things seem to work at first).
Starting with version 1.18, you can switch back to depending on the package
named *paramiko* by setting the environment variable ``PARAMIKO_REPLACE=1``
while installing *fab-classic*::
PARAMIKO_REPLACE=1 pip install --no-binary fab-classic fab-classic==1.18.0
(*paramiko-ng* also supports ``PARAMIKO_REPLACE``,
see `paramiko-ng#installation `_)
%prep
%autosetup -n fab-classic-1.19.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fab-classic -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 1.19.2-1
- Package Spec generated