%global _empty_manifest_terminate_build 0
Name:		python-west
Version:	1.0.0
Release:	1
Summary:	Zephyr RTOS Project meta-tool
License:	Apache Software License
URL:		https://github.com/zephyrproject-rtos/west
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/29/86/4283e43a287dd7e7146176dec4c6fb24c2aceac3628c964ef204a9005b58/west-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-colorama
Requires:	python3-PyYAML
Requires:	python3-pykwalify
Requires:	python3-setuptools
Requires:	python3-packaging

%description
Using pip::
  pip3 install west
(Use ``pip3 uninstall west`` to uninstall it.)

%package -n python3-west
Summary:	Zephyr RTOS Project meta-tool
Provides:	python-west
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-west
Using pip::
  pip3 install west
(Use ``pip3 uninstall west`` to uninstall it.)

%package help
Summary:	Development documents and examples for west
Provides:	python3-west-doc
%description help
Using pip::
  pip3 install west
(Use ``pip3 uninstall west`` to uninstall it.)

%prep
%autosetup -n west-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-west -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated