%global _empty_manifest_terminate_build 0
Name:		python-git-remote-codecommit
Version:	1.16
Release:	1
Summary:	Git remote prefix to simplify pushing to and pulling from CodeCommit.
License:	Apache License 2.0
URL:		https://github.com/awslabs/git-remote-codecommit
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2c/d2/bdf76a090f4b0afe254b03333bbe7df2a26818417cbb6f646dc1888104b7/git-remote-codecommit-1.16.tar.gz
BuildArch:	noarch


%description
This package provides a simple method for pushing and pulling from `AWS
CodeCommit <https://aws.amazon.com/codecommit/>`__. This package extends `git
<https://git-scm.com/>`__ to support repository URLs prefixed with
**codecommit://**. For example, if using IAM...
  % cat ~/.aws/config
  [profile demo-profile]
  region = us-east-2
  output = json
  % cat ~/.aws/credentials
  [demo-profile]
  aws_access_key_id = AKIAIOSFODNN7EXAMPLE
  aws_secret_access_key = wJalrXUtnFEMI/K7MDENG/bPxRfiCYEXAMPLEKEY
  % git clone codecommit://demo-profile@MyRepositoryName
The *git-remote-codecommit* package works on Python versions:
* 3.6.x
* 3.7.x
* 3.8.x
* 3.9.x

%package -n python3-git-remote-codecommit
Summary:	Git remote prefix to simplify pushing to and pulling from CodeCommit.
Provides:	python-git-remote-codecommit
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-git-remote-codecommit
This package provides a simple method for pushing and pulling from `AWS
CodeCommit <https://aws.amazon.com/codecommit/>`__. This package extends `git
<https://git-scm.com/>`__ to support repository URLs prefixed with
**codecommit://**. For example, if using IAM...
  % cat ~/.aws/config
  [profile demo-profile]
  region = us-east-2
  output = json
  % cat ~/.aws/credentials
  [demo-profile]
  aws_access_key_id = AKIAIOSFODNN7EXAMPLE
  aws_secret_access_key = wJalrXUtnFEMI/K7MDENG/bPxRfiCYEXAMPLEKEY
  % git clone codecommit://demo-profile@MyRepositoryName
The *git-remote-codecommit* package works on Python versions:
* 3.6.x
* 3.7.x
* 3.8.x
* 3.9.x

%package help
Summary:	Development documents and examples for git-remote-codecommit
Provides:	python3-git-remote-codecommit-doc
%description help
This package provides a simple method for pushing and pulling from `AWS
CodeCommit <https://aws.amazon.com/codecommit/>`__. This package extends `git
<https://git-scm.com/>`__ to support repository URLs prefixed with
**codecommit://**. For example, if using IAM...
  % cat ~/.aws/config
  [profile demo-profile]
  region = us-east-2
  output = json
  % cat ~/.aws/credentials
  [demo-profile]
  aws_access_key_id = AKIAIOSFODNN7EXAMPLE
  aws_secret_access_key = wJalrXUtnFEMI/K7MDENG/bPxRfiCYEXAMPLEKEY
  % git clone codecommit://demo-profile@MyRepositoryName
The *git-remote-codecommit* package works on Python versions:
* 3.6.x
* 3.7.x
* 3.8.x
* 3.9.x

%prep
%autosetup -n git-remote-codecommit-1.16

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-git-remote-codecommit -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.16-1
- Package Spec generated