%global _empty_manifest_terminate_build 0
Name: python-paramiko-ng
Version: 2.8.10
Release: 1
Summary: SSH2 protocol library
License: LGPL
URL: https://github.com/ploxiln/paramiko-ng/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ff/93/c2fd71c1392710de0e23c2f481b3aa9d3f6f5c482aea85d82e761c225c3d/paramiko-ng-2.8.10.tar.gz
BuildArch: noarch
Requires: python3-bcrypt
Requires: python3-cryptography
Requires: python3-PyNaCl
Requires: python3-gssapi
Requires: python3-pyasn1
%description
*paramiko-ng* is a fork of `paramiko `_
for more active maintenance.
For changes in releases of this fork, see https://github.com/ploxiln/paramiko-ng/releases
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
Required packages:
Cryptography
The import name is still just ``paramiko``. Make sure the original *paramiko*
is not installed before installing *paramiko-ng* - otherwise pip may report
success even though *paramiko-ng* was not correctly installed.
To install the development version::
pip install -e git+https://github.com/ploxiln/paramiko-ng/#egg=paramiko-ng
You can also install under the original "paramiko" pip-package-name,
in order to satisfy requirements for other packages::
PARAMIKO_REPLACE=1 pip install https://github.com/ploxiln/paramiko-ng/archive/2.7.4.tar.gz#egg=paramiko
Replace "2.7.4" with the desired recent version, or for latest development version do::
PARAMIKO_REPLACE=1 pip install git+https://github.com/ploxiln/paramiko-ng/#egg=paramiko
%package -n python3-paramiko-ng
Summary: SSH2 protocol library
Provides: python-paramiko-ng
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-paramiko-ng
*paramiko-ng* is a fork of `paramiko `_
for more active maintenance.
For changes in releases of this fork, see https://github.com/ploxiln/paramiko-ng/releases
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
Required packages:
Cryptography
The import name is still just ``paramiko``. Make sure the original *paramiko*
is not installed before installing *paramiko-ng* - otherwise pip may report
success even though *paramiko-ng* was not correctly installed.
To install the development version::
pip install -e git+https://github.com/ploxiln/paramiko-ng/#egg=paramiko-ng
You can also install under the original "paramiko" pip-package-name,
in order to satisfy requirements for other packages::
PARAMIKO_REPLACE=1 pip install https://github.com/ploxiln/paramiko-ng/archive/2.7.4.tar.gz#egg=paramiko
Replace "2.7.4" with the desired recent version, or for latest development version do::
PARAMIKO_REPLACE=1 pip install git+https://github.com/ploxiln/paramiko-ng/#egg=paramiko
%package help
Summary: Development documents and examples for paramiko-ng
Provides: python3-paramiko-ng-doc
%description help
*paramiko-ng* is a fork of `paramiko `_
for more active maintenance.
For changes in releases of this fork, see https://github.com/ploxiln/paramiko-ng/releases
This is a library for making SSH2 connections (client or server).
Emphasis is on using SSH2 as an alternative to SSL for making secure
connections between python scripts. All major ciphers and hash methods
are supported. SFTP client and server mode are both supported too.
Required packages:
Cryptography
The import name is still just ``paramiko``. Make sure the original *paramiko*
is not installed before installing *paramiko-ng* - otherwise pip may report
success even though *paramiko-ng* was not correctly installed.
To install the development version::
pip install -e git+https://github.com/ploxiln/paramiko-ng/#egg=paramiko-ng
You can also install under the original "paramiko" pip-package-name,
in order to satisfy requirements for other packages::
PARAMIKO_REPLACE=1 pip install https://github.com/ploxiln/paramiko-ng/archive/2.7.4.tar.gz#egg=paramiko
Replace "2.7.4" with the desired recent version, or for latest development version do::
PARAMIKO_REPLACE=1 pip install git+https://github.com/ploxiln/paramiko-ng/#egg=paramiko
%prep
%autosetup -n paramiko-ng-2.8.10
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-paramiko-ng -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 2.8.10-1
- Package Spec generated