%global _empty_manifest_terminate_build 0
Name: python-wemake-python-styleguide
Version: 0.17.0
Release: 1
Summary: The strictest and most opinionated python linter ever
License: MIT
URL: https://wemake-python-styleguide.rtfd.io
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5d/8a/6ce717f3956ca6d99fc85347166d17d82f57a923c2d7f6f2ffcdd1248903/wemake-python-styleguide-0.17.0.tar.gz
BuildArch: noarch
Requires: python3-flake8
Requires: python3-attrs
Requires: python3-typing_extensions
Requires: python3-astor
Requires: python3-pygments
Requires: python3-importlib-metadata
Requires: python3-flake8-commas
Requires: python3-flake8-quotes
Requires: python3-flake8-comprehensions
Requires: python3-flake8-docstrings
Requires: python3-flake8-string-format
Requires: python3-flake8-bugbear
Requires: python3-flake8-debugger
Requires: python3-flake8-isort
Requires: python3-flake8-eradicate
Requires: python3-flake8-bandit
Requires: python3-flake8-broken-line
Requires: python3-flake8-rst-docstrings
Requires: python3-pep8-naming
Requires: python3-darglint
%description
Welcome to the strictest and most opinionated Python linter ever.
`wemake-python-styleguide` is actually a [flake8](http://flake8.pycqa.org/en/latest/)
plugin with [some other plugins](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/violations/index.html#external-plugins) as dependencies.
## Quickstart
```bash
pip install wemake-python-styleguide
```
You will also need to create a `setup.cfg` file with the [configuration](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/configuration.html).
[Try it online](https://wps.orsinium.dev)!
We highly recommend to also use:
- [flakehell](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/flakehell.html) for easy integration into a **legacy** codebase
- [nitpick](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/nitpick.html) for sharing and validating configuration across multiple projects
## Running
```bash
flake8 your_module.py
```
This app is still just good old `flake8`!
And it won't change your existing workflow.
See ["Usage" section](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/setup.html)
in the docs for examples and integrations.
We also support [GitHub Actions](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/github-actions.html) as first class-citizens.
[Try it out](https://github.com/marketplace/actions/wemake-python-styleguide)!
## Strict is the new cool
Strict linting offers the following benefits to developers and companies:
1. Ensures consistency - no matter who works on it, the end product will always be the same dependable code
2. Helps avoid potential bugs - strict rules make sure that you don't make common mistakes
3. Efficient code reviews - each piece of code has a similar familiar style and syntax. If it passes all the checks, there's little left to review!
4. Fewer code revisions - strict linting ensures that you don't have to re-write the codebase again and again
5. Reduce code redundancy - Sometimes we write complex code as we are thinking in a certain way about a problem. The linter offers suggestions that can help simplify the code and eliminate redundant statements
## What we are about
The ultimate goal of this project is
to make all people write **exactly** the same `Python` code.
| | flake8 | pylint | black | mypy | wemake-python-styleguide |
|----------------------------|--------|--------|-------|------|--------------------------|
| Formats code? | ❌ | ❌ | ✅ | ❌ | ❌ |
| Finds style issues? | 🤔 | ✅ | 🤔 | ❌ | ✅ |
| Finds bugs? | 🤔 | ✅ | ❌ | ✅ | ✅ |
| Finds complex code? | ❌ | 🤔 | ❌ | ❌ | ✅ |
| Has a lot of strict rules? | ❌ | 🤔 | ❌ | ❌ | ✅ |
| Has a lot of plugins? | ✅ | ❌ | ❌ | 🤔 | ✅ |
We have several primary objectives:
0. Enforce `python3.6+` usage
1. Significantly reduce the complexity of your code and make it more maintainable
2. Enforce "There should be one -- and preferably only one -- obvious way to do it" rule to coding and naming styles
3. Protect developers from possible errors and enforce best practices
You can find all error codes and plugins [in the docs](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/violations/index.html).
## What we are not
We are *not* planning to do the following things:
0. Assume or check types, use `mypy` together with our linter
1. [Reformat code](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/auto-formatters.html), since we believe that developers should do that
2. Check for `SyntaxError` or logical bugs, write tests instead
3. Appeal to everyone. But, you can [switch off](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/setup.html#ignoring-violations) any rules that you don't like
## Supporting us :tada:
We in [wemake.services](https://wemake.services) make
all our tools open-source by default, so the community can benefit from them.
If you use our tools and they make your life easier and brings business value,
you can return us a favor by supporting the work we do.
[](https://opencollective.com/wemake-python-styleguide)
[](https://opencollective.com/wemake-python-styleguide)
[](https://opencollective.com/wemake-python-styleguide)
## Show your style :sunglasses:
If you use our linter - it means that your code is awesome.
You can be proud of it!
And you should share your accomplishment with others
by including a badge in your `README` file. It looks like this:
[](https://github.com/wemake-services/wemake-python-styleguide)
### Markdown
```md
[](https://github.com/wemake-services/wemake-python-styleguide)
```
### Restructured text
```rst
```
## Contributing
We **warmly welcome** all contributions!
[](https://github.com/wemake-services/wemake-python-styleguide/graphs/contributors)
See ["Contributing"](https://wemake-python-styleguide.rtfd.io/en/latest/pages/api/index.html#contributing) section in the documentation if you want to contribute.
You can start with [issues that need some help](https://github.com/wemake-services/wemake-python-styleguide/issues?q=is%3Aissue+is%3Aopen+label%3A%22help+wanted%22)
right now.
%package -n python3-wemake-python-styleguide
Summary: The strictest and most opinionated python linter ever
Provides: python-wemake-python-styleguide
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wemake-python-styleguide
Welcome to the strictest and most opinionated Python linter ever.
`wemake-python-styleguide` is actually a [flake8](http://flake8.pycqa.org/en/latest/)
plugin with [some other plugins](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/violations/index.html#external-plugins) as dependencies.
## Quickstart
```bash
pip install wemake-python-styleguide
```
You will also need to create a `setup.cfg` file with the [configuration](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/configuration.html).
[Try it online](https://wps.orsinium.dev)!
We highly recommend to also use:
- [flakehell](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/flakehell.html) for easy integration into a **legacy** codebase
- [nitpick](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/nitpick.html) for sharing and validating configuration across multiple projects
## Running
```bash
flake8 your_module.py
```
This app is still just good old `flake8`!
And it won't change your existing workflow.
See ["Usage" section](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/setup.html)
in the docs for examples and integrations.
We also support [GitHub Actions](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/github-actions.html) as first class-citizens.
[Try it out](https://github.com/marketplace/actions/wemake-python-styleguide)!
## Strict is the new cool
Strict linting offers the following benefits to developers and companies:
1. Ensures consistency - no matter who works on it, the end product will always be the same dependable code
2. Helps avoid potential bugs - strict rules make sure that you don't make common mistakes
3. Efficient code reviews - each piece of code has a similar familiar style and syntax. If it passes all the checks, there's little left to review!
4. Fewer code revisions - strict linting ensures that you don't have to re-write the codebase again and again
5. Reduce code redundancy - Sometimes we write complex code as we are thinking in a certain way about a problem. The linter offers suggestions that can help simplify the code and eliminate redundant statements
## What we are about
The ultimate goal of this project is
to make all people write **exactly** the same `Python` code.
| | flake8 | pylint | black | mypy | wemake-python-styleguide |
|----------------------------|--------|--------|-------|------|--------------------------|
| Formats code? | ❌ | ❌ | ✅ | ❌ | ❌ |
| Finds style issues? | 🤔 | ✅ | 🤔 | ❌ | ✅ |
| Finds bugs? | 🤔 | ✅ | ❌ | ✅ | ✅ |
| Finds complex code? | ❌ | 🤔 | ❌ | ❌ | ✅ |
| Has a lot of strict rules? | ❌ | 🤔 | ❌ | ❌ | ✅ |
| Has a lot of plugins? | ✅ | ❌ | ❌ | 🤔 | ✅ |
We have several primary objectives:
0. Enforce `python3.6+` usage
1. Significantly reduce the complexity of your code and make it more maintainable
2. Enforce "There should be one -- and preferably only one -- obvious way to do it" rule to coding and naming styles
3. Protect developers from possible errors and enforce best practices
You can find all error codes and plugins [in the docs](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/violations/index.html).
## What we are not
We are *not* planning to do the following things:
0. Assume or check types, use `mypy` together with our linter
1. [Reformat code](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/auto-formatters.html), since we believe that developers should do that
2. Check for `SyntaxError` or logical bugs, write tests instead
3. Appeal to everyone. But, you can [switch off](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/setup.html#ignoring-violations) any rules that you don't like
## Supporting us :tada:
We in [wemake.services](https://wemake.services) make
all our tools open-source by default, so the community can benefit from them.
If you use our tools and they make your life easier and brings business value,
you can return us a favor by supporting the work we do.
[](https://opencollective.com/wemake-python-styleguide)
[](https://opencollective.com/wemake-python-styleguide)
[](https://opencollective.com/wemake-python-styleguide)
## Show your style :sunglasses:
If you use our linter - it means that your code is awesome.
You can be proud of it!
And you should share your accomplishment with others
by including a badge in your `README` file. It looks like this:
[](https://github.com/wemake-services/wemake-python-styleguide)
### Markdown
```md
[](https://github.com/wemake-services/wemake-python-styleguide)
```
### Restructured text
```rst
```
## Contributing
We **warmly welcome** all contributions!
[](https://github.com/wemake-services/wemake-python-styleguide/graphs/contributors)
See ["Contributing"](https://wemake-python-styleguide.rtfd.io/en/latest/pages/api/index.html#contributing) section in the documentation if you want to contribute.
You can start with [issues that need some help](https://github.com/wemake-services/wemake-python-styleguide/issues?q=is%3Aissue+is%3Aopen+label%3A%22help+wanted%22)
right now.
%package help
Summary: Development documents and examples for wemake-python-styleguide
Provides: python3-wemake-python-styleguide-doc
%description help
Welcome to the strictest and most opinionated Python linter ever.
`wemake-python-styleguide` is actually a [flake8](http://flake8.pycqa.org/en/latest/)
plugin with [some other plugins](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/violations/index.html#external-plugins) as dependencies.
## Quickstart
```bash
pip install wemake-python-styleguide
```
You will also need to create a `setup.cfg` file with the [configuration](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/configuration.html).
[Try it online](https://wps.orsinium.dev)!
We highly recommend to also use:
- [flakehell](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/flakehell.html) for easy integration into a **legacy** codebase
- [nitpick](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/nitpick.html) for sharing and validating configuration across multiple projects
## Running
```bash
flake8 your_module.py
```
This app is still just good old `flake8`!
And it won't change your existing workflow.
See ["Usage" section](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/setup.html)
in the docs for examples and integrations.
We also support [GitHub Actions](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/github-actions.html) as first class-citizens.
[Try it out](https://github.com/marketplace/actions/wemake-python-styleguide)!
## Strict is the new cool
Strict linting offers the following benefits to developers and companies:
1. Ensures consistency - no matter who works on it, the end product will always be the same dependable code
2. Helps avoid potential bugs - strict rules make sure that you don't make common mistakes
3. Efficient code reviews - each piece of code has a similar familiar style and syntax. If it passes all the checks, there's little left to review!
4. Fewer code revisions - strict linting ensures that you don't have to re-write the codebase again and again
5. Reduce code redundancy - Sometimes we write complex code as we are thinking in a certain way about a problem. The linter offers suggestions that can help simplify the code and eliminate redundant statements
## What we are about
The ultimate goal of this project is
to make all people write **exactly** the same `Python` code.
| | flake8 | pylint | black | mypy | wemake-python-styleguide |
|----------------------------|--------|--------|-------|------|--------------------------|
| Formats code? | ❌ | ❌ | ✅ | ❌ | ❌ |
| Finds style issues? | 🤔 | ✅ | 🤔 | ❌ | ✅ |
| Finds bugs? | 🤔 | ✅ | ❌ | ✅ | ✅ |
| Finds complex code? | ❌ | 🤔 | ❌ | ❌ | ✅ |
| Has a lot of strict rules? | ❌ | 🤔 | ❌ | ❌ | ✅ |
| Has a lot of plugins? | ✅ | ❌ | ❌ | 🤔 | ✅ |
We have several primary objectives:
0. Enforce `python3.6+` usage
1. Significantly reduce the complexity of your code and make it more maintainable
2. Enforce "There should be one -- and preferably only one -- obvious way to do it" rule to coding and naming styles
3. Protect developers from possible errors and enforce best practices
You can find all error codes and plugins [in the docs](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/violations/index.html).
## What we are not
We are *not* planning to do the following things:
0. Assume or check types, use `mypy` together with our linter
1. [Reformat code](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/integrations/auto-formatters.html), since we believe that developers should do that
2. Check for `SyntaxError` or logical bugs, write tests instead
3. Appeal to everyone. But, you can [switch off](https://wemake-python-styleguide.rtfd.io/en/latest/pages/usage/setup.html#ignoring-violations) any rules that you don't like
## Supporting us :tada:
We in [wemake.services](https://wemake.services) make
all our tools open-source by default, so the community can benefit from them.
If you use our tools and they make your life easier and brings business value,
you can return us a favor by supporting the work we do.
[](https://opencollective.com/wemake-python-styleguide)
[](https://opencollective.com/wemake-python-styleguide)
[](https://opencollective.com/wemake-python-styleguide)
## Show your style :sunglasses:
If you use our linter - it means that your code is awesome.
You can be proud of it!
And you should share your accomplishment with others
by including a badge in your `README` file. It looks like this:
[](https://github.com/wemake-services/wemake-python-styleguide)
### Markdown
```md
[](https://github.com/wemake-services/wemake-python-styleguide)
```
### Restructured text
```rst
```
## Contributing
We **warmly welcome** all contributions!
[](https://github.com/wemake-services/wemake-python-styleguide/graphs/contributors)
See ["Contributing"](https://wemake-python-styleguide.rtfd.io/en/latest/pages/api/index.html#contributing) section in the documentation if you want to contribute.
You can start with [issues that need some help](https://github.com/wemake-services/wemake-python-styleguide/issues?q=is%3Aissue+is%3Aopen+label%3A%22help+wanted%22)
right now.
%prep
%autosetup -n wemake-python-styleguide-0.17.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wemake-python-styleguide -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.17.0-1
- Package Spec generated